aboutsummaryrefslogtreecommitdiff
path: root/audio/soundtracker
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-22 09:40:13 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-11-22 09:40:13 +0000
commitc919cf310d15d171bd01938941f949932de5b918 (patch)
tree5a349bb1f6baf5261f6a262ea1deff7b71b3c578 /audio/soundtracker
parent5a1cb5a9adc659bc74c8e770397d2b5c15f813d2 (diff)
downloadports-c919cf310d15d171bd01938941f949932de5b918.tar.gz
ports-c919cf310d15d171bd01938941f949932de5b918.zip
Notes
Diffstat (limited to 'audio/soundtracker')
-rw-r--r--audio/soundtracker/Makefile35
-rw-r--r--audio/soundtracker/pkg-descr10
2 files changed, 22 insertions, 23 deletions
diff --git a/audio/soundtracker/Makefile b/audio/soundtracker/Makefile
index a9f9fcb76e7d..7f483016d355 100644
--- a/audio/soundtracker/Makefile
+++ b/audio/soundtracker/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: soundtracker
-# Date created: 28 November 1999
-# Whom: kzentner
-#
+# Created by: Kristopher Zentner <kzentner@u.washington.edu>
# $FreeBSD$
-#
PORTNAME= soundtracker
PORTVERSION= 0.6.8
@@ -15,27 +11,27 @@ MASTER_SITE_SUBDIR= v${PORTVERSION:R}
MAINTAINER= ports@FreeBSD.org
COMMENT= Mod player/tracking tool which supports XM and MOD formats
-LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile
+LICENSE= GPLv2
+
+LIB_DEPENDS= sndfile:${PORTSDIR}/audio/libsndfile
-USE_GNOME= esound gdkpixbuf gnomehack
GNU_CONFIGURE= yes
+USE_GNOME= esound gdkpixbuf gnomehack
+
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-OPTIONS_DEFINE= GNOME1 I386_ASM JACK SDL NLS
-GNOME1_DESC= use GNOME 1.x (enables envelope editors)
-I386_ASM_DESC= i386 asm optimizations (potentially unstable)
+OPTIONS_DEFINE= GNOME1 JACK SDL NLS
+OPTIONS_DEFINE_i386= ASM
+GNOME1_DESC= Use GNOME 1.x (enables envelope editing)
+ASM_DESC= Use optimized assembly (potentially unstable)
-DESKTOP_ENTRIES="SoundTracker" \
- "Compose music" \
- "soundtracker.xpm" \
- "soundtracker" \
- "" \
- false
+DESKTOP_ENTRIES="SoundTracker" "Compose music" "soundtracker.xpm" \
+ "soundtracker" "Audio;Player;Recorder;" false
.include <bsd.port.pre.mk>
-.if ${ARCH} == "i386" && ${PORT_OPTIONS:MI386_ASM}
+.if ${PORT_OPTIONS:MASM}
CONFIGURE_ARGS+= --enable-asm
.endif
@@ -47,7 +43,7 @@ CONFIGURE_ARGS+= --disable-gnome
.endif
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else
CONFIGURE_ARGS+= --disable-jack
.endif
@@ -82,6 +78,7 @@ pre-build:
.endif
post-install:
- ${INSTALL_DATA} ${WRKSRC}/sharp.xpm ${PREFIX}/share/pixmaps/soundtracker.xpm
+ ${INSTALL_DATA} ${WRKSRC}/sharp.xpm \
+ ${PREFIX}/share/pixmaps/soundtracker.xpm
.include <bsd.port.post.mk>
diff --git a/audio/soundtracker/pkg-descr b/audio/soundtracker/pkg-descr
index cef43c081c5f..09ba7eedecad 100644
--- a/audio/soundtracker/pkg-descr
+++ b/audio/soundtracker/pkg-descr
@@ -1,6 +1,8 @@
-Soundtracker is a gtk based module tracker and editor for X written by
-Michael Krause. It currently supports XM and MOD formats only and it
-allows you to save your files to XM or WAV format. Soundtracker supports XI
-instruments and WAV samples.
+SoundTracker is a pattern-oriented music editor (similar to the classic DOS
+program FastTracker and the Amiga legend ProTracker). Samples can be lined
+up on tracks and patterns which are then arranged to a song.
+
+Supported module formats are XM and MOD; the player code is the one from
+OpenCP. A basic sample recorder and editor is also included.
WWW: http://www.soundtracker.org/