aboutsummaryrefslogtreecommitdiff
path: root/audio/sox
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-09-24 12:12:26 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-09-24 12:12:26 +0000
commitcb88912bd907eee9d99645d4f58e388575203cac (patch)
tree9d79ae01fb1f96bff8cea4198d97b161b5bd4d19 /audio/sox
parentb6fbc3d224418a8706811c5f67a188a2180f4621 (diff)
downloadports-cb88912bd907eee9d99645d4f58e388575203cac.tar.gz
ports-cb88912bd907eee9d99645d4f58e388575203cac.zip
Notes
Diffstat (limited to 'audio/sox')
-rw-r--r--audio/sox/Makefile32
-rw-r--r--audio/sox/distinfo6
-rw-r--r--audio/sox/files/patch-sox.c14
-rw-r--r--audio/sox/pkg-plist70
4 files changed, 105 insertions, 17 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index 9c78b37d5e7d..a76a0f203193 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= sox
-PORTVERSION= 14.0.1
-PORTREVISION= 1
+PORTVERSION= 14.1.0
CATEGORIES= audio
MASTER_SITES= SF
@@ -16,16 +15,23 @@ COMMENT= SOund eXchange - universal sound sample translator
CONFLICTS= play-[0-9]*
-MAN1= sox.1
+MAN1= sox.1 soxi.1
MAN3= libsox.3
-MAN7= soxexam.7 soxformat.7 soxeffect.7
+MAN7= soxformat.7 soxeffect.7
MLINKS= sox.1 play.1 sox.1 rec.1
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
USE_AUTOTOOLS= libltdl
+USE_GNOME= pkgconfig
# src/Makefile uses ${RM} but never sets it
MAKE_ENV+= RM="rm -f"
+.if defined(PACKAGE_BUILDING)
+_LAME= off
+.else
+_LAME= on
+.endif
+
OPTIONS= AO "Enable libao output" on \
AMRNB "AMR Speech Codec (Narrowband)" off \
AMRWB "AMR Speech Codec (Wideband)" off \
@@ -33,17 +39,20 @@ OPTIONS= AO "Enable libao output" on \
FLAC "Enable flac en/decoding with libflac" on \
GSM "Use libgsm from ports (else use bundled lib)" on \
LADSPA "Audio plugin support" off \
- LAME "Enable mp3 encoding with LAME" on \
+ LAME "Enable mp3 encoding with LAME" ${_LAME} \
MAD "Enable mp3 decoding with MAD" on \
SAMPLERATE "Enable libsamplerate" on \
SNDFILE "Enable libsndfile" on \
- VORBIS "Enable Ogg Vorbis support" on
+ VORBIS "Enable Ogg Vorbis support" on \
+ WAVPACK "Enable Wavpack support" off
.include <bsd.port.pre.mk>
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+LIB_DEPENDS+= png.5:${PORTSDIR}/graphics/png
.if !defined(WITH_LAME) && !defined(WITH_MAD)
PLIST_SUB+= PLIST_MP3="@comment "
@@ -154,9 +163,20 @@ LIB_DEPENDS+= samplerate.1:${PORTSDIR}/audio/libsamplerate
CONFIGURE_ARGS+= --without-samplerate
.endif
+.if defined(WITH_WAVPACK)
+CONFIGURE_ARGS+= --with-wavpack
+LIB_DEPENDS+= wavpack.1:${PORTSDIR}/audio/wavpack
+PLIST_SUB+= PLIST_WAVPACK=""
+.else
+CONFIGURE_ARGS+= --without-wavpack
+PLIST_SUB+= PLIST_WAVPACK="@comment "
+.endif
+
# Tell configure that libgsm's headers are in $LOCALDIR/include
post-patch:
@${REINPLACE_CMD} -Ee 's![[:<:]]gsm/gsm.h!gsm.h!' ${WRKSRC}/configure \
${WRKSRC}/src/gsm.c ${WRKSRC}/src/wav.c
+ @${REINPLACE_CMD} -Ee 's!ffmpeg/avformat.h!libavformat/avformat.h!' \
+ ${WRKSRC}/configure ${WRKSRC}/src/ffmpeg.c
.include <bsd.port.post.mk>
diff --git a/audio/sox/distinfo b/audio/sox/distinfo
index ca1b6b738715..47c183e31d82 100644
--- a/audio/sox/distinfo
+++ b/audio/sox/distinfo
@@ -1,3 +1,3 @@
-MD5 (sox-14.0.1.tar.gz) = 6c95af60b20b9655531bf3162c0be937
-SHA256 (sox-14.0.1.tar.gz) = 52398a49bef64aa6e06b158cb59b3e1790fa1bf94262b896688bcfdcf539ca73
-SIZE (sox-14.0.1.tar.gz) = 859538
+MD5 (sox-14.1.0.tar.gz) = b8e2cb3d615d3830347a0948dd8b74a8
+SHA256 (sox-14.1.0.tar.gz) = 319cf07ee06fcbfbcaced7307e23ca567739c278f76bc143a9258a9a23e42101
+SIZE (sox-14.1.0.tar.gz) = 912057
diff --git a/audio/sox/files/patch-sox.c b/audio/sox/files/patch-sox.c
new file mode 100644
index 000000000000..db6e1842903e
--- /dev/null
+++ b/audio/sox/files/patch-sox.c
@@ -0,0 +1,14 @@
+Fix badly-imbalanced parens.
+
+diff -burp sox-14.1.0/src/sox.c sox-14.1.0-dan/src/sox.c
+--- src/sox.c 2008-07-28 15:04:36.000000000 -0500
++++ src/sox.c 2008-07-30 11:36:41.046073378 -0500
+@@ -1716,7 +1716,7 @@ int main(int argc, char **argv)
+ combine_method = sox_concatenate;
+
+ /* Make sure we got at least the required # of input filenames */
+- if (input_count < is_serial(combine_method ? 1 : 2))
++ if (input_count < (is_serial(combine_method) ? 1 : 2))
+ usage("Not enough input filenames specified");
+
+ /* Check for misplaced input/output-specific options */
diff --git a/audio/sox/pkg-plist b/audio/sox/pkg-plist
index ab5e2c40ea8d..e08073b5413b 100644
--- a/audio/sox/pkg-plist
+++ b/audio/sox/pkg-plist
@@ -2,6 +2,7 @@
bin/play
bin/rec
bin/sox
+bin/soxi
include/sox.h
include/soxstdint.h
lib/libsfx.a
@@ -40,14 +41,14 @@ lib/sox/libsox_fmt_au.a
lib/sox/libsox_fmt_au.la
lib/sox/libsox_fmt_au.so
lib/sox/libsox_fmt_au.so.0
-lib/sox/libsox_fmt_auto.a
-lib/sox/libsox_fmt_auto.la
-lib/sox/libsox_fmt_auto.so
-lib/sox/libsox_fmt_auto.so.0
lib/sox/libsox_fmt_avr.a
lib/sox/libsox_fmt_avr.la
lib/sox/libsox_fmt_avr.so
lib/sox/libsox_fmt_avr.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_caf.so.0
lib/sox/libsox_fmt_cdr.a
lib/sox/libsox_fmt_cdr.la
lib/sox/libsox_fmt_cdr.so
@@ -64,6 +65,18 @@ lib/sox/libsox_fmt_dvms.a
lib/sox/libsox_fmt_dvms.la
lib/sox/libsox_fmt_dvms.so
lib/sox/libsox_fmt_dvms.so.0
+lib/sox/libsox_fmt_f4.a
+lib/sox/libsox_fmt_f4.la
+lib/sox/libsox_fmt_f4.so
+lib/sox/libsox_fmt_f4.so.0
+lib/sox/libsox_fmt_f8.a
+lib/sox/libsox_fmt_f8.la
+lib/sox/libsox_fmt_f8.so
+lib/sox/libsox_fmt_f8.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_fap.so.0
%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.a
%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.la
%%PLIST_FFMPEG%%lib/sox/libsox_fmt_ffmpeg.so
@@ -80,6 +93,10 @@ lib/sox/libsox_fmt_hcom.a
lib/sox/libsox_fmt_hcom.la
lib/sox/libsox_fmt_hcom.so
lib/sox/libsox_fmt_hcom.so.0
+lib/sox/libsox_fmt_htk.a
+lib/sox/libsox_fmt_htk.la
+lib/sox/libsox_fmt_htk.so
+lib/sox/libsox_fmt_htk.so.0
lib/sox/libsox_fmt_ima.a
lib/sox/libsox_fmt_ima.la
lib/sox/libsox_fmt_ima.so
@@ -96,6 +113,14 @@ lib/sox/libsox_fmt_lu.a
lib/sox/libsox_fmt_lu.la
lib/sox/libsox_fmt_lu.so
lib/sox/libsox_fmt_lu.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat4.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_mat5.so.0
lib/sox/libsox_fmt_maud.a
lib/sox/libsox_fmt_maud.la
lib/sox/libsox_fmt_maud.so
@@ -112,10 +137,18 @@ lib/sox/libsox_fmt_oss.a
lib/sox/libsox_fmt_oss.la
lib/sox/libsox_fmt_oss.so
lib/sox/libsox_fmt_oss.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_paf.so.0
lib/sox/libsox_fmt_prc.a
lib/sox/libsox_fmt_prc.la
lib/sox/libsox_fmt_prc.so
lib/sox/libsox_fmt_prc.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_pvf.so.0
lib/sox/libsox_fmt_raw.a
lib/sox/libsox_fmt_raw.la
lib/sox/libsox_fmt_raw.so
@@ -136,6 +169,10 @@ lib/sox/libsox_fmt_s4.a
lib/sox/libsox_fmt_s4.la
lib/sox/libsox_fmt_s4.so
lib/sox/libsox_fmt_s4.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sd2.so.0
lib/sox/libsox_fmt_sf.a
lib/sox/libsox_fmt_sf.la
lib/sox/libsox_fmt_sf.so
@@ -148,10 +185,14 @@ lib/sox/libsox_fmt_smp.so.0
%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.la
%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.so
%%PLIST_SNDFILE%%lib/sox/libsox_fmt_sndfile.so.0
-lib/sox/libsox_fmt_sndrtool.a
-lib/sox/libsox_fmt_sndrtool.la
-lib/sox/libsox_fmt_sndrtool.so
-lib/sox/libsox_fmt_sndrtool.so.0
+lib/sox/libsox_fmt_sounder.a
+lib/sox/libsox_fmt_sounder.la
+lib/sox/libsox_fmt_sounder.so
+lib/sox/libsox_fmt_sounder.so.0
+lib/sox/libsox_fmt_soundtool.a
+lib/sox/libsox_fmt_soundtool.la
+lib/sox/libsox_fmt_soundtool.so
+lib/sox/libsox_fmt_soundtool.so.0
lib/sox/libsox_fmt_sphere.a
lib/sox/libsox_fmt_sphere.la
lib/sox/libsox_fmt_sphere.so
@@ -196,10 +237,18 @@ lib/sox/libsox_fmt_vox.a
lib/sox/libsox_fmt_vox.la
lib/sox/libsox_fmt_vox.so
lib/sox/libsox_fmt_vox.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_w64.so.0
lib/sox/libsox_fmt_wav.a
lib/sox/libsox_fmt_wav.la
lib/sox/libsox_fmt_wav.so
lib/sox/libsox_fmt_wav.so.0
+%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.a
+%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.la
+%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.so
+%%PLIST_WAVPACK%%lib/sox/libsox_fmt_wavpack.so.0
lib/sox/libsox_fmt_wve.a
lib/sox/libsox_fmt_wve.la
lib/sox/libsox_fmt_wve.so
@@ -208,4 +257,9 @@ lib/sox/libsox_fmt_xa.a
lib/sox/libsox_fmt_xa.la
lib/sox/libsox_fmt_xa.so
lib/sox/libsox_fmt_xa.so.0
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.a
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.la
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.so
+%%PLIST_SNDFILE%%lib/sox/libsox_fmt_xi.so.0
@dirrm lib/sox
+libdata/pkgconfig/sox.pc