aboutsummaryrefslogtreecommitdiff
path: root/audio/sox
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>2007-07-07 13:38:15 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>2007-07-07 13:38:15 +0000
commite1757b682edfa0433d7d6be39142666299a812c5 (patch)
treee93bd865a48328e71803f96c3ee0418a2debdd6a /audio/sox
parent6f117f782e005d9bbf92c7ca60259157642346e9 (diff)
downloadports-e1757b682edfa0433d7d6be39142666299a812c5.tar.gz
ports-e1757b682edfa0433d7d6be39142666299a812c5.zip
Notes
Diffstat (limited to 'audio/sox')
-rw-r--r--audio/sox/Makefile65
-rw-r--r--audio/sox/distinfo6
-rw-r--r--audio/sox/pkg-plist11
3 files changed, 58 insertions, 24 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index ae9167f33960..5bb1ad235265 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= sox
-PORTVERSION= 12.18.2
+PORTVERSION= 13.0.0
CATEGORIES= audio
MASTER_SITES= SF
@@ -15,57 +15,80 @@ COMMENT= SOund eXchange - universal sound sample translator
CONFLICTS= play-[0-9]*
-MAN1= sox.1 play.1 soxexam.1
-MLINKS= play.1 rec.1 sox.1 soxmix.1
+MAN1= sox.1
+MAN3= libst.3
+MAN7= soxexam.7
+MLINKS= sox.1 play.1 sox.1 rec.1
GNU_CONFIGURE= yes
-MAKE_ENV= PLAY_SUPPORT=1
+USE_LDCONFIG= yes
+# src/Makefile uses ${RM} but never sets it
+MAKE_ENV+= RM="rm -f"
-OPTIONS= LAME "Enable mp3 encoding with LAME" off \
- MAD "Enable mp3 decoding with MAD" off \
- VORBIS "Enable Ogg Vorbis support" off \
- GSM "Enable GSM audio codec support" off
-
-PLIST_FILES= bin/sox bin/soxmix bin/rec bin/play
-CONFIGURE_ARGS= --disable-alsa-dsp --disable-sun-audio
+OPTIONS= FLAC "Enable libflac" on \
+ GSM "Use libgsm from ports (else use bundled lib)" on \
+ LAME "Enable mp3 encoding with LAME" on \
+ MAD "Enable mp3 decoding with MAD" on \
+ SNDFILE "Enable libsndfile" on \
+ VORBIS "Enable Ogg Vorbis support" on
.include <bsd.port.pre.mk>
-.if defined(WITH_VORBIS) || defined(WITH_LAME) || defined(WITH_MAD) || defined(WITH_GSM)
+.if defined(WITH_FLAC) || defined(WITH_GSM) || defined(WITH_LAME) || \
+ defined(WITH_MAD) || defined(WITH_SNDFILE) || defined(WITH_VORBIS)
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.endif
.if defined(WITH_VORBIS)
-CONFIGURE_ARGS+= --enable-ogg-vorbis
+CONFIGURE_ARGS+= --with-ogg-vorbis
LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
.else
-CONFIGURE_ARGS+= --disable-ogg-vorbis
+CONFIGURE_ARGS+= --without-ogg-vorbis
+# Above configure flag does not exist, so workaround with the below line
+CONFIGURE_ENV+= ac_cv_header_vorbis_codec_h=no
+.endif
+
+.if defined(WITH_SNDFILE)
+CONFIGURE_ARGS+= --with-sndfile
+LIB_DEPENDS+= sndfile.1:${PORTSDIR}/audio/libsndfile
+.else
+CONFIGURE_ARGS+= --without-sndfile
.endif
.if defined(WITH_LAME)
-CONFIGURE_ARGS+= --enable-lame
+CONFIGURE_ARGS+= --with-lame
LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
.else
-CONFIGURE_ARGS+= --disable-lame
+CONFIGURE_ARGS+= --without-lame
+.endif
+
+.if defined(WITH_FLAC)
+CONFIGURE_ARGS+= --with-flac
+LIB_DEPENDS+= FLAC.7:${PORTSDIR}/audio/flac
+.else
+CONFIGURE_ARGS+= --without-flac
.endif
.if defined(WITH_MAD)
-CONFIGURE_ARGS+= --enable-mad
+CONFIGURE_ARGS+= --with-mad
LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
.else
-CONFIGURE_ARGS+= --disable-mad
+CONFIGURE_ARGS+= --without-mad
.endif
.if defined(WITH_GSM)
-CONFIGURE_ARGS+= --enable-external-gsm
+CONFIGURE_ARGS+= --with-external-gsm
LIB_DEPENDS+= gsm.1:${PORTSDIR}/audio/gsm
.else
-CONFIGURE_ARGS+= --disable-external-gsm --disable-gsm
+CONFIGURE_ARGS+= --without-external-gsm
+# Above configure flag does not exist, so workaround with the below line
+CONFIGURE_ENV+= ac_cv_header_gsm_h=no
.endif
+# Tell configure that libgsm's headers are in $LOCALDIR/include
post-patch:
- @${REINPLACE_CMD} -Ee 's![[:<:]]gsm/!!' ${WRKSRC}/configure ${WRKSRC}/src/Makefile.gcc \
+ @${REINPLACE_CMD} -Ee 's![[:<:]]gsm/gsm.h!gsm.h!' ${WRKSRC}/configure \
${WRKSRC}/src/gsm.c ${WRKSRC}/src/wav.c
.include <bsd.port.post.mk>
diff --git a/audio/sox/distinfo b/audio/sox/distinfo
index 0634b0ed25da..b6b90833c46a 100644
--- a/audio/sox/distinfo
+++ b/audio/sox/distinfo
@@ -1,3 +1,3 @@
-MD5 (sox-12.18.2.tar.gz) = ba25e512a6c824d6e56d76767a18af99
-SHA256 (sox-12.18.2.tar.gz) = 832bf98c95580af879fe51311c861ba7c57f07a5791628108ef29a027f0271ff
-SIZE (sox-12.18.2.tar.gz) = 486814
+MD5 (sox-13.0.0.tar.gz) = 0243d62895caee558b5294d5b78cfbcb
+SHA256 (sox-13.0.0.tar.gz) = c66c52cfa42fe126592563c3d8974007a9858bd35d2c1136389a721eeebb9f8e
+SIZE (sox-13.0.0.tar.gz) = 725259
diff --git a/audio/sox/pkg-plist b/audio/sox/pkg-plist
new file mode 100644
index 000000000000..ed905f5d9c00
--- /dev/null
+++ b/audio/sox/pkg-plist
@@ -0,0 +1,11 @@
+@comment $FreeBSD$
+bin/libst-config
+bin/play
+bin/rec
+bin/sox
+include/st.h
+include/ststdint.h
+lib/libst.a
+lib/libst.la
+lib/libst.so
+lib/libst.so.0