aboutsummaryrefslogtreecommitdiff
path: root/audio/speex-devel/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-05-08 04:04:17 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-05-08 04:04:17 +0000
commit3dcb251e1af7d9d3cae04191d8a8f9ce2464e842 (patch)
treeed9fa50a0cfdd16af3a95e4a6f1564a6caa96897 /audio/speex-devel/Makefile
parent2b3295fca6fe0fb4f741c4c4eec929af410ec283 (diff)
downloadports-3dcb251e1af7d9d3cae04191d8a8f9ce2464e842.tar.gz
ports-3dcb251e1af7d9d3cae04191d8a8f9ce2464e842.zip
Notes
Diffstat (limited to 'audio/speex-devel/Makefile')
-rw-r--r--audio/speex-devel/Makefile19
1 files changed, 14 insertions, 5 deletions
diff --git a/audio/speex-devel/Makefile b/audio/speex-devel/Makefile
index e50b6b5e170e..45fab4958d2a 100644
--- a/audio/speex-devel/Makefile
+++ b/audio/speex-devel/Makefile
@@ -7,10 +7,10 @@
#
PORTNAME= speex
-PORTVERSION= 1.1.7
+PORTVERSION= 1.1.8
PORTEPOCH= 1
CATEGORIES= audio
-MASTER_SITES= http://www.speex.org/download/
+MASTER_SITES= http://downloads.xiph.org/releases/speex/
PKGNAMESUFFIX= -devel
MAINTAINER= ahze@FreeBSD.org
@@ -23,9 +23,9 @@ CONFLICTS= speex-1.0*
USE_GNOME= gnomehack
USE_GETOPT_LONG= yes
USE_REINPLACE= yes
-USE_LIBTOOL_VER= 15
-LIBTOOLFLAGS= --disable-ltlibs --release-ignore
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+USE_INC_LIBTOOL_VER= 15
+USE_GCC= 3.4+
+CONFIGURE_TARGET= --build=${ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
INSTALLS_SHLIB= yes
@@ -34,6 +34,15 @@ MAN1= speexdec.1 speexenc.1
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|doc win32|win32|g ; \