aboutsummaryrefslogtreecommitdiff
path: root/audio/spek/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-26 02:04:40 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2013-10-26 02:04:40 +0000
commit05187cc4549cfbd24512180433ea9fe77c084fca (patch)
tree34c482051e3761def17dd6fd6ae65860bc771c5e /audio/spek/Makefile
parent2e89fe22c3952690fd55f1ed649518eecabe677d (diff)
downloadports-05187cc4549cfbd24512180433ea9fe77c084fca.tar.gz
ports-05187cc4549cfbd24512180433ea9fe77c084fca.zip
Notes
Diffstat (limited to 'audio/spek/Makefile')
-rw-r--r--audio/spek/Makefile23
1 files changed, 14 insertions, 9 deletions
diff --git a/audio/spek/Makefile b/audio/spek/Makefile
index a4b2776da23c..99c2daef63c8 100644
--- a/audio/spek/Makefile
+++ b/audio/spek/Makefile
@@ -14,12 +14,8 @@ LICENSE= GPLv3
LIB_DEPENDS= libavcodec.so:${PORTSDIR}/multimedia/ffmpeg
-MAN1= spek.1
-
USE_XZ= yes
-NO_STAGE= yes
-USE_GCC= 4.7+
-USES= gettext gmake
+USES= gmake pkgconfig desktop-file-utils
USE_GNOME= desktopfileutils intltool
USE_WX= 2.8+
WX_UNICODE= yes
@@ -27,10 +23,19 @@ WX_CONF_ARGS= absolute
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-post-install:
- -@update-desktop-database
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 1000054
+USE_GCC= 4.7+
+.endif
post-patch:
- @${REINPLACE_CMD} -e "s,^itlocaledir =.*$$,itlocaledir = ${PREFIX}/share/locale,g" ${WRKSRC}/po/Makefile.in.in
+ @${REINPLACE_CMD} -e "s,^itlocaledir =.*$$,itlocaledir = ${PREFIX}/share/locale,g" \
+ ${WRKSRC}/po/Makefile.in.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>