aboutsummaryrefslogtreecommitdiff
path: root/audio/sphinx3/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2008-03-22 20:38:18 +0000
committerPav Lucistnik <pav@FreeBSD.org>2008-03-22 20:38:18 +0000
commit3acf65bd2b675b5a6949de41216a40b3f31b1630 (patch)
tree4079b7f39a586bded9b225175cef9b673dba896c /audio/sphinx3/Makefile
parentce5c5cae595bb150043ce59ccc9f7c454e89b89c (diff)
Notes
Diffstat (limited to 'audio/sphinx3/Makefile')
-rw-r--r--audio/sphinx3/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/sphinx3/Makefile b/audio/sphinx3/Makefile
new file mode 100644
index 000000000000..ff42b39f30ce
--- /dev/null
+++ b/audio/sphinx3/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: sphinx3
+# Date created: 4 Jan 2008
+# Whom: Richard Neese
+#
+# $FreeBSD$
+#
+
+PORTNAME= sphinx3
+PORTVERSION= 0.7
+CATEGORIES= audio accessibility
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cmusphinx
+
+MAINTAINER= r.neese@gmail.com
+COMMENT= Speech recognition system
+
+LIB_DEPENDS= sphinxfe.0:${PORTSDIR}/audio/sphinxbase
+
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS=libtool:15
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/sphinxbase" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAKE_ENV= MKDIR="${MKDIR}" \
+ OSVERSION=${OSVERSION} \
+ CXX="${CXX}"
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|(libdir)/pkgconfig|(prefix)/libdata/pkgconfig|' ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>