aboutsummaryrefslogtreecommitdiff
path: root/audio/sphinx3
diff options
context:
space:
mode:
authorEitan Adler <eadler@FreeBSD.org>2012-12-14 17:09:21 +0000
committerEitan Adler <eadler@FreeBSD.org>2012-12-14 17:09:21 +0000
commitdf57a0e76fc5727d0e2cec0fc7d1c3f12bb3e26e (patch)
treeea562e20e69d836de3f65cdae639822a5e9e3785 /audio/sphinx3
parentd26530b7136cdbbc743cb41cba488928a2fb490e (diff)
downloadports-df57a0e76fc5727d0e2cec0fc7d1c3f12bb3e26e.tar.gz
ports-df57a0e76fc5727d0e2cec0fc7d1c3f12bb3e26e.zip
Notes
Diffstat (limited to 'audio/sphinx3')
-rw-r--r--audio/sphinx3/Makefile9
-rw-r--r--audio/sphinx3/distinfo4
-rw-r--r--audio/sphinx3/files/patch-src_libs3decoder_libsearch_vithist.c11
3 files changed, 18 insertions, 6 deletions
diff --git a/audio/sphinx3/Makefile b/audio/sphinx3/Makefile
index 731ae81be14e..e75442c0d7b7 100644
--- a/audio/sphinx3/Makefile
+++ b/audio/sphinx3/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= sphinx3
-PORTVERSION= 0.7
+PORTVERSION= 0.8
CATEGORIES= audio accessibility
MASTER_SITES= SF/cmusphinx/${PORTNAME}/${PORTVERSION}
@@ -11,13 +11,14 @@ COMMENT= Speech recognition system
LIB_DEPENDS= sphinxbase:${PORTSDIR}/audio/sphinxbase
-BROKEN= does not compile
-
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_AUTOTOOLS=libtool
+USE_CSTD= gnu99
+MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/sphinxbase
+CFLAGS+= -I${LOCALBASE}/include #-I${LOCALBASE}/include/sphinxbase
+CXXFLAGS+= -I${LOCALBASE}/include #-I${LOCALBASE}/include/sphinxbase
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ENV= MKDIR="${MKDIR}" \
diff --git a/audio/sphinx3/distinfo b/audio/sphinx3/distinfo
index fc30c8e2e984..6661700c395b 100644
--- a/audio/sphinx3/distinfo
+++ b/audio/sphinx3/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sphinx3-0.7.tar.gz) = 5f2cf463e7aa4b4991492b707b3b82c15cc7bf0698530bdbbfbb8e2daebaf69a
-SIZE (sphinx3-0.7.tar.gz) = 25219945
+SHA256 (sphinx3-0.8.tar.gz) = 1cf76a086f9b509e35f7226df2e61b0a0bf8b0858b9676e5b18cfc47b2ea2741
+SIZE (sphinx3-0.8.tar.gz) = 25226326
diff --git a/audio/sphinx3/files/patch-src_libs3decoder_libsearch_vithist.c b/audio/sphinx3/files/patch-src_libs3decoder_libsearch_vithist.c
new file mode 100644
index 000000000000..e3fc3d22e2c6
--- /dev/null
+++ b/audio/sphinx3/files/patch-src_libs3decoder_libsearch_vithist.c
@@ -0,0 +1,11 @@
+--- src/libs3decoder/libsearch/vithist.c.orig 2012-12-14 12:01:13.000000000 -0500
++++ src/libs3decoder/libsearch/vithist.c 2012-12-14 12:00:44.000000000 -0500
+@@ -647,7 +647,7 @@ vithist_prune(vithist_t * vh, dict_t * d
+ {
+ int32 se, fe, filler_done, th;
+ vithist_entry_t *ve;
+- heap_t h;
++ heap_t* h;
+ s3wid_t *wid;
+ int32 i;
+