aboutsummaryrefslogtreecommitdiff
path: root/audio/splay/files
diff options
context:
space:
mode:
authorMasafumi Max NAKANE <max@FreeBSD.org>1997-05-16 07:39:29 +0000
committerMasafumi Max NAKANE <max@FreeBSD.org>1997-05-16 07:39:29 +0000
commit5ae9afcef5f459dcc0b064b60d0304a9fba55f43 (patch)
tree21d8f3d59caa3b9ceddf23603a7224ee966ec802 /audio/splay/files
parent1b8fb360665d82645d741cf2bbb78399b4ea5a53 (diff)
downloadports-5ae9afcef5f459dcc0b064b60d0304a9fba55f43.tar.gz
ports-5ae9afcef5f459dcc0b064b60d0304a9fba55f43.zip
Notes
Diffstat (limited to 'audio/splay/files')
-rw-r--r--audio/splay/files/patch-aa243
1 files changed, 2 insertions, 241 deletions
diff --git a/audio/splay/files/patch-aa b/audio/splay/files/patch-aa
index 9a1244a523fa..253006d4b401 100644
--- a/audio/splay/files/patch-aa
+++ b/audio/splay/files/patch-aa
@@ -1,181 +1,5 @@
-diff -c -r ../splay-0.2-orig/Makefile ./Makefile
-*** ../splay-0.2-orig/Makefile Sat Mar 15 00:00:00 1997
---- ./Makefile Wed Mar 19 19:19:58 1997
-***************
-*** 1,4 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
-
---- 1,4 ----
-! CC = cc
- #CC = pgcc
- AR = ar
-
-***************
-*** 7,14 ****
- WFLAGS = -Wstrict-prototypes -Wall
- OFLAGS = -O2 -m486
- #OFLAGS = -O6 -mpentium
-! TFLAGS = -D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = -lpthread
- CFLAGS = $(OFLAGS) $(WFLAGS) $(IFLAGS) $(DEBUG) $(TFLAGS)
- OBJECTS = splay.o
- LIBRARY = -lm $(TLIBFLAGS) \
---- 7,14 ----
- WFLAGS = -Wstrict-prototypes -Wall
- OFLAGS = -O2 -m486
- #OFLAGS = -O6 -mpentium
-! TFLAGS = #-D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = #-lpthread
- CFLAGS = $(OFLAGS) $(WFLAGS) $(IFLAGS) $(DEBUG) $(TFLAGS)
- OBJECTS = splay.o
- LIBRARY = -lm $(TLIBFLAGS) \
-diff -c -r ../splay-0.2-orig/bbitstream/Makefile ./bbitstream/Makefile
-*** ../splay-0.2-orig/bbitstream/Makefile Sat Mar 15 00:00:00 1997
---- ./bbitstream/Makefile Wed Mar 19 19:17:17 1997
-***************
-*** 1,7 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-
- OBJLIB = bbitstream.a
- OBJECTS = input.o output.o
---- 1,8 ----
-! CC = cc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-+ RANLIB = ranlib
-
- OBJLIB = bbitstream.a
- OBJECTS = input.o output.o
-***************
-*** 21,27 ****
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rcs $(OBJLIB) $(OBJECTS)
-
- .cc.o :
- $(CC) -c $(CFLAGS) -o $*.o $<
---- 22,29 ----
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rc $(OBJLIB) $(OBJECTS)
-! $(RANLIB) $(OBJLIB)
-
- .cc.o :
- $(CC) -c $(CFLAGS) -o $*.o $<
-diff -c -r ../splay-0.2-orig/sound/Makefile ./sound/Makefile
-*** ../splay-0.2-orig/sound/Makefile Sat Mar 15 00:00:00 1997
---- ./sound/Makefile Wed Mar 19 19:18:57 1997
-***************
-*** 1,7 ****
-! CC = gcc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-
- OBJLIB = mpegsound.a
- OBJECTS = rawplayer.o wavetoraw.o \
---- 1,8 ----
-! CC = cc
- #CC = pgcc
- AR = ar
- RM = \rm -f
-+ RANLIB = ranlib
-
- OBJLIB = mpegsound.a
- OBJECTS = rawplayer.o wavetoraw.o \
-***************
-*** 15,29 ****
- DEBUG = -g
- IFLAGS = -I../bbitstream/
- AFLAGS = -malign-loops=2 -malign-jumps=2 -malign-functions=2
-! TFLAGS = -D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = -lpthread
- OFLAGS = -O3 -fomit-frame-pointer -fno-strength-reduce -m486 $(AFLAG)
- #OFLAGS = -O6 -mpentium
- WFLAGS = -Wstrict-prototypes -Wall
- CFLAGS = $(DEBUG) $(IFLAGS) $(OFLAGS) $(WFLAGS) $(TFLAGS)
- LIBS = $(OBJLIB) -lm $(TLIBFLAGS) ../bbitstream/bbitstream.a
-
-! all: $(OBJLIB) test
-
- clean:
- $(RM) *.a test *.o *~
---- 16,30 ----
- DEBUG = -g
- IFLAGS = -I../bbitstream/
- AFLAGS = -malign-loops=2 -malign-jumps=2 -malign-functions=2
-! TFLAGS = #-D_REENTRANT -DPTHREADEDMPEG
-! TLIBFLAGS = #-lpthread
- OFLAGS = -O3 -fomit-frame-pointer -fno-strength-reduce -m486 $(AFLAG)
- #OFLAGS = -O6 -mpentium
- WFLAGS = -Wstrict-prototypes -Wall
- CFLAGS = $(DEBUG) $(IFLAGS) $(OFLAGS) $(WFLAGS) $(TFLAGS)
- LIBS = $(OBJLIB) -lm $(TLIBFLAGS) ../bbitstream/bbitstream.a
-
-! all: $(OBJLIB) #test
-
- clean:
- $(RM) *.a test *.o *~
-***************
-*** 36,42 ****
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rcs $(OBJLIB) $(OBJECTS)
-
- .cc.o:
- $(CC) -c $(CFLAGS) -o $*.o $<
---- 37,44 ----
-
- $(OBJLIB): $(OBJECTS)
- $(RM) $(OBJLIB)
-! $(AR) rc $(OBJLIB) $(OBJECTS)
-! $(RANLIB) $(OBJLIB)
-
- .cc.o:
- $(CC) -c $(CFLAGS) -o $*.o $<
-***************
-*** 54,57 ****
-
- bitwindow.o : mpegsound.h bitwindow.cc
- huffman.o : mpegsound.h huffman.cc
-! huffmantable.o : mpegsound.h huffmantable.cc
---- 56,59 ----
-
- bitwindow.o : mpegsound.h bitwindow.cc
- huffman.o : mpegsound.h huffman.cc
-! huffmantable.o : mpegsound.h huffmantable.cc
-diff -c -r ../splay-0.2-orig/sound/mpegsound.h ./sound/mpegsound.h
-*** ../splay-0.2-orig/sound/mpegsound.h Sat Mar 15 00:00:00 1997
---- ./sound/mpegsound.h Wed Mar 19 20:02:22 1997
-***************
-*** 11,17 ****
- /* Inlcude default library packages */
- /************************************/
- #include <stdio.h>
-! #include <malloc.h>
- #include <unistd.h>
-
- #ifdef PTHREADEDMPEG
---- 11,17 ----
- /* Inlcude default library packages */
- /************************************/
- #include <stdio.h>
-! #include <stdlib.h>
- #include <unistd.h>
-
- #ifdef PTHREADEDMPEG
-diff -c -r ../splay-0.2-orig/sound/rawplayer.cc ./sound/rawplayer.cc
-*** ../splay-0.2-orig/sound/rawplayer.cc Sat Mar 15 00:00:00 1997
---- ./sound/rawplayer.cc Wed Mar 19 19:16:56 1997
+*** mpegsound/rawplayer.cc Thu Mar 27 22:18:47 1997
+--- mpegsound/rawplayer.cc Tue Apr 1 19:33:46 1997
***************
*** 8,14 ****
@@ -193,66 +17,3 @@ diff -c -r ../splay-0.2-orig/sound/rawplayer.cc ./sound/rawplayer.cc
#include "mpegsound.h"
-diff -c -r ../splay-0.2-orig/sound/test.cc ./sound/test.cc
-*** ../splay-0.2-orig/sound/test.cc Sat Mar 15 00:00:00 1997
---- ./sound/test.cc Wed Mar 19 19:18:03 1997
-***************
-*** 2,8 ****
-
- #include <stdio.h>
- #include <string.h>
-! #include <getopt.h>
- #include <unistd.h>
-
- #include "mpegsound.h"
---- 2,8 ----
-
- #include <stdio.h>
- #include <string.h>
-! //#include <getopt.h>
- #include <unistd.h>
-
- #include "mpegsound.h"
-diff -c -r ../splay-0.2-orig/sound/wavetoraw.cc ./sound/wavetoraw.cc
-*** ../splay-0.2-orig/sound/wavetoraw.cc Sat Mar 15 00:00:00 1997
---- ./sound/wavetoraw.cc Wed Mar 19 20:02:48 1997
-***************
-*** 5,11 ****
- // Wavetoraw.cc
- // Server which strips wave header.
-
-! #include <malloc.h>
-
- #include "mpegsound.h"
-
---- 5,11 ----
- // Wavetoraw.cc
- // Server which strips wave header.
-
-! #include <stdlib.h>
-
- #include "mpegsound.h"
-
-diff -c -r ../splay-0.2-orig/splay.cc ./splay.cc
-*** ../splay-0.2-orig/splay.cc Sat Mar 15 00:00:00 1997
---- ./splay.cc Wed Mar 19 19:20:52 1997
-***************
-*** 42,47 ****
---- 42,48 ----
- return;
- }
-
-+ #ifdef PTHREADEDMPEG
- void playingthread(Mpegfileplayer *player)
- {
- if(player->geterrorcode()>0)error(player->geterrorcode());
-***************
-*** 52,57 ****
---- 53,59 ----
- if(player->geterrorcode()>0)error(player->geterrorcode());
- }
- }
-+ #endif
-
- void playing(Fileplayer *player)
- {