aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezeboxserver-lazysearch
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2008-06-29 21:56:21 +0000
committerTim Bishop <tdb@FreeBSD.org>2008-06-29 21:56:21 +0000
commitd9c0f1d5a5c0ffc724a0725bbccc51e21deb1ee7 (patch)
treed6e594d27c742e83efe31c669c167afbb69579f1 /audio/squeezeboxserver-lazysearch
parent70b7e1c05cee4df28a9bcc88768441625dd2557f (diff)
downloadports-d9c0f1d5a5c0ffc724a0725bbccc51e21deb1ee7.tar.gz
ports-d9c0f1d5a5c0ffc724a0725bbccc51e21deb1ee7.zip
Notes
Diffstat (limited to 'audio/squeezeboxserver-lazysearch')
-rw-r--r--audio/squeezeboxserver-lazysearch/Makefile33
-rw-r--r--audio/squeezeboxserver-lazysearch/distinfo3
-rw-r--r--audio/squeezeboxserver-lazysearch/pkg-descr7
-rw-r--r--audio/squeezeboxserver-lazysearch/pkg-plist16
4 files changed, 59 insertions, 0 deletions
diff --git a/audio/squeezeboxserver-lazysearch/Makefile b/audio/squeezeboxserver-lazysearch/Makefile
new file mode 100644
index 000000000000..550cb74273f2
--- /dev/null
+++ b/audio/squeezeboxserver-lazysearch/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: squeezecenter-lazysearch
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= lazysearch
+PORTVERSION= 3.0
+CATEGORIES= audio
+# Distfile mirrored due to being unversioned on author's site
+MASTER_SITES= ftp://ftp.i-scream.org/pub/slimserver/${PORTNAME}/ \
+ http://ftp.i-scream.org/pub/slimserver/${PORTNAME}/
+PKGNAMEPREFIX= squeezecenter-
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin for performing lazy searches
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter
+
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/LazySearch2
+ ${CP} -R ${WRKSRC}/LazySearch2/* ${PREFIX}/${SLIMDIR}/Plugins/LazySearch2
+
+.include <bsd.port.mk>
diff --git a/audio/squeezeboxserver-lazysearch/distinfo b/audio/squeezeboxserver-lazysearch/distinfo
new file mode 100644
index 000000000000..5ab4edd95b23
--- /dev/null
+++ b/audio/squeezeboxserver-lazysearch/distinfo
@@ -0,0 +1,3 @@
+MD5 (squeezecenter/lazysearch-3.0.zip) = 912a5bc307f7743a4fa17d889c58413e
+SHA256 (squeezecenter/lazysearch-3.0.zip) = 562413203a979c1c9013aab8bed4c96124511948fb44b092084dae1b53817812
+SIZE (squeezecenter/lazysearch-3.0.zip) = 58056
diff --git a/audio/squeezeboxserver-lazysearch/pkg-descr b/audio/squeezeboxserver-lazysearch/pkg-descr
new file mode 100644
index 000000000000..ff5cde9e430e
--- /dev/null
+++ b/audio/squeezeboxserver-lazysearch/pkg-descr
@@ -0,0 +1,7 @@
+This is a SqueezeCenter plugin to add lazy search capabilities. Lazy
+searching allows for much faster entry of search text by allowing you
+to forget about multi-tapping and instead just press each of the
+remote control buttons once for each of the letters in the text,
+whatever position the letter appears in above the button.
+
+WWW: http://hickinbottom.demon.co.uk/lazysearch/
diff --git a/audio/squeezeboxserver-lazysearch/pkg-plist b/audio/squeezeboxserver-lazysearch/pkg-plist
new file mode 100644
index 000000000000..f0e2fb76564b
--- /dev/null
+++ b/audio/squeezeboxserver-lazysearch/pkg-plist
@@ -0,0 +1,16 @@
+%%SLIMDIR%%/Plugins/LazySearch2/HTML/EN/plugins/LazySearch2/settings/basic.html
+%%SLIMDIR%%/Plugins/LazySearch2/HTML/EN/plugins/LazySearch2/settings/logo.jpg
+%%SLIMDIR%%/Plugins/LazySearch2/INSTALL
+%%SLIMDIR%%/Plugins/LazySearch2/LICENSE
+%%SLIMDIR%%/Plugins/LazySearch2/Plugin.pm
+%%SLIMDIR%%/Plugins/LazySearch2/Settings.pm
+%%SLIMDIR%%/Plugins/LazySearch2/install.xml
+%%SLIMDIR%%/Plugins/LazySearch2/strings.txt
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2/HTML/EN/plugins/LazySearch2/settings
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2/HTML/EN/plugins/LazySearch2
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2/HTML/EN/plugins
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2/HTML/EN
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2/HTML
+@dirrm %%SLIMDIR%%/Plugins/LazySearch2
+@dirrmtry %%SLIMDIR%%/Plugins
+@dirrmtry %%SLIMDIR%%