aboutsummaryrefslogtreecommitdiff
path: root/audio/squeezeboxserver-trackstat/Makefile
diff options
context:
space:
mode:
authorTim Bishop <tdb@FreeBSD.org>2008-06-29 21:59:28 +0000
committerTim Bishop <tdb@FreeBSD.org>2008-06-29 21:59:28 +0000
commit5618af2399d7c8e9e300dfad4844cdc5d6dd9611 (patch)
tree3e2e8a377390ad298203e8057f14f566980321d0 /audio/squeezeboxserver-trackstat/Makefile
parent2d59184efce27474c5588409544fdda016e8e12f (diff)
Notes
Diffstat (limited to 'audio/squeezeboxserver-trackstat/Makefile')
-rw-r--r--audio/squeezeboxserver-trackstat/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/audio/squeezeboxserver-trackstat/Makefile b/audio/squeezeboxserver-trackstat/Makefile
new file mode 100644
index 000000000000..5eb6f7fc142b
--- /dev/null
+++ b/audio/squeezeboxserver-trackstat/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: squeezecenter-trackstat
+# Date created: 21 June 2008
+# Whom: Tim Bishop <tdb@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trackstat
+PORTVERSION= 2.0.b09
+CATEGORIES= audio
+MASTER_SITES= http://erland.homeip.net/download/do/downloadapplication?name=slimserver-trackstat&filename=/
+PKGNAMEPREFIX= squeezecenter-
+DISTNAME= TrackStat-${PORTVERSION:S/b/beta/}
+DIST_SUBDIR= squeezecenter
+
+MAINTAINER= tdb@FreeBSD.org
+COMMENT= SqueezeCenter plugin to store ratings and statistics about songs
+
+RUN_DEPENDS= softsqueeze:${PORTSDIR}/audio/squeezecenter
+
+FETCH_BEFORE_ARGS= -o ${DISTFILES}
+USE_ZIP= yes
+NO_WRKSUBDIR= yes
+NO_BUILD= yes
+
+SLIMDIR?= squeezecenter
+PLIST_SUB+= SLIMDIR=${SLIMDIR}
+
+do-install:
+ ${MKDIR} ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+ ${CP} -R ${WRKSRC}/TrackStat/* ${PREFIX}/${SLIMDIR}/Plugins/TrackStat
+
+.include <bsd.port.mk>