aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper/Makefile
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-02-13 12:12:30 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-02-13 12:12:30 +0000
commit86008e4b2349277619bfe309e62f94c7a426d6e3 (patch)
tree241337dfd26d7185f144019f2105b9eb190bf630 /audio/streamripper/Makefile
parenta89aa84612c997b51bfaadc83bb3de056184fcaa (diff)
Update to 1.61.17.
- Pet portlint - Add OPTIONS for vorbis support - Submitter takes maintainership PR: ports/93213 Submitted by: Rainer Alves <rainer.alves@gmail.com>
Notes
Notes: svn path=/head/; revision=155926
Diffstat (limited to 'audio/streamripper/Makefile')
-rw-r--r--audio/streamripper/Makefile23
1 files changed, 18 insertions, 5 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 91ad4c4a8d56..4f72bd796f00 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -6,16 +6,26 @@
#
PORTNAME= streamripper
-PORTVERSION= 1.61.16
+PORTVERSION= 1.61.17
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= streamripper
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= rainer.alves@gmail.com
COMMENT= Splits SHOUTcast stream into tracks
-LIB_DEPENDS= iconv.3:${PORTSDIR}/converters/libiconv \
- mad.2:${PORTSDIR}/audio/libmad
+LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad
+
+USE_ICONV= yes
+
+OPTIONS= VORBIS "Include Ogg Vorbis codec support" on
+
+.include <bsd.port.pre.mk>
+
+.ifdef(WITH_VORBIS)
+LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis
+.endif
GNU_CONFIGURE= yes
CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
@@ -24,4 +34,7 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_FILES= bin/streamripper
MAN1= streamripper.1
-.include <bsd.port.mk>
+pre-install:
+ @${CHMOD} +x ${WRKSRC}/install-sh
+
+.include <bsd.port.post.mk>