aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper/Makefile
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
committerJohn Marino <marino@FreeBSD.org>2015-03-25 21:37:39 +0000
commit112f62e6b9a1ec43ddc94a4694095f410e4b643e (patch)
tree277ac2758fc47caca6c3e00663bc52d197085558 /audio/streamripper/Makefile
parent33ac97e0314d5998c3111bd87d8bcece3e1978b2 (diff)
downloadports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.tar.gz
ports-112f62e6b9a1ec43ddc94a4694095f410e4b643e.zip
Notes
Diffstat (limited to 'audio/streamripper/Makefile')
-rw-r--r--audio/streamripper/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 7af46f43f669..45f555cd2133 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -56,19 +56,19 @@ post-extract:
${MV} ${WRKDIR}/cdk-${CDK_VERSION} ${WRKSRC}
post-patch:
- @${REINPLACE_CMD} -e '/if test/s|==|=|g ; \
- s|-lpthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e '/if test/s|==|=|g' ${WRKSRC}/configure
pre-configure:
- @cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} CC="${CC}" \
- CFLAGS="${CFLAGS}" ${SH} ./configure
+ (cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} CC="${CC}" \
+ CFLAGS="${CFLAGS}" ${SH} ./configure)
pre-build:
- @cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} ${MAKE_ENV} \
- ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET}
+ (cd ${WRKSRC}/cdk-${CDK_VERSION} && ${SETENV} ${MAKE_ENV} \
+ ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${ALL_TARGET})
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/streamripper ${STAGEDIR}${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/streamripper.1 ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_MAN} ${WRKSRC}/streamripper.1 \
+ ${STAGEDIR}${MANPREFIX}/man/man1
.include <bsd.port.mk>