aboutsummaryrefslogtreecommitdiff
path: root/audio/streamripper
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2005-01-19 07:36:45 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2005-01-19 07:36:45 +0000
commita4a46d195f89d31078518d94990ca312935e5a73 (patch)
tree297427da9002c3fcf5b1d5b9075cb5b09da82b52 /audio/streamripper
parent1197ed7168930689b9f75f3bbce06ce5723a2cc1 (diff)
downloadports-a4a46d195f89d31078518d94990ca312935e5a73.tar.gz
ports-a4a46d195f89d31078518d94990ca312935e5a73.zip
Notes
Diffstat (limited to 'audio/streamripper')
-rw-r--r--audio/streamripper/Makefile8
-rw-r--r--audio/streamripper/files/patch-lib_util.c33
2 files changed, 34 insertions, 7 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index effdde26124e..816c46749d59 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -24,10 +24,4 @@ CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_FILES= bin/streamripper
MAN1= streamripper.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 500000
-BROKEN= "Does not compile on FreeBSD < 5.x"
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/streamripper/files/patch-lib_util.c b/audio/streamripper/files/patch-lib_util.c
new file mode 100644
index 000000000000..365ef2f92a48
--- /dev/null
+++ b/audio/streamripper/files/patch-lib_util.c
@@ -0,0 +1,33 @@
+Argh, FreeBSD 4.X has a wctype.h header that does nothing.
+
+--- lib/util.c.orig Sat Nov 13 17:41:09 2004
++++ lib/util.c Wed Jan 19 07:01:41 2005
+@@ -28,9 +28,7 @@
+ #if defined HAVE_WCHAR_H
+ #include <wchar.h>
+ #endif
+-#if defined HAVE_WCTYPE_H
+-#include <wctype.h>
+-#endif
++#include <ctype.h>
+ #endif
+ #include <locale.h>
+ #include <time.h>
+@@ -464,7 +462,7 @@ strip_invalid_chars_testing(char *str)
+
+ /* Replace illegals to legal */
+ for (wstrp = w_in; *wstrp; wstrp++) {
+- if ((wcschr(w_invalid, *wstrp) == NULL) && (!iswcntrl(*wstrp)))
++ if ((wcschr(w_invalid, *wstrp) == NULL) && (!iscntrl(*wstrp)))
+ continue;
+ *wstrp = replacement;
+ }
+@@ -543,7 +541,7 @@ strip_invalid_chars_stable(char *str)
+
+ /* Replace illegals to legal */
+ for (wstrp = w_in; *wstrp; wstrp++) {
+- if ((wcschr(w_invalid, *wstrp) == NULL) && (!iswcntrl(*wstrp)))
++ if ((wcschr(w_invalid, *wstrp) == NULL) && (!iscntrl(*wstrp)))
+ continue;
+ *wstrp = replacement;
+ }