aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner-local/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:52:23 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:52:23 +0000
commitc5814bc688cc0462ab6e33306d740ec744a1db81 (patch)
tree7248918ad0bda73bc3d52a7a993315ff850a510e /audio/streamtuner-local/Makefile
parent602d1aa84094d4fe4e6487f29cdfe2c19fcdf615 (diff)
downloadports-c5814bc688cc0462ab6e33306d740ec744a1db81.tar.gz
ports-c5814bc688cc0462ab6e33306d740ec744a1db81.zip
Notes
Diffstat (limited to 'audio/streamtuner-local/Makefile')
-rw-r--r--audio/streamtuner-local/Makefile17
1 files changed, 9 insertions, 8 deletions
diff --git a/audio/streamtuner-local/Makefile b/audio/streamtuner-local/Makefile
index 5593f24d8bc9..33b7375455f2 100644
--- a/audio/streamtuner-local/Makefile
+++ b/audio/streamtuner-local/Makefile
@@ -5,22 +5,23 @@
# $FreeBSD$
#
-PORTNAME= local
-PORTVERSION= 0.2.1
+PORTNAME= streamtuner-local
+PORTVERSION= 0.3.0
CATEGORIES= audio www
MASTER_SITES= http://streamtuner.sourceforge.net/streamtuner/
-PKGNAMEPREFIX= streamtuner-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jylefort@brutele.be
-COMMENT= A plugin for streamtuner that browses a local MP3 repository
+COMMENT= A streamtuner plugin for local music access
BUILD_DEPENDS= ${X11BASE}/include/streamtuner/streamtuner.h:${PORTSDIR}/audio/streamtuner
RUN_DEPENDS= ${X11BASE}/bin/streamtuner:${PORTSDIR}/audio/streamtuner
-LIB_DEPENDS= id3-3.8:${PORTSDIR}/audio/id3lib
+LIB_DEPENDS= id3tag:${PORTSDIR}/audio/libid3tag \
+ vorbis:${PORTSDIR}/audio/libvorbis
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-id3lib=${LOCALBASE}
+USE_LIBTOOL_VER= 15
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>