aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner-python
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:57:25 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-02-01 01:57:25 +0000
commit909f75d1a82af567c76bb983002dfb4f0b8ba505 (patch)
tree3820730eac6f14d9ae2cc66904e617388643f073 /audio/streamtuner-python
parentc5814bc688cc0462ab6e33306d740ec744a1db81 (diff)
downloadports-909f75d1a82af567c76bb983002dfb4f0b8ba505.tar.gz
ports-909f75d1a82af567c76bb983002dfb4f0b8ba505.zip
Notes
Diffstat (limited to 'audio/streamtuner-python')
-rw-r--r--audio/streamtuner-python/Makefile13
-rw-r--r--audio/streamtuner-python/distinfo2
-rw-r--r--audio/streamtuner-python/pkg-descr2
-rw-r--r--audio/streamtuner-python/pkg-plist3
4 files changed, 9 insertions, 11 deletions
diff --git a/audio/streamtuner-python/Makefile b/audio/streamtuner-python/Makefile
index e4e61de714fc..f877fde36263 100644
--- a/audio/streamtuner-python/Makefile
+++ b/audio/streamtuner-python/Makefile
@@ -5,12 +5,10 @@
# $FreeBSD$
#
-PORTNAME= python
-PORTVERSION= 0.0.2
+PORTNAME= streamtuner-python
+PORTVERSION= 0.0.3
CATEGORIES= audio www
MASTER_SITES= http://streamtuner.sourceforge.net/streamtuner/
-PKGNAMEPREFIX= streamtuner-
-DISTNAME= ${PKGNAMEPREFIX}${PORTNAME}-${PORTVERSION}
MAINTAINER= jylefort@brutele.be
COMMENT= A streamtuner plugin providing a Python interpreter
@@ -19,9 +17,10 @@ BUILD_DEPENDS= ${X11BASE}/include/streamtuner/streamtuner.h:${PORTSDIR}/audio/s
RUN_DEPENDS= ${X11BASE}/bin/streamtuner:${PORTSDIR}/audio/streamtuner
USE_X_PREFIX= yes
-GNU_CONFIGURE= yes
+USE_LIBTOOL_VER= 15
USE_PYTHON= yes
-USE_LIBTOOL= yes
-#INSTALLS_SHLIB= not needed, the libs are plugins for streamtuner only
+
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
.include <bsd.port.mk>
diff --git a/audio/streamtuner-python/distinfo b/audio/streamtuner-python/distinfo
index ffc6a363daff..e50083f010d5 100644
--- a/audio/streamtuner-python/distinfo
+++ b/audio/streamtuner-python/distinfo
@@ -1 +1 @@
-MD5 (streamtuner-python-0.0.2.tar.gz) = aa6067f94be48b163f0d8ea57e397264
+MD5 (streamtuner-python-0.0.3.tar.gz) = 37a58abc59761b1b2fbdb156db8aa4fb
diff --git a/audio/streamtuner-python/pkg-descr b/audio/streamtuner-python/pkg-descr
index 1eb43d9927f9..d4092aa96224 100644
--- a/audio/streamtuner-python/pkg-descr
+++ b/audio/streamtuner-python/pkg-descr
@@ -1,7 +1,7 @@
streamtuner-python is a streamtuner plugin providing an embedded
Python interpreter.
-WWW: http://www.nongnu.org/streamtuner/plugins/
+WWW: http://www.nongnu.org/streamtuner/
- Jean-Yves Lefort
jylefort@brutele.be
diff --git a/audio/streamtuner-python/pkg-plist b/audio/streamtuner-python/pkg-plist
index 2e1aeb987eb3..ffcc8e0fcca6 100644
--- a/audio/streamtuner-python/pkg-plist
+++ b/audio/streamtuner-python/pkg-plist
@@ -1,6 +1,5 @@
-lib/streamtuner/plugins/python.a
-lib/streamtuner/plugins/python.la
lib/streamtuner/plugins/python.so
+share/locale/fr/LC_MESSAGES/streamtuner-python.mo
share/streamtuner-python/icons/google-stations.png
share/streamtuner-python/modules/G.py
share/streamtuner-python/modules/G.pyc