aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /audio/streamtuner/Makefile
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'audio/streamtuner/Makefile')
-rw-r--r--audio/streamtuner/Makefile9
1 files changed, 6 insertions, 3 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index fd3ab322db8f..b81254a014f3 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -7,7 +7,7 @@
PORTNAME= streamtuner
PORTVERSION= 0.99.99
-PORTREVISION= 7
+PORTREVISION= 9
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,14 +15,15 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= jylefort@FreeBSD.org
COMMENT= A GTK+ stream directory browser
-BUILD_DEPENDS= scrollkeeper-config:${PORTSDIR}/textproc/scrollkeeper
+BUILD_DEPENDS= rarian-sk-config:${PORTSDIR}/textproc/rarian
LIB_DEPENDS= curl:${PORTSDIR}/ftp/curl
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/gnome-icon-theme.pc:${PORTSDIR}/misc/gnome-icon-theme
USE_XLIB= yes
USE_GNOME= gtk20 gnomehack gnomeprefix
USE_GMAKE= yes
-GNU_CONFIGURE= yes
+INSTALLS_OMF= yes
+GNU_CONFIGURE= yes
USE_GETOPT_LONG= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
@@ -85,5 +86,7 @@ USE_GNOME+= pygtk2
post-patch:
@${REINPLACE_CMD} -e 's|echo aout|echo elf|' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|[(]datadir[)]/help|(datadir)/gnome/help|g' \
+ ${WRKSRC}/help/C/Makefile.in
.include <bsd.port.post.mk>