aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-13 21:12:40 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-04-13 21:12:40 +0000
commit0fb1b18f7c7be3a8b6dba09697d4906ffc991348 (patch)
tree55c730e48fd6c4480ab5bb8a3cfff9106b9a51b5 /audio/streamtuner
parent328d7e4f54229c7271457103ffeac3e0c84022b0 (diff)
downloadports-0fb1b18f7c7be3a8b6dba09697d4906ffc991348.tar.gz
ports-0fb1b18f7c7be3a8b6dba09697d4906ffc991348.zip
Notes
Diffstat (limited to 'audio/streamtuner')
-rw-r--r--audio/streamtuner/Makefile2
-rw-r--r--audio/streamtuner/files/patch-src_plugins_python_pst-main.c18
2 files changed, 19 insertions, 1 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index 90bb6a3d8b12..d80d7873587e 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -7,7 +7,7 @@
PORTNAME= streamtuner
PORTVERSION= 0.99.99
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/streamtuner/files/patch-src_plugins_python_pst-main.c b/audio/streamtuner/files/patch-src_plugins_python_pst-main.c
new file mode 100644
index 000000000000..1e51097505b6
--- /dev/null
+++ b/audio/streamtuner/files/patch-src_plugins_python_pst-main.c
@@ -0,0 +1,18 @@
+--- src/plugins/python/pst-main.c.orig Thu Mar 24 15:52:58 2005
++++ src/plugins/python/pst-main.c Thu Mar 24 15:53:59 2005
+@@ -94,6 +94,7 @@
+ {
+ gboolean status = FALSE;
+ PyObject *module;
++ char *argv[] = { "" };
+
+ if (! check_api_version(err))
+ return FALSE;
+@@ -109,6 +110,7 @@
+ }
+
+ Py_Initialize();
++ PySys_SetArgv(G_N_ELEMENTS(argv), argv);
+ PyEval_InitThreads();
+
+ module = PyImport_AddModule("__main__");