aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-10-28 21:20:12 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-10-28 21:20:12 +0000
commit4dd0047e68a5d0af2a0ffcf59ddaab08dadd7b5c (patch)
treee57db16702602bead653c448081ba6399bf7fd1a /audio/streamtuner
parentb9fd5dfdcfecee8bcfe9d31e6a122101ddea133a (diff)
downloadports-4dd0047e68a5d0af2a0ffcf59ddaab08dadd7b5c.tar.gz
ports-4dd0047e68a5d0af2a0ffcf59ddaab08dadd7b5c.zip
Notes
Diffstat (limited to 'audio/streamtuner')
-rw-r--r--audio/streamtuner/Makefile58
-rw-r--r--audio/streamtuner/distinfo4
-rw-r--r--audio/streamtuner/pkg-plist17
3 files changed, 74 insertions, 5 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index b77c6462f713..d361eda6bd4f 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= streamtuner
-PORTVERSION= 0.12.5
+PORTVERSION= 0.99
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -25,4 +25,58 @@ USE_LIBTOOL_VER= 15
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-.include <bsd.port.mk>
+OPTIONS= SHOUTCAST "SHOUTcast plugin" on \
+ LIVE365 "Live365 plugin" on \
+ XIPH "Xiph plugin" on \
+ LOCAL "Local plugin" on \
+ LOCAL_METADATA "metadata support for the Local plugin" on \
+ PYTHON "Python plugin" on
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITHOUT_SHOUTCAST)
+CONFIGURE_ARGS+= --disable-shoutcast
+PLIST_SUB+= SHOUTCAST="@comment "
+.else
+PLIST_SUB+= SHOUTCAST=""
+.endif
+
+.if defined(WITHOUT_LIVE365)
+CONFIGURE_ARGS+= --disable-live365
+PLIST_SUB+= LIVE365="@comment "
+.else
+PLIST_SUB+= LIVE365=""
+.endif
+
+.if defined(WITHOUT_XIPH)
+CONFIGURE_ARGS+= --disable-xiph
+PLIST_SUB+= XIPH="@comment "
+.else
+PLIST_SUB+= XIPH=""
+USE_GNOME+= libxml2
+.endif
+
+.if defined(WITHOUT_LOCAL)
+CONFIGURE_ARGS+= --disable-local
+PLIST_SUB+= LOCAL="@comment "
+.else
+PLIST_SUB+= LOCAL=""
+.if defined(WITHOUT_LOCAL_METADATA)
+CONFIGURE_ARGS+= --disable-local-metadata
+.else
+LIB_DEPENDS+= tag_c:${PORTSDIR}/audio/taglib
+.endif
+.endif
+
+.if defined(WITHOUT_PYTHON)
+CONFIGURE_ARGS+= --disable-python
+PLIST_SUB+= PYTHON="@comment "
+.else
+PLIST_SUB+= PYTHON=""
+USE_PYTHON= 2.2+
+# we need to manually include this, because USE_PYTHON is defined
+# after including bsd.port.pre.mk
+.include "${PORTSDIR}/Mk/bsd.python.mk"
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/streamtuner/distinfo b/audio/streamtuner/distinfo
index 2967abcd71f7..061cc61c82c9 100644
--- a/audio/streamtuner/distinfo
+++ b/audio/streamtuner/distinfo
@@ -1,2 +1,2 @@
-MD5 (streamtuner-0.12.5.tar.gz) = 4782aa87bda0bbefbeb172ee2b3bfecf
-SIZE (streamtuner-0.12.5.tar.gz) = 676473
+MD5 (streamtuner-0.99.tar.gz) = 0cd9ad6de35860af5e0a78a0b017973d
+SIZE (streamtuner-0.99.tar.gz) = 782084
diff --git a/audio/streamtuner/pkg-plist b/audio/streamtuner/pkg-plist
index 29f73497b00e..50aefdea013e 100644
--- a/audio/streamtuner/pkg-plist
+++ b/audio/streamtuner/pkg-plist
@@ -14,9 +14,14 @@ include/streamtuner/st-sgml-ref-api.h
include/streamtuner/st-state-api.h
include/streamtuner/st-stream-api.h
include/streamtuner/st-transfer-api.h
+include/streamtuner/st-util-api.h
include/streamtuner/st-version-api.h
include/streamtuner/streamtuner.h
-lib/streamtuner/plugins/shoutcast.so
+%%LIVE365%%lib/streamtuner/plugins/live365.so
+%%LOCAL%%lib/streamtuner/plugins/local.so
+%%PYTHON%%lib/streamtuner/plugins/python.so
+%%SHOUTCAST%%lib/streamtuner/plugins/shoutcast.so
+%%XIPH%%lib/streamtuner/plugins/xiph.so
libdata/pkgconfig/streamtuner.pc
share/gnome/applications/streamtuner.desktop
share/gnome/doc/streamtuner/C/documentation-license.xml
@@ -26,6 +31,12 @@ share/gnome/doc/streamtuner/C/streamtuner.xml
share/gnome/omf/streamtuner/streamtuner-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/streamtuner/streamtuner-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/streamtuner.png
+%%PYTHON%%share/gnome/streamtuner/python/icons/basic.ch.png
+%%PYTHON%%share/gnome/streamtuner/python/icons/google-stations.png
+%%PYTHON%%share/gnome/streamtuner/python/icons/punkcast.com.png
+%%PYTHON%%share/gnome/streamtuner/python/scripts/basic.ch.py
+%%PYTHON%%share/gnome/streamtuner/python/scripts/google-stations.py
+%%PYTHON%%share/gnome/streamtuner/python/scripts/punkcast.com.py
share/locale/de/LC_MESSAGES/streamtuner.mo
share/locale/fr/LC_MESSAGES/streamtuner.mo
share/locale/hu/LC_MESSAGES/streamtuner.mo
@@ -38,3 +49,7 @@ share/locale/pt/LC_MESSAGES/streamtuner.mo
@dirrm share/gnome/doc/streamtuner
@dirrm share/gnome/omf/streamtuner
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/streamtuner/streamtuner-C.omf 2>/dev/null || /usr/bin/true
+%%PYTHON%%@dirrm share/gnome/streamtuner/python/icons
+%%PYTHON%%@dirrm share/gnome/streamtuner/python/scripts
+%%PYTHON%%@dirrm share/gnome/streamtuner/python
+%%PYTHON%%@dirrm share/gnome/streamtuner