aboutsummaryrefslogtreecommitdiff
path: root/audio/streamtuner
diff options
context:
space:
mode:
authorEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 02:25:39 +0000
committerEdwin Groothuis <edwin@FreeBSD.org>2004-12-22 02:25:39 +0000
commitadd996bba32444ec46d60744b7c273f6fd31982d (patch)
tree291659698e818dda9f808975302ba38054cea1de /audio/streamtuner
parent900dfa479e53e75bba1697fbdc85ebc141e7b793 (diff)
downloadports-add996bba32444ec46d60744b7c273f6fd31982d.tar.gz
ports-add996bba32444ec46d60744b7c273f6fd31982d.zip
Notes
Diffstat (limited to 'audio/streamtuner')
-rw-r--r--audio/streamtuner/Makefile12
-rw-r--r--audio/streamtuner/distinfo4
-rw-r--r--audio/streamtuner/pkg-plist71
3 files changed, 72 insertions, 15 deletions
diff --git a/audio/streamtuner/Makefile b/audio/streamtuner/Makefile
index 366aa112f828..7420a4ad225e 100644
--- a/audio/streamtuner/Makefile
+++ b/audio/streamtuner/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= streamtuner
-PORTVERSION= 0.99
-PORTREVISION= 1
+PORTVERSION= 0.99.99
CATEGORIES= audio www
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,8 +22,10 @@ USE_X_PREFIX= yes
USE_GNOME= gtk20 gnomehack gnomeprefix
USE_GMAKE= yes
USE_LIBTOOL_VER= 15
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+USE_GETOPT_LONG= yes
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
OPTIONS= SHOUTCAST "SHOUTcast plugin" on \
LIVE365 "Live365 plugin" on \
@@ -74,10 +75,11 @@ CONFIGURE_ARGS+= --disable-python
PLIST_SUB+= PYTHON="@comment "
.else
PLIST_SUB+= PYTHON=""
-USE_PYTHON= 2.2+
+USE_PYTHON= 2.3+
# we need to manually include this, because USE_PYTHON is defined
# after including bsd.port.pre.mk
.include "${PORTSDIR}/Mk/bsd.python.mk"
+USE_GNOME+= pygtk2
.endif
.include <bsd.port.post.mk>
diff --git a/audio/streamtuner/distinfo b/audio/streamtuner/distinfo
index 061cc61c82c9..8c175811aeef 100644
--- a/audio/streamtuner/distinfo
+++ b/audio/streamtuner/distinfo
@@ -1,2 +1,2 @@
-MD5 (streamtuner-0.99.tar.gz) = 0cd9ad6de35860af5e0a78a0b017973d
-SIZE (streamtuner-0.99.tar.gz) = 782084
+MD5 (streamtuner-0.99.99.tar.gz) = 2027b7c34e85b594524b0b4351c14362
+SIZE (streamtuner-0.99.99.tar.gz) = 948075
diff --git a/audio/streamtuner/pkg-plist b/audio/streamtuner/pkg-plist
index 50aefdea013e..49b9461ba2df 100644
--- a/audio/streamtuner/pkg-plist
+++ b/audio/streamtuner/pkg-plist
@@ -7,6 +7,7 @@ include/streamtuner/st-handler-field-api.h
include/streamtuner/st-handlers-api.h
include/streamtuner/st-m3u-api.h
include/streamtuner/st-pls-api.h
+include/streamtuner/st-plugin-api.h
include/streamtuner/st-programs-api.h
include/streamtuner/st-re-api.h
include/streamtuner/st-settings-api.h
@@ -23,14 +24,65 @@ include/streamtuner/streamtuner.h
%%SHOUTCAST%%lib/streamtuner/plugins/shoutcast.so
%%XIPH%%lib/streamtuner/plugins/xiph.so
libdata/pkgconfig/streamtuner.pc
+share/doc/streamtuner/api-reference.html
+share/doc/streamtuner/ch01s02.html
+share/doc/streamtuner/home.png
+share/doc/streamtuner/index.html
+share/doc/streamtuner/index.sgml
+share/doc/streamtuner/ix01.html
+share/doc/streamtuner/left.png
+share/doc/streamtuner/overview.html
+share/doc/streamtuner/right.png
+share/doc/streamtuner/streamtuner-STHandler.html
+share/doc/streamtuner/streamtuner-STPlugin.html
+share/doc/streamtuner/streamtuner-st-action-api.html
+share/doc/streamtuner/streamtuner-st-category-api.html
+share/doc/streamtuner/streamtuner-st-dialog-api.html
+share/doc/streamtuner/streamtuner-st-handler-field-api.html
+share/doc/streamtuner/streamtuner-st-handlers-api.html
+share/doc/streamtuner/streamtuner-st-m3u-api.html
+share/doc/streamtuner/streamtuner-st-pls-api.html
+share/doc/streamtuner/streamtuner-st-programs-api.html
+share/doc/streamtuner/streamtuner-st-re-api.html
+share/doc/streamtuner/streamtuner-st-settings-api.html
+share/doc/streamtuner/streamtuner-st-sgml-ref-api.html
+share/doc/streamtuner/streamtuner-st-state-api.html
+share/doc/streamtuner/streamtuner-st-stream-api.html
+share/doc/streamtuner/streamtuner-st-transfer-api.html
+share/doc/streamtuner/streamtuner-st-util-api.html
+share/doc/streamtuner/streamtuner-st-version-api.html
+share/doc/streamtuner/streamtuner.devhelp
+share/doc/streamtuner/up.png
share/gnome/applications/streamtuner.desktop
-share/gnome/doc/streamtuner/C/documentation-license.xml
-share/gnome/doc/streamtuner/C/figures/main-window.png
-share/gnome/doc/streamtuner/C/software-license.xml
-share/gnome/doc/streamtuner/C/streamtuner.xml
+share/gnome/help/streamtuner/C/documentation-license.xml
+share/gnome/help/streamtuner/C/figures/main-window.png
+share/gnome/help/streamtuner/C/software-license.xml
+share/gnome/help/streamtuner/C/streamtuner.xml
share/gnome/omf/streamtuner/streamtuner-C.omf
@exec scrollkeeper-install -q %D/share/gnome/omf/streamtuner/streamtuner-C.omf 2>/dev/null || /usr/bin/true
share/gnome/pixmaps/streamtuner.png
+share/gnome/streamtuner/ui/applications.png
+share/gnome/streamtuner/ui/bookmarks.png
+share/gnome/streamtuner/ui/browse.png
+share/gnome/streamtuner/ui/category-open-running.png
+share/gnome/streamtuner/ui/category-open.png
+share/gnome/streamtuner/ui/category-running.png
+share/gnome/streamtuner/ui/category.png
+%%LIVE365%%share/gnome/streamtuner/ui/live365.png
+%%LOCAL%%share/gnome/streamtuner/ui/local.png
+share/gnome/streamtuner/ui/logo.png
+share/gnome/streamtuner/ui/main-category-running.png
+share/gnome/streamtuner/ui/main-category.png
+share/gnome/streamtuner/ui/preselections.png
+%%PYTHON%%share/gnome/streamtuner/ui/python.png
+share/gnome/streamtuner/ui/record.png
+share/gnome/streamtuner/ui/search-category-running.png
+share/gnome/streamtuner/ui/search-category.png
+share/gnome/streamtuner/ui/search.png
+%%SHOUTCAST%%share/gnome/streamtuner/ui/shoutcast.png
+share/gnome/streamtuner/ui/streamtuner.png
+share/gnome/streamtuner/ui/tune-in.png
+%%XIPH%%share/gnome/streamtuner/ui/xiph.png
%%PYTHON%%share/gnome/streamtuner/python/icons/basic.ch.png
%%PYTHON%%share/gnome/streamtuner/python/icons/google-stations.png
%%PYTHON%%share/gnome/streamtuner/python/icons/punkcast.com.png
@@ -40,16 +92,19 @@ share/gnome/pixmaps/streamtuner.png
share/locale/de/LC_MESSAGES/streamtuner.mo
share/locale/fr/LC_MESSAGES/streamtuner.mo
share/locale/hu/LC_MESSAGES/streamtuner.mo
+share/locale/ja/LC_MESSAGES/streamtuner.mo
share/locale/pt/LC_MESSAGES/streamtuner.mo
@dirrm include/streamtuner
@dirrm lib/streamtuner/plugins
@dirrm lib/streamtuner
-@dirrm share/gnome/doc/streamtuner/C/figures
-@dirrm share/gnome/doc/streamtuner/C
-@dirrm share/gnome/doc/streamtuner
+@dirrm share/doc/streamtuner
+@dirrm share/gnome/help/streamtuner/C/figures
+@dirrm share/gnome/help/streamtuner/C
+@dirrm share/gnome/help/streamtuner
@dirrm share/gnome/omf/streamtuner
@unexec scrollkeeper-uninstall -q %D/share/gnome/omf/streamtuner/streamtuner-C.omf 2>/dev/null || /usr/bin/true
+@dirrm share/gnome/streamtuner/ui
%%PYTHON%%@dirrm share/gnome/streamtuner/python/icons
%%PYTHON%%@dirrm share/gnome/streamtuner/python/scripts
%%PYTHON%%@dirrm share/gnome/streamtuner/python
-%%PYTHON%%@dirrm share/gnome/streamtuner
+@dirrm share/gnome/streamtuner