aboutsummaryrefslogtreecommitdiff
path: root/audio/sweep/Makefile
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2000-10-23 07:29:48 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2000-10-23 07:29:48 +0000
commitae034e6ce2bef93ac1f3e8268b830fc81848133d (patch)
tree6741fc25684ac188c37e2ff9c91b5d825efc1471 /audio/sweep/Makefile
parentc03270e4e794adb70278ee88df8768777af02ea4 (diff)
downloadports-ae034e6ce2bef93ac1f3e8268b830fc81848133d.tar.gz
ports-ae034e6ce2bef93ac1f3e8268b830fc81848133d.zip
Notes
Diffstat (limited to 'audio/sweep/Makefile')
-rw-r--r--audio/sweep/Makefile15
1 files changed, 3 insertions, 12 deletions
diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index b3188e2812c6..840ab6ab0b91 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -6,28 +6,19 @@
#
PORTNAME= sweep
-PORTVERSION= 0.0.9
+PORTVERSION= 0.1.1
CATEGORIES= audio gnome
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= sobomax@FreeBSD.org
-LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
-RUN_DEPENDS= panel:${PORTSDIR}/x11/gnomecore
-
USE_X_PREFIX= yes
+USE_GNOME= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
-GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
-GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
-
-CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
- --datadir=${PREFIX}/share/gnome
-CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" \
- GTK_CONFIG="${GTK_CONFIG}" \
- CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
MAN1= sweep.1