aboutsummaryrefslogtreecommitdiff
path: root/audio/sweep
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2007-10-24 23:37:25 +0000
commit4acc6fb2a411b291c9c210d82bafe7c62e71c77d (patch)
treebc16420eb52d65511ceb520c00171d219210a473 /audio/sweep
parent97dfcc1b41c5b4581b1d73128a866beec069c5bf (diff)
downloadports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.tar.gz
ports-4acc6fb2a411b291c9c210d82bafe7c62e71c77d.zip
Notes
Diffstat (limited to 'audio/sweep')
-rw-r--r--audio/sweep/Makefile29
-rw-r--r--audio/sweep/distinfo6
-rw-r--r--audio/sweep/pkg-plist20
3 files changed, 34 insertions, 21 deletions
diff --git a/audio/sweep/Makefile b/audio/sweep/Makefile
index cf5312762c0f..65e916cb55c5 100644
--- a/audio/sweep/Makefile
+++ b/audio/sweep/Makefile
@@ -6,37 +6,36 @@
#
PORTNAME= sweep
-PORTVERSION= 0.9.2
+PORTVERSION= 0.9.1
+PORTREVISION= 5
CATEGORIES= audio gnome
-MASTER_SITES= SF
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A sound editor for the GNOME/GTK 2.0 desktop
-LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
+LIB_DEPENDS= sndfile.1:${PORTSDIR}/audio/libsndfile \
samplerate.1:${PORTSDIR}/audio/libsamplerate \
- sndfile.1:${PORTSDIR}/audio/libsndfile \
vorbis.4:${PORTSDIR}/audio/libvorbis \
- speex.1:${PORTSDIR}/audio/speex
+ speex.1:${PORTSDIR}/audio/speex \
+ mad.2:${PORTSDIR}/audio/mad
USE_BZIP2= yes
-USE_GNOME= gnomehack gnometarget gtk20
+USE_X_PREFIX= yes
USE_GETTEXT= yes
+USE_GNOME= gnomehack gnomeprefix gnometarget gtk20
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool:15
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-extralibdir=${LOCALBASE}/lib \
--with-extraincdir=${LOCALBASE}/include \
- --with-vorbis-libraries=${LOCALBASE}/lib \
- --with-vorbis-includes=${LOCALBASE}/include/vorbis \
- --with-ogg-libraries=${LOCALBASE}/lib \
- --with-ogg-includes=${LOCALBASE}/include/ogg
+ --with-vorbis=${LOCALBASE}/lib \
+ --with-vorbis=${LOCALBASE}/include/vorbis \
+ --with-ogg=${LOCALBASE}/lib \
+ --with-ogg=${LOCALBASE}/include/ogg
MAN1= sweep.1
-post-patch:
- @${REINPLACE_CMD} -e 's|^ac_enable_alsa=yes|ac_enable_alsa=no|g ; \
- s|$${datadir}|$${datarootdir}|g' ${WRKSRC}/configure
-
.include <bsd.port.mk>
diff --git a/audio/sweep/distinfo b/audio/sweep/distinfo
index a73361a03944..59f323918825 100644
--- a/audio/sweep/distinfo
+++ b/audio/sweep/distinfo
@@ -1,3 +1,3 @@
-MD5 (sweep-0.9.2.tar.bz2) = 285e04b950dda85639f13aaac86153a0
-SHA256 (sweep-0.9.2.tar.bz2) = 33f8a57b38d141e4892da807be8f4e0f99869f1414977a5e36715d1e6d673b77
-SIZE (sweep-0.9.2.tar.bz2) = 885375
+MD5 (sweep-0.9.1.tar.bz2) = 7c346e28ff09c4a4f529a607ffd165f9
+SHA256 (sweep-0.9.1.tar.bz2) = 68ba9d32d3c3ed72d8d91a9aa8a845ec4c79aaf1da67c4db2ba705d9bddc925f
+SIZE (sweep-0.9.1.tar.bz2) = 898641
diff --git a/audio/sweep/pkg-plist b/audio/sweep/pkg-plist
index 40273840278a..93c9fef8d5e4 100644
--- a/audio/sweep/pkg-plist
+++ b/audio/sweep/pkg-plist
@@ -9,13 +9,27 @@ include/sweep/sweep_typeconvert.h
include/sweep/sweep_types.h
include/sweep/sweep_undo.h
include/sweep/sweep_version.h
+lib/sweep/libbyenergy.a
+lib/sweep/libbyenergy.la
lib/sweep/libbyenergy.so
+lib/sweep/libecho.a
+lib/sweep/libecho.la
lib/sweep/libecho.so
+lib/sweep/libfade.a
+lib/sweep/libfade.la
lib/sweep/libfade.so
+lib/sweep/libladspameta.a
+lib/sweep/libladspameta.la
lib/sweep/libladspameta.so
+lib/sweep/libnormalise.a
+lib/sweep/libnormalise.la
lib/sweep/libnormalise.so
+lib/sweep/libreverse.a
+lib/sweep/libreverse.la
lib/sweep/libreverse.so
share/applications/sweep.desktop
+share/pixmaps/sweep.svg
+share/sweep/sweep_logo.ppm
share/locale/de/LC_MESSAGES/sweep.mo
share/locale/el/LC_MESSAGES/sweep.mo
share/locale/en_AU/LC_MESSAGES/sweep.mo
@@ -25,9 +39,9 @@ share/locale/hu/LC_MESSAGES/sweep.mo
share/locale/it/LC_MESSAGES/sweep.mo
share/locale/pl/LC_MESSAGES/sweep.mo
share/locale/ru/LC_MESSAGES/sweep.mo
-share/pixmaps/sweep.svg
-%%DATADIR%%/sweep_splash.png
-@dirrm %%DATADIR%%
+@dirrm share/sweep
@dirrm lib/sweep
@dirrm include/sweep
+@exec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
+@unexec %%LOCALBASE%%/bin/update-desktop-database > /dev/null || /usr/bin/true
@dirrmtry share/applications