aboutsummaryrefslogtreecommitdiff
path: root/audio/swhplugins/Makefile
diff options
context:
space:
mode:
authorKris Kennaway <kris@FreeBSD.org>2004-03-28 00:04:13 +0000
committerKris Kennaway <kris@FreeBSD.org>2004-03-28 00:04:13 +0000
commit08492c52f4d83cab2ee1a128bafc024a8c183563 (patch)
tree2b76b70864ae8a28e4d25d9182a2c29b6575af8a /audio/swhplugins/Makefile
parent67038eaa4d2ed258d38cb03cb843669a3c5aa8d5 (diff)
downloadports-08492c52f4d83cab2ee1a128bafc024a8c183563.tar.gz
ports-08492c52f4d83cab2ee1a128bafc024a8c183563.zip
Notes
Diffstat (limited to 'audio/swhplugins/Makefile')
-rw-r--r--audio/swhplugins/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index 21d841d99731..81b129d8a6e5 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -20,7 +20,6 @@ LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
# includes assember code
ONLY_FOR_ARCHS= i386 amd64
-USE_GETTEXT= yes
USE_REINPLACE= yes
USE_GMAKE= yes
USE_LIBTOOL_VER= 13
@@ -31,6 +30,14 @@ CONFIGURE_ENV= CPPFLAGS="-fPIC -I${LOCALBASE}/include" \
CONFIGURE_ARGS+= --with-libintl-prefix=${LOCALBASE}
INSTALLS_SHLIB= yes
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^CFLAGS=|#CFLAGS=|g ; \
s|INCLUDED_LIBINTL=yes|INCLUDED_LIBINTL=no|g ; \