aboutsummaryrefslogtreecommitdiff
path: root/audio/swhplugins/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2006-12-05 10:49:45 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2006-12-05 10:49:45 +0000
commitec60d52749c5628992556bc202a3c224fec1d906 (patch)
tree262042ff1d02173af99bbfcf6ed458e35a37ba81 /audio/swhplugins/Makefile
parentcbed17d2280139f014662c8a4b3dd440422bb415 (diff)
Notes
Diffstat (limited to 'audio/swhplugins/Makefile')
-rw-r--r--audio/swhplugins/Makefile29
1 files changed, 19 insertions, 10 deletions
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index bd5f259fc0c0..6ab48317b0a7 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= swhplugins
-PORTVERSION= 0.4.14
-PORTREVISION= 1
+PORTVERSION= 0.4.15
CATEGORIES= audio
MASTER_SITES= http://plugin.org.uk/releases/%SUBDIR%/
MASTER_SITE_SUBDIR= ${PORTVERSION}
@@ -24,23 +23,33 @@ ONLY_FOR_ARCHS= i386 amd64
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
+CPPFLAGS= -I${LOCALBASE}/include
+LDFLAGS= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
USE_LDCONFIG= yes
CFLAGS+= -fPIC -DPIC
-.if defined(WITH_3DNOW)
-CONFIGURE_ARGS+= --enable-3dnow
-.endif
-
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
+LDFLAGS+= -lintl
+.endif
+
+OPTIONS= 3DNOW "use 3DNow! instructions" off \
+ SSE "use SSE instructions" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_3DNOW)
+CONFIGURE_ARGS+= --enable-3dnow
+.endif
+
+.if defined(WITH_SSE)
+CONFIGURE_ARGS+= --enable-sse
.endif
post-patch:
@@ -49,4 +58,4 @@ post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<inttypes.h>|g' ${WRKSRC}/ladspa-util.h
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>