aboutsummaryrefslogtreecommitdiff
path: root/audio/swhplugins
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 12:17:20 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2012-06-01 12:17:20 +0000
commit296f94764ca98c2d63230b50258d84ebbd017475 (patch)
treee9f19d26a84a628d85da08663a6faf2b0af6c75a /audio/swhplugins
parentc7cbbb763127d34cf3a60d61bd2385a792cad7bf (diff)
downloadports-296f94764ca98c2d63230b50258d84ebbd017475.tar.gz
ports-296f94764ca98c2d63230b50258d84ebbd017475.zip
Notes
Diffstat (limited to 'audio/swhplugins')
-rw-r--r--audio/swhplugins/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/audio/swhplugins/Makefile b/audio/swhplugins/Makefile
index e1415dfaa8b7..a4dccee2d6b8 100644
--- a/audio/swhplugins/Makefile
+++ b/audio/swhplugins/Makefile
@@ -31,25 +31,25 @@ USE_LDCONFIG= yes
CFLAGS+= -fPIC -DPIC
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
-PLIST_SUB+= NLS="@comment "
-.else
+OPTIONS_DEFINE= NLS 3DNOW SSE
+3DNOW_DESC= use 3DNow! instructions
+SSE_DESC= use SSE instructions
+
+.include <bsd.port.options.mk>
+.if ${PORT_OPTIONS:MNLS}
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
LDFLAGS+= -lintl
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
.endif
-OPTIONS= 3DNOW "use 3DNow! instructions" off \
- SSE "use SSE instructions" off
-
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_3DNOW)
+.if ${PORT_OPTIONS:M3DNOW}
CONFIGURE_ARGS+= --enable-3dnow
.endif
-.if defined(WITH_SSE)
+.if ${PORT_OPTIONS:MSSE}
CONFIGURE_ARGS+= --enable-sse
.endif
@@ -59,4 +59,4 @@ post-patch:
@${REINPLACE_CMD} -e \
's|<stdint\.h>|<inttypes.h>|g' ${WRKSRC}/ladspa-util.h
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>