aboutsummaryrefslogtreecommitdiff
path: root/audio/synthpod-lv2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-04-08 00:59:49 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-04-08 00:59:49 +0000
commit70cbed48736fc9ee48ff8b88a554ff1075b862f7 (patch)
treee126871f076a0fe42fc51e06e2e5081bd6139008 /audio/synthpod-lv2
parente39485aea37a0934e0f2a68329102e5c81bfc6da (diff)
downloadports-70cbed48736fc9ee48ff8b88a554ff1075b862f7.tar.gz
ports-70cbed48736fc9ee48ff8b88a554ff1075b862f7.zip
Notes
Diffstat (limited to 'audio/synthpod-lv2')
-rw-r--r--audio/synthpod-lv2/Makefile85
-rw-r--r--audio/synthpod-lv2/distinfo6
-rw-r--r--audio/synthpod-lv2/files/patch-CMakeLists.txt39
-rw-r--r--audio/synthpod-lv2/pkg-plist58
4 files changed, 63 insertions, 125 deletions
diff --git a/audio/synthpod-lv2/Makefile b/audio/synthpod-lv2/Makefile
index d26d36a15ed0..32c16bee4ae3 100644
--- a/audio/synthpod-lv2/Makefile
+++ b/audio/synthpod-lv2/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= synthpod
-PORTVERSION= g20170810
-PORTREVISION= 4
+PORTVERSION= g20190407
CATEGORIES= audio
PKGNAMESUFFIX= -lv2
@@ -19,68 +18,50 @@ LIB_DEPENDS= liblilv-0.so:audio/lilv \
libsord-0.so:devel/sord \
libsratom-0.so:audio/sratom
-USES= cmake:insource compiler:c++11-lib pkgconfig localbase
+USES= meson compiler:c++11-lib pkgconfig localbase
USE_GITHUB= yes
GH_ACCOUNT= OpenMusicKontrollers
-GH_TAGNAME= 07cae54
+GH_TAGNAME= 01aad91
USE_CXXSTD= c++11
-CMAKE_OFF= BUILD_ALSA BUILD_SANDBOX_QT4
+MESON_ARGS= -Duse-alsa=false -Duse-qt4=false
-OPTIONS_DEFINE= JACK DUMMY DOT
-OPTIONS_DEFAULT=JACK X11 SHOW KX
-OPTIONS_GROUP= UI
-OPTIONS_GROUP_UI= X11 GTK2 GTK3 QT5 SHOW KX
-OPTIONS_SUB= yes
+OPTIONS_DEFINE= JACK DUMMY
+OPTIONS_DEFAULT= JACK X11
+OPTIONS_GROUP= UI
+OPTIONS_GROUP_UI= X11 GTK2 GTK3 QT
+OPTIONS_SUB= yes
-DUMMY_DESC= Build DUMMY standalone host
-DOT_DESC= Build Dot exporter
-KX_DESC= Build external-ui sandbox
-JACK_DESC= Build JACK standalone host
-X11_DESC= Build X11 sandbox
-GTK2_DESC= Build GTK-2 sandbox
-GTK3_DESC= Build GTK-3 sandbox
-QT5_DESC= Build Qt-5 sandbox
-SHOW_DESC= Build show-iface sandbox
-
-DOT_CMAKE_ON= -DBUILD_DOT="ON"
-DUMMY_CMAKE_ON= -DBUILD_DUMMY="ON"
+DUMMY_DESC= Build DUMMY standalone host
+DUMMY_MESON_OFF= -Duse-dummy=false
DUMMY_LIB_DEPENDS= libuv.so:devel/libuv
-GTK2_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_GTK2="ON"
+
+GTK2_DESC= Build GTK-2 sandbox
+GTK2_MESON_OFF= -Duse-gtk2=false
GTK2_LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2
-GTK2_USES= gl gnome
-GTK2_USE= XORG=x11,xcb,xext GL=gl,glu GNOME=glib20,gtk20,gdkpixbuf2,atk,cairo,pango gettext-runtime
-GTK3_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_GTK3="ON"
-GTK3_USES= gl gnome
-GTK3_USE= XORG=x11,xcb,xext GL=glu GNOME=glib20,gtk30,gdkpixbuf2,atk,cairo,pango gettext-runtime
+GTK2_USES= gl gnome
+GTK2_USE= XORG=x11,xcb,xext GL=gl,glu GNOME=glib20,gtk20,gdkpixbuf2,atk,cairo,pango gettext-runtime
+
+GTK3_DESC= Build GTK-3 sandbox
+GTK3_MESON_OFF= -Duse-gtk3=false
+GTK3_USES= gl gnome
+GTK3_USE= XORG=x11,xcb,xext GL=glu GNOME=glib20,gtk30,gdkpixbuf2,atk,cairo,pango gettext-runtime
+
+JACK_DESC= Build JACK standalone host
JACK_LIB_DEPENDS= libjack.so:audio/jack \
libuv.so:devel/libuv
-JACK_CMAKE_OFF= -DBUILD_JACK="OFF"
-KX_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_KX="ON"
-KX_USES= gl
-KX_USE= XORG=x11,xcb,xext GL=glu
-QT5_USES= qt:5
-QT5_BROKEN= Build fails: https://github.com/OpenMusicKontrollers/synthpod/issues/10
-QT5_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_QT5="ON"
-QT5_USE= XORG=x11,xcb,xext GL=glu QT=core,gui
-SHOW_USES= gl
-SHOW_USE= XORG=x11,xcb,xext GL=glu
-SHOW_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_SHOW="ON"
-X11_CMAKE_ON= -DBUILD_UI="ON" -DBUILD_SANDBOX_X11="ON"
-X11_LIB_DEPENDS= libxcb-icccm.so:x11/xcb-util-wm
-X11_USES= gl
-X11_USE= XORG=x11,xcb,xext GL=gl,glu
-
-.include <bsd.port.options.mk>
+JACK_MESON_OFF= -Duse-jack=false
-.if ${PORT_OPTIONS:MX11} || ${PORT_OPTIONS:MGTK2} || ${PORT_OPTIONS:MGTK3} || ${PORT_OPTIONS:MQT5} || ${PORT_OPTIONS:MSHOW} || ${PORT_OPTIONS:MKX}
-PLIST_SUB+= UI=""
-.else
-PLIST_SUB+= UI="@comment "
-.endif
+QT_DESC= Build Qt-5 sandbox
+QT_USES= qt:5
+QT_MESON_OFF= -Duse-qt5=false
+QT_USE= QT=core,widgets
-post-patch:
- @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/bin/CMakeLists.txt
+X11_DESC= Build X11 sandbox
+X11_MESON_OFF= -Duse-x11=false
+X11_LIB_DEPENDS= libxcb-icccm.so:x11/xcb-util-wm
+X11_USES= gnome
+X11_USE= XORG=xcb GNOME=cairo
.include <bsd.port.mk>
diff --git a/audio/synthpod-lv2/distinfo b/audio/synthpod-lv2/distinfo
index ea65f202295f..a88ff2ba09e7 100644
--- a/audio/synthpod-lv2/distinfo
+++ b/audio/synthpod-lv2/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1503280076
-SHA256 (OpenMusicKontrollers-synthpod-g20170810-07cae54_GH0.tar.gz) = 319dc6ababcf867cd7ae628931b1c99fba842d634245675ac600d611a4df362d
-SIZE (OpenMusicKontrollers-synthpod-g20170810-07cae54_GH0.tar.gz) = 2336518
+TIMESTAMP = 1554680643
+SHA256 (OpenMusicKontrollers-synthpod-g20190407-01aad91_GH0.tar.gz) = ce8ebecc26ba90df7b9261c8212753c1b8fcd981520d3ca8616e28a526d0d126
+SIZE (OpenMusicKontrollers-synthpod-g20190407-01aad91_GH0.tar.gz) = 2387590
diff --git a/audio/synthpod-lv2/files/patch-CMakeLists.txt b/audio/synthpod-lv2/files/patch-CMakeLists.txt
deleted file mode 100644
index a3efaee39e34..000000000000
--- a/audio/synthpod-lv2/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,39 +0,0 @@
---- CMakeLists.txt.orig 2017-08-06 12:24:04 UTC
-+++ CMakeLists.txt
-@@ -34,6 +34,15 @@ include_directories(${PROJECT_SOURCE_DIR
- include_directories(${PROJECT_SOURCE_DIR}/zero_worker.lv2)
- include_directories(${PROJECT_SOURCE_DIR}/zero_writer.lv2)
-
-+# FreeBSD: clock_nanosleep was missing and was added to 11-STABLE in r317618
-+CHECK_FUNCTION_EXISTS(clock_nanosleep HAVE_CLOCK_NANOSLEEP_FUNCTION)
-+if(${HAVE_CLOCK_NANOSLEEP_FUNCTION})
-+ MESSAGE("-- FreeBSD: clock_nanosleep exists")
-+else()
-+ MESSAGE("-- FreeBSD: clock_nanosleep DOES NOT EXIST and will be replaced with nanosleep")
-+ execute_process(COMMAND sed -i'.bak' -E "s|clock_nanosleep\\\(CLOCK_[A-Z]+, TIMER_ABSTIME, |nanosleep\\\(|" bin/synthpod_dummy.c bin/synthpod_sandbox_show.c bin/synthpod_sandbox_kx.c)
-+endif()
-+
- set(SYNTHPOD_BIN_DIR "bin")
- add_definitions("-DSYNTHPOD_BIN_DIR=\"${CMAKE_INSTALL_PREFIX}/${SYNTHPOD_BIN_DIR}/\"")
-
-@@ -92,16 +101,16 @@ option(BUILD_DUMMY "Build DUMMY standalo
-
- option(BUILD_DOT "Build Dot exporter" OFF)
-
--option(BUILD_UI "Build graphical user interface(s)" ON)
-+option(BUILD_UI "Build graphical user interface(s)" OFF)
-
- include(CMakeDependentOption)
--cmake_dependent_option(BUILD_SANDBOX_X11 "Build X11 sandbox" ON "BUILD_UI" OFF)
-+cmake_dependent_option(BUILD_SANDBOX_X11 "Build X11 sandbox" OFF "BUILD_UI" OFF)
- cmake_dependent_option(BUILD_SANDBOX_GTK2 "Build GTK-2 sandbox" OFF "BUILD_UI" OFF)
- cmake_dependent_option(BUILD_SANDBOX_GTK3 "Build GTK-3 sandbox" OFF "BUILD_UI" OFF)
- cmake_dependent_option(BUILD_SANDBOX_QT4 "Build Qt-4 sandbox" OFF "BUILD_UI" OFF)
- cmake_dependent_option(BUILD_SANDBOX_QT5 "Build Qt-5 sandbox" OFF "BUILD_UI" OFF)
--cmake_dependent_option(BUILD_SANDBOX_SHOW "Build show-iface sandbox" ON "BUILD_UI" OFF)
--cmake_dependent_option(BUILD_SANDBOX_KX "Build external-ui sandbox" ON "BUILD_UI" OFF)
-+cmake_dependent_option(BUILD_SANDBOX_SHOW "Build show-iface sandbox" OFF "BUILD_UI" OFF)
-+cmake_dependent_option(BUILD_SANDBOX_KX "Build external-ui sandbox" OFF "BUILD_UI" OFF)
-
- if(BUILD_SANDBOX_X11)
- add_definitions("-DSANDBOX_X11")
diff --git a/audio/synthpod-lv2/pkg-plist b/audio/synthpod-lv2/pkg-plist
index 2c0454b07065..fcb97c83ad8b 100644
--- a/audio/synthpod-lv2/pkg-plist
+++ b/audio/synthpod-lv2/pkg-plist
@@ -1,46 +1,42 @@
%%DUMMY%%bin/synthpod_dummy
-%%DOT%%bin/synthpod_dot
%%JACK%%bin/synthpod_jack
%%X11%%bin/synthpod_sandbox_x11
%%GTK2%%bin/synthpod_sandbox_gtk2
%%GTK3%%bin/synthpod_sandbox_gtk3
-%%QT5%%bin/synthpod_sandbox_qt5
-%%SHOW%%bin/synthpod_sandbox_show
-%%KX%%bin/synthpod_sandbox_kx
+%%QT%%bin/synthpod_sandbox_qt5
+bin/synthpod_sandbox_show
+bin/synthpod_sandbox_kx
%%X11%%bin/synthpod_ui
-%%UI%%lib/lv2/synthpod.lv2/Abel-Regular.ttf
-%%UI%%lib/lv2/synthpod.lv2/synthpod_nk.so
+%%X11%%lib/lv2/synthpod.lv2/synthpod_nk.so
+lib/lv2/synthpod.lv2/Abel-Regular.ttf
+lib/lv2/synthpod.lv2/atom.png
+lib/lv2/synthpod.lv2/atom_inverted.png
+lib/lv2/synthpod.lv2/audio.png
+lib/lv2/synthpod.lv2/automaton.png
+lib/lv2/synthpod.lv2/cancel.png
+lib/lv2/synthpod.lv2/control.png
+lib/lv2/synthpod.lv2/cv.png
+lib/lv2/synthpod.lv2/download.png
+lib/lv2/synthpod.lv2/event.png
+lib/lv2/synthpod.lv2/event_inverted.png
+lib/lv2/synthpod.lv2/house.png
+lib/lv2/synthpod.lv2/layers.png
lib/lv2/synthpod.lv2/manifest.ttl
+lib/lv2/synthpod.lv2/menu.png
+lib/lv2/synthpod.lv2/midi.png
+lib/lv2/synthpod.lv2/osc.png
+lib/lv2/synthpod.lv2/patch.png
+lib/lv2/synthpod.lv2/plus.png
+lib/lv2/synthpod.lv2/settings.png
lib/lv2/synthpod.lv2/synthpod.so
lib/lv2/synthpod.lv2/synthpod.ttl
-lib/lv2/synthpod.lv2/synthpod_ui.ttl
+%%X11%%lib/lv2/synthpod.lv2/synthpod_ui.ttl
+lib/lv2/synthpod.lv2/time.png
+lib/lv2/synthpod.lv2/user.png
+lib/lv2/synthpod.lv2/xpress.png
lib/synthpod/lv2/manifest.ttl
lib/synthpod/lv2/synthpod_bundle.so
lib/synthpod/lv2/synthpod_bundle.ttl
-%%DUMMY%%share/applications/synthpod_dummy.desktop
-%%JACK%%share/applications/synthpod_jack.desktop
-%%JACK%%share/icons/hicolor/256x256/apps/synthpod.png
%%DUMMY%%man/man1/synthpod_dummy.1.gz
%%JACK%%man/man1/synthpod_jack.1.gz
%%X11%%man/man1/synthpod_sandbox.1.gz
-%%DATADIR%%/atom.png
-%%DATADIR%%/atom_inverted.png
-%%DATADIR%%/audio.png
-%%DATADIR%%/automaton.png
-%%DATADIR%%/cancel.png
-%%DATADIR%%/control.png
-%%DATADIR%%/cv.png
-%%DATADIR%%/download.png
-%%DATADIR%%/event.png
-%%DATADIR%%/event_inverted.png
-%%DATADIR%%/house.png
-%%DATADIR%%/layers.png
-%%DATADIR%%/menu.png
-%%DATADIR%%/midi.png
-%%DATADIR%%/osc.png
-%%DATADIR%%/patch.png
-%%DATADIR%%/plus.png
-%%DATADIR%%/settings.png
-%%DATADIR%%/time.png
-%%DATADIR%%/user.png
-%%DATADIR%%/xpress.png