aboutsummaryrefslogtreecommitdiff
path: root/audio/tap-plugins/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:19:27 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-14 12:19:27 +0000
commit0a8d279ab9228ffe7933ed45854feef7c329fc0f (patch)
treedd3e48348c9661347da3895e6c6bd989e1ced75c /audio/tap-plugins/Makefile
parent46a47408418d2c481cdd75ccc9833718837dd124 (diff)
Notes
Diffstat (limited to 'audio/tap-plugins/Makefile')
-rw-r--r--audio/tap-plugins/Makefile10
1 files changed, 5 insertions, 5 deletions
diff --git a/audio/tap-plugins/Makefile b/audio/tap-plugins/Makefile
index faf0b54f004f..e10eaa7a6b18 100644
--- a/audio/tap-plugins/Makefile
+++ b/audio/tap-plugins/Makefile
@@ -5,7 +5,7 @@
# $FreeBSD$
PORTNAME= tap-plugins
-PORTVERSION= 0.5.0
+PORTVERSION= 0.6.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= tap-plugins
@@ -14,12 +14,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= LADSPA Plugins by Tom Szilagy
USE_REINPLACE= yes
-INSTALLS_SHLIB= yes
+MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS} -I. -c -fPIC -DPIC" \
+ LDFLAGS="-nostartfiles -shared -Wl,-Bsymbolic -lm"
post-patch:
- ${REINPLACE_CMD} -e "s,-lrt,,; \
- s,-O3 -Wall -fomit-frame-pointer -fstrength-reduce -funroll-loops -ffast-math,${CFLAGS}," \
- ${WRKSRC}/Makefile
+ @${GREP} -lR "<stdint\.h>" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|<stdint\.h>|<inttypes.h>|g'
do-install:
${MKDIR} ${PREFIX}/lib/ladspa