aboutsummaryrefslogtreecommitdiff
path: root/audio/tcd
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-06-26 23:31:04 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-06-26 23:31:04 +0000
commit07db9b1ac3e028ed0567c466b0480ee092a201bc (patch)
treeec6ee5cd6ed49a981b3ff4034ab5e2196a823091 /audio/tcd
parentade2790f00076ce0624696d05230997f2fec2e32 (diff)
downloadports-07db9b1ac3e028ed0567c466b0480ee092a201bc.tar.gz
ports-07db9b1ac3e028ed0567c466b0480ee092a201bc.zip
Notes
Diffstat (limited to 'audio/tcd')
-rw-r--r--audio/tcd/Makefile1
-rw-r--r--audio/tcd/files/patch-tcd.c11
-rw-r--r--audio/tcd/files/patch-tcd_mb.c2
-rw-r--r--audio/tcd/files/patch-tcd_mb.h2
4 files changed, 11 insertions, 5 deletions
diff --git a/audio/tcd/Makefile b/audio/tcd/Makefile
index c89d48409dad..47fd1c2eb603 100644
--- a/audio/tcd/Makefile
+++ b/audio/tcd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= tcd
PORTVERSION= 2.2.0
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/audio/tcd/files/patch-tcd.c b/audio/tcd/files/patch-tcd.c
index dc61a4e5750f..0a2a2af92778 100644
--- a/audio/tcd/files/patch-tcd.c
+++ b/audio/tcd/files/patch-tcd.c
@@ -1,6 +1,11 @@
---- src/tcd.c.orig 2008-06-26 19:40:23.000000000 +0200
-+++ src/tcd.c 2008-06-26 19:40:47.000000000 +0200
-@@ -221,7 +221,7 @@
+--- src/tcd.c.orig 2004-06-15 22:32:31.000000000 +0200
++++ src/tcd.c 2008-06-27 01:25:01.000000000 +0200
+@@ -217,11 +217,11 @@
+ static void detect_disc_change(void)
+ {
+ unsigned long discid = cddb_discid(state.cdrom);
+- if (discid != state.current_discid) {
++ if (CD_INDRIVE(state.cdrom->status) && discid != state.current_discid) {
if (state.cd_info.modified) {
tcd_writediskinfo(&state.cd_info, state.cdrom);
}
diff --git a/audio/tcd/files/patch-tcd_mb.c b/audio/tcd/files/patch-tcd_mb.c
index abdf65532c14..cd42d1c0572c 100644
--- a/audio/tcd/files/patch-tcd_mb.c
+++ b/audio/tcd/files/patch-tcd_mb.c
@@ -2,7 +2,7 @@
+++ src/tcd_mb.c 2008-06-26 21:43:09.000000000 +0200
@@ -0,0 +1,98 @@
+/*-
-+ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.ch>
++ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.org>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
diff --git a/audio/tcd/files/patch-tcd_mb.h b/audio/tcd/files/patch-tcd_mb.h
index 1e9aa881929c..aaa59bd4f443 100644
--- a/audio/tcd/files/patch-tcd_mb.h
+++ b/audio/tcd/files/patch-tcd_mb.h
@@ -2,7 +2,7 @@
+++ src/tcd_mb.h 2008-06-26 19:37:19.000000000 +0200
@@ -0,0 +1,44 @@
+/*-
-+ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.ch>
++ * Copyright (c) 2008 Pietro Cerutti <gahr@FreeBSD.org>
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions