aboutsummaryrefslogtreecommitdiff
path: root/audio/tepsonic
diff options
context:
space:
mode:
authorDennis Herrmann <dhn@FreeBSD.org>2011-04-04 19:18:51 +0000
committerDennis Herrmann <dhn@FreeBSD.org>2011-04-04 19:18:51 +0000
commitfa4241daa16a1906fa1ebda7c0b219ed08c8451b (patch)
tree7fa8f9d66c85f43eb8dd618b20981b618ac2eb97 /audio/tepsonic
parent7b560971012d3cd75f47018bffba6781660071d5 (diff)
downloadports-fa4241daa16a1906fa1ebda7c0b219ed08c8451b.tar.gz
ports-fa4241daa16a1906fa1ebda7c0b219ed08c8451b.zip
Notes
Diffstat (limited to 'audio/tepsonic')
-rw-r--r--audio/tepsonic/Makefile6
-rw-r--r--audio/tepsonic/distinfo4
-rw-r--r--audio/tepsonic/files/patch-player-3rdparty-CMakeLists.txt8
-rw-r--r--audio/tepsonic/files/patch-player-3rdparty-qxt-CMakeLists.txt10
-rw-r--r--audio/tepsonic/files/patch-player-CMakeLists.txt27
-rw-r--r--audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp15
-rw-r--r--audio/tepsonic/files/patch-player-playlist-playlistpopulator.cpp15
-rw-r--r--audio/tepsonic/pkg-plist4
8 files changed, 68 insertions, 21 deletions
diff --git a/audio/tepsonic/Makefile b/audio/tepsonic/Makefile
index 809aa291f53a..10b997ffb8ae 100644
--- a/audio/tepsonic/Makefile
+++ b/audio/tepsonic/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= tepsonic
-PORTVERSION= 0.97.0
+PORTVERSION= 0.98.2
CATEGORIES= audio
MASTER_SITES= http://www.tepsonic.org/files/
DISTNAME= ${PORTNAME}-${PORTVERSION}-src
@@ -28,4 +28,8 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
LICENSE= GPLv3
+post-patch:
+ ${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
+ ${WRKSRC}/3rdparty/qxt/CMakeLists.txt
+
.include <bsd.port.mk>
diff --git a/audio/tepsonic/distinfo b/audio/tepsonic/distinfo
index a20d615b5ea0..adf7698a1654 100644
--- a/audio/tepsonic/distinfo
+++ b/audio/tepsonic/distinfo
@@ -1,2 +1,2 @@
-SHA256 (tepsonic-0.97.0-src.tar.gz) = 0e9c115514deb0b7bc94c9382d67ae55abca52fe0661b7141ba5c8ed35835db0
-SIZE (tepsonic-0.97.0-src.tar.gz) = 679326
+SHA256 (tepsonic-0.98.2-src.tar.gz) = b7ac029f7979f32441535d5cba10b600eaddaccc6d40682239354fe16c98409a
+SIZE (tepsonic-0.98.2-src.tar.gz) = 792924
diff --git a/audio/tepsonic/files/patch-player-3rdparty-CMakeLists.txt b/audio/tepsonic/files/patch-player-3rdparty-CMakeLists.txt
new file mode 100644
index 000000000000..987d7a862739
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-3rdparty-CMakeLists.txt
@@ -0,0 +1,8 @@
+--- 3rdparty/CMakeLists.txt.orig 2011-04-02 21:21:16.000000000 +0800
++++ 3rdparty/CMakeLists.txt 2011-04-02 21:21:34.000000000 +0800
+@@ -1,3 +1,3 @@
+-if (NOT UNIX OR APPLE)
++#if (NOT UNIX OR APPLE)
+ add_subdirectory(qxt)
+-endif (NOT UNIX OR APPLE)
++#endif (NOT UNIX OR APPLE)
diff --git a/audio/tepsonic/files/patch-player-3rdparty-qxt-CMakeLists.txt b/audio/tepsonic/files/patch-player-3rdparty-qxt-CMakeLists.txt
new file mode 100644
index 000000000000..2f378c1d85ff
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-3rdparty-qxt-CMakeLists.txt
@@ -0,0 +1,10 @@
+--- 3rdparty/qxt/CMakeLists.txt.orig 2011-03-09 05:08:14.000000000 +0700
++++ 3rdparty/qxt/CMakeLists.txt 2011-04-02 22:57:57.000000000 +0800
+@@ -1,6 +1,7 @@
+ cmake_minimum_required(VERSION 2.6)
+
+ find_package(Qt4 REQUIRED)
++include_directories(%%LOCALBASE%%/include/)
+
+ include_directories(
+ ${QT_INCLUDE_DIR}
diff --git a/audio/tepsonic/files/patch-player-CMakeLists.txt b/audio/tepsonic/files/patch-player-CMakeLists.txt
new file mode 100644
index 000000000000..0a6f5380d9c5
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-CMakeLists.txt
@@ -0,0 +1,27 @@
+--- player/CMakeLists.txt.orig 2011-04-02 21:22:26.000000000 +0800
++++ player/CMakeLists.txt 2011-04-02 21:24:51.000000000 +0800
+@@ -16,20 +16,10 @@ find_package(Taglib REQUIRED)
+ find_package(Phonon REQUIRED)
+
+ # Use native libqxt on Linux and patched sources in /3rdparty/qxt on Mac an Win.
+-if (UNIX AND NOT APPLE)
+- set(QXT_USE_QXTCORE TRUE)
+- set(QXT_USE_QXTGUI TRUE)
+- find_package(Qxt REQUIRED)
+- set(QXT_HEADERS "")
+- set(QXT_SOURCES "")
+-else (UNIX AND NOT APPLE)
+- add_definitions(-DQXT_STATIC -DBUILD_QXT_GUI -DBUILD_QXT_CORE)
+- set(QXT_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/qxt)
+- set(QXT_LIBRARIES qxt)
+- set(QXT_HEADERS "../3rdparty/qxt/qxtglobalshortcuts.h")
+- set(QXT_SOURCES "../3rdparty/qxt/qxtglobalshortcuts.cpp")
+-endif (UNIX AND NOT APPLE)
+-
++add_definitions(-DQXT_STATIC -DBUILD_QXT_GUI -DBUILD_QXT_CORE)
++set(QXT_INCLUDE_DIRS ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/qxt)
++set(QXT_LIBRARIES qxt)
++set(QXT_HEADERS ${CMAKE_CURRENT_SOURCE_DIR}/../3rdparty/qxt/qxtglobalshortcut.h)
+
+
+ if (NOT DEFINED CMAKE_BUILD_TYPE)
diff --git a/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp b/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp
deleted file mode 100644
index 7604e44fc556..000000000000
--- a/audio/tepsonic/files/patch-player-playlist-playlistmodel.cpp
+++ /dev/null
@@ -1,15 +0,0 @@
---- player/playlist/playlistmodel.cpp.orig 2010-05-18 02:04:47.000000000 +0800
-+++ player/playlist/playlistmodel.cpp 2010-05-18 18:11:45.000000000 +0800
-@@ -21,9 +21,9 @@
- #include <QtGui>
- #include <QTime>
-
--#include <taglib/fileref.h>
--#include <taglib/tag.h>
--#include <taglib/tstring.h>
-+#include <fileref.h>
-+#include <tag.h>
-+#include <tstring.h>
-
- #include "playlistmodel.h"
- #include "playlistitem.h"
diff --git a/audio/tepsonic/files/patch-player-playlist-playlistpopulator.cpp b/audio/tepsonic/files/patch-player-playlist-playlistpopulator.cpp
new file mode 100644
index 000000000000..ef78cb9cc596
--- /dev/null
+++ b/audio/tepsonic/files/patch-player-playlist-playlistpopulator.cpp
@@ -0,0 +1,15 @@
+--- player/playlist/playlistpopulator.cpp.orig 2011-04-02 21:48:45.000000000 +0800
++++ player/playlist/playlistpopulator.cpp 2011-04-02 21:49:04.000000000 +0800
+@@ -31,9 +31,9 @@
+ #include <QSqlDriver>
+ #include <QSqlQuery>
+
+-#include <taglib/taglib.h>
+-#include <taglib/fileref.h>
+-#include <taglib/tag.h>
++#include <taglib.h>
++#include <fileref.h>
++#include <tag.h>
+
+ PlaylistPopulator::PlaylistPopulator()
+ {
diff --git a/audio/tepsonic/pkg-plist b/audio/tepsonic/pkg-plist
index 62d50e7cbc26..96df40352e6c 100644
--- a/audio/tepsonic/pkg-plist
+++ b/audio/tepsonic/pkg-plist
@@ -1,6 +1,6 @@
bin/tepsonic
lib/libtepsonic_lastfmscrobbler.so
-lib/libtepsonic_lastfmscrobbler.so.0.1.0
+lib/libtepsonic_lastfmscrobbler.so.0.2.0
lib/libtepsonic_lastfmscrobbler.so.1
share/applications/tepsonic.desktop
share/icons/hicolor/128x128/apps/tepsonic.png
@@ -9,8 +9,6 @@ share/icons/hicolor/256x256/apps/tepsonic.png
share/icons/hicolor/32x32/apps/tepsonic.png
share/icons/hicolor/48x48/apps/tepsonic.png
share/icons/hicolor/64x64/apps/tepsonic.png
-%%DATADIR%%/locale/tepsonic/cs.qm
-%%DATADIR%%/locale/lastfmscrobbler/cs.qm
@dirrm %%DATADIR%%/locale/tepsonic
@dirrm %%DATADIR%%/locale/lastfmscrobbler
@dirrm %%DATADIR%%/locale