aboutsummaryrefslogtreecommitdiff
path: root/audio/terminatorx/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-23 21:58:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-23 21:58:22 +0000
commitec7ade5ee8dc15f5c4adc3114a5d645e840d3622 (patch)
tree014048c02f33e6b57ef1d74a006b75a114bf3840 /audio/terminatorx/Makefile
parent4a4d7d01110df2f4e3cfb50ff5089082f655fd86 (diff)
downloadports-ec7ade5ee8dc15f5c4adc3114a5d645e840d3622.tar.gz
ports-ec7ade5ee8dc15f5c4adc3114a5d645e840d3622.zip
Notes
Diffstat (limited to 'audio/terminatorx/Makefile')
-rw-r--r--audio/terminatorx/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index b31d33bd19a8..a30aa8d671dc 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= terminatorx
-PORTVERSION= 3.80
-PORTREVISION= 1
+PORTVERSION= 3.81
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/dist/
DISTNAME= terminatorX-${PORTVERSION}
@@ -21,14 +20,13 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehier libxml2 gtk20
-USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomehier gnometarget gtk20 libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-docdir="${PREFIX}/share/gnome"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-alsa --disable-jack \
+ --with-docdir="${PREFIX}/share/gnome"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
@@ -77,10 +75,12 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|function option_info|option_info|g' ${WRKSRC}/configure
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${GREP} -lR "%%LOCALBASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g'
+ @${GREP} -lR "%%X11BASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%X11BASE%%|${LOCALBASE}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin