aboutsummaryrefslogtreecommitdiff
path: root/audio/terminatorx/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-01 21:16:35 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-01 21:16:35 +0000
commit7e2d94ec1a49dc44160fa66021cc7874049715b1 (patch)
treec384780db248a5a87cda42272a18593d3df7a97b /audio/terminatorx/Makefile
parentd96c7d1993a2332d23390ab80e388c42ee8022d7 (diff)
downloadports-7e2d94ec1a49dc44160fa66021cc7874049715b1.tar.gz
ports-7e2d94ec1a49dc44160fa66021cc7874049715b1.zip
Notes
Diffstat (limited to 'audio/terminatorx/Makefile')
-rw-r--r--audio/terminatorx/Makefile64
1 files changed, 44 insertions, 20 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 38f530907fe0..4ae6afa521d7 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -1,28 +1,49 @@
# New ports collection Makefile for: terminatorx
# Date created: 13 May 2002
-# Whom: Tilman Linneweh <freebsdports@arved.de
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= terminatorx
-PORTVERSION= 3.72
+PORTVERSION= 3.73
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/
DISTNAME= terminatorX-${PORTVERSION}
-MAINTAINER= freebsdports@arved.de
+MAINTAINER= ports@FreeBSD.org
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+
+USE_GNOMENG= yes
+USE_GNOME= gnomehier gnomelibs
+CONFIGURE_ARGS+= --disable-gtk2
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_SOX)
-BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
+BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
+CONFIGURE_ARGS+= --enable-sox
.endif
.if !defined(WITHOUT_VORBIS)
-BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+CONFIGURE_ARGS+= --enable-vorbis
+.endif
+.if !defined(WITHOUT_MAD)
+LIB_DEPENDS+= mad.1:${PORTSDIR}/audio/mad
+CONFIGURE_ARGS+= --enable-mad
.endif
-USE_GNOMENG= yes
-USE_GNOME= gtk12
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= terminatorX.1
pre-everything:
.if !defined(WITHOUT_SOX)
@@ -31,19 +52,22 @@ pre-everything:
.if !defined(WITHOUT_VORBIS)
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
.endif
+.if !defined(WITHOUT_MAD)
+ @${ECHO_MSG} "You can disable support for mad by defining WITHOUT_MAD."
+.endif
post-patch:
+ ${REINPLACE_CMD} -e "s,function option_info,option_info," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,malloc.h,stdlib.h," ${WRKSRC}/src/main.cc \
+ ${WRKSRC}/src/tX_audiofile.cc ${WRKSRC}/src/tX_flash.c \
+ ${WRKSRC}/src/tX_seqpar.cc ${WRKSRC}/src/tX_vtt.cc \
+ ${WRKSRC}/src/tX_widget.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/terminatorX.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX-mime.png ${WRKSRC}/gnome-support/terminatorX-app.png ${PREFIX}/share/gnome/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.mime ${WRKSRC}/gnome-support/terminatorX.keys ${PREFIX}/share/gnome/mime-info
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.desktop ${PREFIX}/share/gnome/apps/Multimedia/terminatorX.desktop
-.for i in main.cc \
- tX_audiofile.cc \
- tX_flash.c \
- tX_seqpar.cc \
- tX_vtt.cc \
- tX_widget.c
- ${MV} ${WRKSRC}/src/$i ${WRKSRC}/src/$i.sed
- ${SED} -e "s:malloc.h:stdlib.h:g" \
- ${WRKSRC}/src/$i.sed >${WRKSRC}/src/$i
- ${RM} ${WRKSRC}/src/$i.sed
-.endfor
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>