aboutsummaryrefslogtreecommitdiff
path: root/audio/terminatorx
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2003-01-01 21:16:35 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2003-01-01 21:16:35 +0000
commit7e2d94ec1a49dc44160fa66021cc7874049715b1 (patch)
treec384780db248a5a87cda42272a18593d3df7a97b /audio/terminatorx
parentd96c7d1993a2332d23390ab80e388c42ee8022d7 (diff)
downloadports-7e2d94ec1a49dc44160fa66021cc7874049715b1.tar.gz
ports-7e2d94ec1a49dc44160fa66021cc7874049715b1.zip
Notes
Diffstat (limited to 'audio/terminatorx')
-rw-r--r--audio/terminatorx/Makefile64
-rw-r--r--audio/terminatorx/distinfo2
-rw-r--r--audio/terminatorx/files/patch-configure29
-rw-r--r--audio/terminatorx/files/patch-src-Makefile.am8
-rw-r--r--audio/terminatorx/files/patch-src-Makefile.in11
-rw-r--r--audio/terminatorx/files/patch-src-tX-audiofile.h11
-rw-r--r--audio/terminatorx/pkg-plist5
7 files changed, 50 insertions, 80 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 38f530907fe0..4ae6afa521d7 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -1,28 +1,49 @@
# New ports collection Makefile for: terminatorx
# Date created: 13 May 2002
-# Whom: Tilman Linneweh <freebsdports@arved.de
+# Whom: Tilman Linneweh <arved@FreeBSD.org>
#
# $FreeBSD$
PORTNAME= terminatorx
-PORTVERSION= 3.72
+PORTVERSION= 3.73
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/
DISTNAME= terminatorX-${PORTVERSION}
-MAINTAINER= freebsdports@arved.de
+MAINTAINER= ports@FreeBSD.org
+LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa
+
+USE_GNOMENG= yes
+USE_GNOME= gnomehier gnomelibs
+CONFIGURE_ARGS+= --disable-gtk2
+
+.include <bsd.port.pre.mk>
+
.if !defined(WITHOUT_SOX)
-BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
+BUILD_DEPENDS+= sox:${PORTSDIR}/audio/sox
+CONFIGURE_ARGS+= --enable-sox
.endif
.if !defined(WITHOUT_VORBIS)
-BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
+CONFIGURE_ARGS+= --enable-vorbis
+.endif
+.if !defined(WITHOUT_MAD)
+LIB_DEPENDS+= mad.1:${PORTSDIR}/audio/mad
+CONFIGURE_ARGS+= --enable-mad
.endif
-USE_GNOMENG= yes
-USE_GNOME= gtk12
GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV+= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= terminatorX.1
pre-everything:
.if !defined(WITHOUT_SOX)
@@ -31,19 +52,22 @@ pre-everything:
.if !defined(WITHOUT_VORBIS)
@${ECHO_MSG} "You can disable support for vorbis by defining WITHOUT_VORBIS."
.endif
+.if !defined(WITHOUT_MAD)
+ @${ECHO_MSG} "You can disable support for mad by defining WITHOUT_MAD."
+.endif
post-patch:
+ ${REINPLACE_CMD} -e "s,function option_info,option_info," ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e "s,malloc.h,stdlib.h," ${WRKSRC}/src/main.cc \
+ ${WRKSRC}/src/tX_audiofile.cc ${WRKSRC}/src/tX_flash.c \
+ ${WRKSRC}/src/tX_seqpar.cc ${WRKSRC}/src/tX_vtt.cc \
+ ${WRKSRC}/src/tX_widget.c
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/terminatorX.1 ${MANPREFIX}/man/man1
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX-mime.png ${WRKSRC}/gnome-support/terminatorX-app.png ${PREFIX}/share/gnome/pixmaps
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.mime ${WRKSRC}/gnome-support/terminatorX.keys ${PREFIX}/share/gnome/mime-info
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/terminatorX.desktop ${PREFIX}/share/gnome/apps/Multimedia/terminatorX.desktop
-.for i in main.cc \
- tX_audiofile.cc \
- tX_flash.c \
- tX_seqpar.cc \
- tX_vtt.cc \
- tX_widget.c
- ${MV} ${WRKSRC}/src/$i ${WRKSRC}/src/$i.sed
- ${SED} -e "s:malloc.h:stdlib.h:g" \
- ${WRKSRC}/src/$i.sed >${WRKSRC}/src/$i
- ${RM} ${WRKSRC}/src/$i.sed
-.endfor
-
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/audio/terminatorx/distinfo b/audio/terminatorx/distinfo
index e18fe03701cb..4b7e310f2985 100644
--- a/audio/terminatorx/distinfo
+++ b/audio/terminatorx/distinfo
@@ -1 +1 @@
-MD5 (terminatorX-3.72.tar.gz) = 85453df5c69ab2ecc6913a2b2226c197
+MD5 (terminatorX-3.73.tar.gz) = b1cc4d1f08d3768286584416ed4dfd4b
diff --git a/audio/terminatorx/files/patch-configure b/audio/terminatorx/files/patch-configure
deleted file mode 100644
index 2c44692e19f9..000000000000
--- a/audio/terminatorx/files/patch-configure
+++ /dev/null
@@ -1,29 +0,0 @@
---- configure.orig Mon May 13 20:02:09 2002
-+++ configure Mon May 13 20:07:07 2002
-@@ -1436,7 +1436,7 @@
- echo $ac_n "(cached) $ac_c" 1>&6
- else
- ac_save_LIBS="$LIBS"
--LIBS="-lpthread $LIBS"
-+LIBS="-pthread $LIBS"
- cat > conftest.$ac_ext <<EOF
- #line 1442 "configure"
- #include "confdefs.h"
-@@ -1470,7 +1470,7 @@
- #define $ac_tr_lib 1
- EOF
-
-- LIBS="-lpthread $LIBS"
-+ LIBS="-pthread $LIBS"
-
- else
- echo "$ac_t""no" 1>&6
-@@ -1983,7 +1983,7 @@
- #include "confdefs.h"
- #include <$ac_hdr>
- EOF
--ac_try="$ac_cpp conftest.$ac_ext >/dev/null 2>conftest.out"
-+ac_try="$ac_cpp -I/usr/local/include conftest.$ac_ext >/dev/null 2>conftest.out"
- { (eval echo configure:1988: \"$ac_try\") 1>&5; (eval $ac_try) 2>&5; }
- ac_err=`grep -v '^ *+' conftest.out | grep -v "^conftest.${ac_ext}\$"`
- if test -z "$ac_err"; then
diff --git a/audio/terminatorx/files/patch-src-Makefile.am b/audio/terminatorx/files/patch-src-Makefile.am
deleted file mode 100644
index 49bcb65e69be..000000000000
--- a/audio/terminatorx/files/patch-src-Makefile.am
+++ /dev/null
@@ -1,8 +0,0 @@
---- src/Makefile.am.orig Mon May 13 22:19:10 2002
-+++ src/Makefile.am Mon May 13 22:19:41 2002
-@@ -1,4 +1,4 @@
--LIBS=@GTK_LIBS@ -lXi -lXxf86dga -lpthread
-+LIBS=@GTK_LIBS@ -lXi -lXxf86dga -pthread
-
- SUBDIRS = gui_icons smallknob
-
diff --git a/audio/terminatorx/files/patch-src-Makefile.in b/audio/terminatorx/files/patch-src-Makefile.in
deleted file mode 100644
index 695de39ccee9..000000000000
--- a/audio/terminatorx/files/patch-src-Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Mon May 13 22:08:37 2002
-+++ src/Makefile.in Mon May 13 22:08:50 2002
-@@ -78,7 +78,7 @@
- X_PRE_LIBS = @X_PRE_LIBS@
- x_libraries = @x_libraries@
-
--LIBS = @GTK_LIBS@ -lXi -lXxf86dga -lpthread
-+LIBS = @GTK_LIBS@ -lXi -lXxf86dga -pthread
-
- SUBDIRS = gui_icons smallknob
-
diff --git a/audio/terminatorx/files/patch-src-tX-audiofile.h b/audio/terminatorx/files/patch-src-tX-audiofile.h
deleted file mode 100644
index f3f455500604..000000000000
--- a/audio/terminatorx/files/patch-src-tX-audiofile.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/tX_audiofile.h.orig Mon May 13 21:30:21 2002
-+++ src/tX_audiofile.h Mon May 13 21:30:45 2002
-@@ -71,7 +71,7 @@
- #define TX_FILE_MPG123 2
- #define TX_FILE_OGG123 3
-
--#include <linux/limits.h>
-+#include <limits.h>
- #include "tX_types.h"
- #include <stdio.h>
-
diff --git a/audio/terminatorx/pkg-plist b/audio/terminatorx/pkg-plist
index c5da605d5b09..9c562c666746 100644
--- a/audio/terminatorx/pkg-plist
+++ b/audio/terminatorx/pkg-plist
@@ -1 +1,6 @@
bin/terminatorX
+share/gnome/pixmaps/terminatorX-mime.png
+share/gnome/pixmaps/terminatorX-app.png
+share/gnome/mime-info/terminatorX.mime
+share/gnome/mime-info/terminatorX.keys
+share/gnome/apps/Multimedia/terminatorX.desktop