aboutsummaryrefslogtreecommitdiff
path: root/audio/terminatorx
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-08-23 21:58:22 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-08-23 21:58:22 +0000
commitec7ade5ee8dc15f5c4adc3114a5d645e840d3622 (patch)
tree014048c02f33e6b57ef1d74a006b75a114bf3840 /audio/terminatorx
parent4a4d7d01110df2f4e3cfb50ff5089082f655fd86 (diff)
downloadports-ec7ade5ee8dc15f5c4adc3114a5d645e840d3622.tar.gz
ports-ec7ade5ee8dc15f5c4adc3114a5d645e840d3622.zip
Notes
Diffstat (limited to 'audio/terminatorx')
-rw-r--r--audio/terminatorx/Makefile20
-rw-r--r--audio/terminatorx/distinfo2
-rw-r--r--audio/terminatorx/files/patch-src::main.cc11
-rw-r--r--audio/terminatorx/files/patch-src::tX_global.c45
-rw-r--r--audio/terminatorx/files/patch-src::tX_ladspa.cc13
-rw-r--r--audio/terminatorx/files/patch-src::tX_widget.c15
6 files changed, 46 insertions, 60 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index b31d33bd19a8..a30aa8d671dc 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= terminatorx
-PORTVERSION= 3.80
-PORTREVISION= 1
+PORTVERSION= 3.81
CATEGORIES= audio
MASTER_SITES= http://www.terminatorx.cx/dist/
DISTNAME= terminatorX-${PORTVERSION}
@@ -21,14 +20,13 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
USE_BZIP2= yes
USE_X_PREFIX= yes
-USE_GNOME= gnomehier libxml2 gtk20
-USE_REINPLACE= yes
+USE_GNOME= gnomehack gnomehier gnometarget gtk20 libxml2
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-docdir="${PREFIX}/share/gnome"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LDFLAGS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+CONFIGURE_ARGS= --disable-alsa --disable-jack \
+ --with-docdir="${PREFIX}/share/gnome"
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
@@ -77,10 +75,12 @@ pre-everything::
.endif
post-patch:
- @${REINPLACE_CMD} -e \
- 's|function option_info|option_info|g' ${WRKSRC}/configure
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'
+ @${GREP} -lR "%%LOCALBASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%LOCALBASE%%|${LOCALBASE}|g'
+ @${GREP} -lR "%%X11BASE%%" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
+ 's|%%X11BASE%%|${LOCALBASE}|g'
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/terminatorX ${PREFIX}/bin
diff --git a/audio/terminatorx/distinfo b/audio/terminatorx/distinfo
index 26fcb307ec42..079f761f1e4f 100644
--- a/audio/terminatorx/distinfo
+++ b/audio/terminatorx/distinfo
@@ -1 +1 @@
-MD5 (terminatorX-3.80.tar.bz2) = 542dfbcec3504ff61aa59dda924f1f24
+MD5 (terminatorX-3.81.tar.bz2) = ff5c61718b9047b1931178736844c0f9
diff --git a/audio/terminatorx/files/patch-src::main.cc b/audio/terminatorx/files/patch-src::main.cc
new file mode 100644
index 000000000000..834b59e3ad6f
--- /dev/null
+++ b/audio/terminatorx/files/patch-src::main.cc
@@ -0,0 +1,11 @@
+--- src/main.cc.orig Thu Aug 21 06:41:24 2003
++++ src/main.cc Sat Aug 23 04:52:05 2003
+@@ -33,7 +33,7 @@
+ 4 October 1999: Rewrite ;) - back to C++
+ */
+
+-#define TX_GTKRC "/usr/share/themes/terminatorX/gtk/gtkrc"
++#define TX_GTKRC "%%X11BASE%%/share/themes/terminatorX/gtk/gtkrc"
+
+ #define BENCH_CYCLES 100000
+
diff --git a/audio/terminatorx/files/patch-src::tX_global.c b/audio/terminatorx/files/patch-src::tX_global.c
index 747d74226e4f..67c21b697554 100644
--- a/audio/terminatorx/files/patch-src::tX_global.c
+++ b/audio/terminatorx/files/patch-src::tX_global.c
@@ -1,34 +1,11 @@
---- src/tX_global.c.orig Thu Apr 17 04:45:56 2003
-+++ src/tX_global.c Thu Apr 24 21:21:59 2003
-@@ -230,7 +230,7 @@
- char indent[]="\t";
- FILE *rc=NULL;
- gzFile rz=NULL;
-- _store_compress_xml=0;
-+ int _store_compress_xml=0;
- char tmp_xml_buffer[4096];
-
- get_rc_name(rc_name);
-@@ -314,7 +314,7 @@
- }
-
- char *encode_xml(char *dest, const char *src) {
-- int i, t, max;
-+ int i, t, max, inlen, outlen, res;
- char tmp[4096];
-
- tmp[0]=0;
-@@ -333,10 +333,10 @@
- }
- tmp[t]=0;
-
-- int outlen=4096;
-- int inlen=t;
-+ outlen=4096;
-+ inlen=t;
-
-- int res=isolat1ToUTF8((unsigned char *) dest, &outlen, (unsigned char *) tmp, &inlen);
-+ res=isolat1ToUTF8((unsigned char *) dest, &outlen, (unsigned char *) tmp, &inlen);
- dest[outlen]=0;
- if (res<0) {
- tX_error("failed to encode string (%s) to UTF-8.", src);
+--- src/tX_global.c.orig Thu Aug 21 06:41:24 2003
++++ src/tX_global.c Sat Aug 23 04:34:16 2003
+@@ -127,7 +127,7 @@
+ #endif
+ globals.use_stdout_cmdline=0;
+ strcpy(globals.current_path, "");
+- strcpy(globals.lrdf_path, "/usr/share/ladspa/rdf:/usr/local/share/ladspa/rdf");
++ strcpy(globals.lrdf_path, "%%LOCALBASE%%/share/ladspa/rdf");
+ globals.fullscreen_enabled=0;
+ globals.confirm_events=0;
+ globals.compress_set_files=0;
diff --git a/audio/terminatorx/files/patch-src::tX_ladspa.cc b/audio/terminatorx/files/patch-src::tX_ladspa.cc
new file mode 100644
index 000000000000..56ba8e4ecc17
--- /dev/null
+++ b/audio/terminatorx/files/patch-src::tX_ladspa.cc
@@ -0,0 +1,13 @@
+--- src/tX_ladspa.cc.orig Tue Aug 19 02:36:40 2003
++++ src/tX_ladspa.cc Sat Aug 23 04:37:18 2003
+@@ -44,8 +44,8 @@
+ ladspa_path_ptr=getenv("LADSPA_PATH");
+
+ if (!ladspa_path_ptr) {
+- tX_warning("LADSPA_PATH not set. Trying /usr/lib/ladspa:/usr/local/lib/ladspa");
+- strcpy(ladspa_path, "/usr/lib/ladspa:/usr/local/lib/ladspa");
++ tX_warning("LADSPA_PATH not set. Trying %%LOCALBASE%%/lib/ladspa");
++ strcpy(ladspa_path, "%%LOCALBASE%%/lib/ladspa");
+ }
+ else strcpy(ladspa_path, ladspa_path_ptr);
+
diff --git a/audio/terminatorx/files/patch-src::tX_widget.c b/audio/terminatorx/files/patch-src::tX_widget.c
deleted file mode 100644
index 55fe97663a89..000000000000
--- a/audio/terminatorx/files/patch-src::tX_widget.c
+++ /dev/null
@@ -1,15 +0,0 @@
---- src/tX_widget.c.orig Sat Apr 19 13:56:36 2003
-+++ src/tX_widget.c Sat Apr 19 14:13:50 2003
-@@ -154,10 +154,10 @@
- }
-
- static void gtk_tx_destroy(GtkObject * object) {
-+ GtkTx *tx=GTK_TX(object);
-+
- g_return_if_fail(object != NULL);
- g_return_if_fail(GTK_IS_TX(object));
--
-- GtkTx *tx=GTK_TX(object);
-
- if (tx->disp_data) { free(tx->disp_data); tx->disp_data=NULL; }
-