aboutsummaryrefslogtreecommitdiff
path: root/audio/terminatorx
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-03-20 08:56:07 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-03-20 08:56:07 +0000
commit5d571f26be1f6c7e87e0a6dd199046efcfe3e557 (patch)
treec10889b1c35c151631906ed1a724b2b97979fef4 /audio/terminatorx
parent69a792b7f9fdbe0386dfee9eaf7ff93314a5c4c1 (diff)
downloadports-5d571f26be1f6c7e87e0a6dd199046efcfe3e557.tar.gz
ports-5d571f26be1f6c7e87e0a6dd199046efcfe3e557.zip
Notes
Diffstat (limited to 'audio/terminatorx')
-rw-r--r--audio/terminatorx/Makefile25
-rw-r--r--audio/terminatorx/files/patch-src_main.cc (renamed from audio/terminatorx/files/patch-src::main.cc)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_dial.c11
-rw-r--r--audio/terminatorx/files/patch-src_tX_dialog.cc (renamed from audio/terminatorx/files/patch-src::tX_dialog.cc)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_global.c (renamed from audio/terminatorx/files/patch-src::tX_global.c)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_ladspa.cc (renamed from audio/terminatorx/files/patch-src::tX_ladspa.cc)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_mastergui.cc (renamed from audio/terminatorx/files/patch-src__tX_mastergui.cc)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_mouse.cc (renamed from audio/terminatorx/files/patch-src__tX_mouse.cc)0
-rw-r--r--audio/terminatorx/files/patch-src_tX_mouse.h (renamed from audio/terminatorx/files/patch-src__tX_mouse.h)0
9 files changed, 22 insertions, 14 deletions
diff --git a/audio/terminatorx/Makefile b/audio/terminatorx/Makefile
index 85435226bfb3..7851e71716f4 100644
--- a/audio/terminatorx/Makefile
+++ b/audio/terminatorx/Makefile
@@ -1,7 +1,4 @@
-# New ports collection Makefile for: terminatorx
-# Date created: 13 May 2002
-# Whom: Tilman Linneweh <arved@FreeBSD.org>
-#
+# Created by: Tilman Linneweh <arved@FreeBSD.org>
# $FreeBSD$
# $MCom: ports/audio/terminatorx/Makefile,v 1.6 2007/08/04 03:51:28 marcus Exp $
@@ -20,8 +17,8 @@ LICENSE_FILE= ${WRKSRC}/COPYING
BUILD_DEPENDS= ${LOCALBASE}/include/ladspa.h:${PORTSDIR}/audio/ladspa \
rarian-sk-config:${PORTSDIR}/textproc/rarian
-LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
- lrdf.2:${PORTSDIR}/textproc/liblrdf
+LIB_DEPENDS= audiofile:${PORTSDIR}/audio/libaudiofile \
+ lrdf:${PORTSDIR}/textproc/liblrdf
OPTIONS_DEFINE= ALSA JACK MPG123 SOX VORBIS MAD
OPTIONS_DEFAULT= JACK MPG123 SOX VORBIS MAD
@@ -41,19 +38,19 @@ MAKE_JOBS_SAFE= yes
MAN1= terminatorX.1
-CPPFLAGS+= -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MALSA}
CONFIGURE_ARGS+= --disable-alsa
.else
-LIB_DEPENDS+= asound.2:${PORTSDIR}/audio/alsa-lib
+LIB_DEPENDS+= asound:${PORTSDIR}/audio/alsa-lib
.endif
.if ${PORT_OPTIONS:MJACK}
-LIB_DEPENDS+= jack.0:${PORTSDIR}/audio/jack
+LIB_DEPENDS+= jack:${PORTSDIR}/audio/jack
.else
CONFIGURE_ARGS+= --disable-jack
.endif
@@ -72,13 +69,13 @@ CONFIGURE_ARGS+= --disable-sox
.if ${PORT_OPTIONS:MVORBIS}
BUILD_DEPENDS+= oggenc:${PORTSDIR}/audio/vorbis-tools
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis:${PORTSDIR}/audio/libvorbis
.else
CONFIGURE_ARGS+= --disable-vorbis
.endif
.if ${PORT_OPTIONS:MMAD}
-LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/mad
+LIB_DEPENDS+= mad:${PORTSDIR}/audio/mad
.else
CONFIGURE_ARGS+= --disable-mad
.endif
@@ -96,8 +93,8 @@ do-install:
${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
${PREFIX}/share/pixmaps
.endfor
-.for file in terminatorX.mime terminatorX.keys
- ${INSTALL_DATA} ${WRKSRC}/gnome-support/${file} \
+.for f in terminatorX.mime terminatorX.keys
+ ${INSTALL_DATA} ${WRKSRC}/gnome-support/${f} \
${PREFIX}/share/mime-info
.endfor
@${MKDIR} ${PREFIX}/share/applications
diff --git a/audio/terminatorx/files/patch-src::main.cc b/audio/terminatorx/files/patch-src_main.cc
index 4b8a777e90f5..4b8a777e90f5 100644
--- a/audio/terminatorx/files/patch-src::main.cc
+++ b/audio/terminatorx/files/patch-src_main.cc
diff --git a/audio/terminatorx/files/patch-src_tX_dial.c b/audio/terminatorx/files/patch-src_tX_dial.c
new file mode 100644
index 000000000000..6589437cf80a
--- /dev/null
+++ b/audio/terminatorx/files/patch-src_tX_dial.c
@@ -0,0 +1,11 @@
+--- src/tX_dial.c.orig 2013-03-20 09:38:30.000000000 +0100
++++ src/tX_dial.c 2013-03-20 09:38:43.000000000 +0100
+@@ -266,7 +266,7 @@
+ }
+ }
+
+-inline void gtk_tx_dial_draw (GtkTxDial *tx_dial, GtkWidget *widget)
++static inline void gtk_tx_dial_draw (GtkTxDial *tx_dial, GtkWidget *widget)
+ {
+ if (GTK_WIDGET_DRAWABLE (widget)) {
+ gdk_pixbuf_render_to_drawable(knob_pixmaps[tx_dial->old_image],
diff --git a/audio/terminatorx/files/patch-src::tX_dialog.cc b/audio/terminatorx/files/patch-src_tX_dialog.cc
index a69700179d6b..a69700179d6b 100644
--- a/audio/terminatorx/files/patch-src::tX_dialog.cc
+++ b/audio/terminatorx/files/patch-src_tX_dialog.cc
diff --git a/audio/terminatorx/files/patch-src::tX_global.c b/audio/terminatorx/files/patch-src_tX_global.c
index 67c21b697554..67c21b697554 100644
--- a/audio/terminatorx/files/patch-src::tX_global.c
+++ b/audio/terminatorx/files/patch-src_tX_global.c
diff --git a/audio/terminatorx/files/patch-src::tX_ladspa.cc b/audio/terminatorx/files/patch-src_tX_ladspa.cc
index 56ba8e4ecc17..56ba8e4ecc17 100644
--- a/audio/terminatorx/files/patch-src::tX_ladspa.cc
+++ b/audio/terminatorx/files/patch-src_tX_ladspa.cc
diff --git a/audio/terminatorx/files/patch-src__tX_mastergui.cc b/audio/terminatorx/files/patch-src_tX_mastergui.cc
index eb889529c199..eb889529c199 100644
--- a/audio/terminatorx/files/patch-src__tX_mastergui.cc
+++ b/audio/terminatorx/files/patch-src_tX_mastergui.cc
diff --git a/audio/terminatorx/files/patch-src__tX_mouse.cc b/audio/terminatorx/files/patch-src_tX_mouse.cc
index a2fec9e93450..a2fec9e93450 100644
--- a/audio/terminatorx/files/patch-src__tX_mouse.cc
+++ b/audio/terminatorx/files/patch-src_tX_mouse.cc
diff --git a/audio/terminatorx/files/patch-src__tX_mouse.h b/audio/terminatorx/files/patch-src_tX_mouse.h
index d86d25ccd1cd..d86d25ccd1cd 100644
--- a/audio/terminatorx/files/patch-src__tX_mouse.h
+++ b/audio/terminatorx/files/patch-src_tX_mouse.h