aboutsummaryrefslogtreecommitdiff
path: root/audio/tomahawk/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2014-08-15 15:08:04 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2014-08-15 15:08:04 +0000
commit8854205b5ecfc19321cd7b1e593e9de53d833d0b (patch)
treea4a3d8ee8f5225fd3702da785142913c891dae01 /audio/tomahawk/Makefile
parentb2d6b0519c00cb25bad06c1180216591e611d602 (diff)
downloadports-8854205b5ecfc19321cd7b1e593e9de53d833d0b.tar.gz
ports-8854205b5ecfc19321cd7b1e593e9de53d833d0b.zip
Notes
Diffstat (limited to 'audio/tomahawk/Makefile')
-rw-r--r--audio/tomahawk/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
index 19c5e7cae9da..5a509806d42a 100644
--- a/audio/tomahawk/Makefile
+++ b/audio/tomahawk/Makefile
@@ -6,7 +6,7 @@ PORTVERSION= 0.7.0
PORTREVISION= 2
CATEGORIES= audio
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= arved@FreeBSD.org
COMMENT= Multi-source, social, and smart music player
LICENSE= GPLv3
@@ -25,6 +25,7 @@ RUN_DEPENDS= qca-ossl>=2.0.0.b3_4:${PORTSDIR}/security/qca-ossl
CMAKE_ARGS+= -DWITH_BREAKPAD:BOOL="OFF" \
-DCLUCENE_CONFIG_PATH:PATH="${LOCALBASE}/share/clucene"
+CXXFLAGS+= -Wno-cast-align
GH_ACCOUNT= tomahawk-player
GH_PROJECT= ${PORTNAME}
@@ -36,14 +37,14 @@ OPTIONS_DEFINE= QTWEETLIB
OPTIONS_DEFAULT= GSTREAMER QTWEETLIB
OPTIONS_RADIO= PHONON
OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE
+OPTIONS_SUB= yes
QTWEETLIB_DESC= Enable Twitter SIP plugin
VLC_DESC= Multimedia support for VLC
PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,} \
PORTVERSION=${PORTVERSION}
-USES= cmake pkgconfig
-NO_STAGE= yes
+USES= cmake pkgconfig desktop-file-utils
USE_GITHUB= yes
USE_LDCONFIG= yes