aboutsummaryrefslogtreecommitdiff
path: root/audio/tomahawk/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2015-07-19 09:06:47 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2015-07-19 09:06:47 +0000
commitb238b7251928a92e7d579204f40b0970c7c05523 (patch)
tree1864c57ed88652aae4bc7aea5963705915c03463 /audio/tomahawk/Makefile
parentecd3da542a31a6d2a0aee4e543a374301ee3f462 (diff)
downloadports-b238b7251928a92e7d579204f40b0970c7c05523.tar.gz
ports-b238b7251928a92e7d579204f40b0970c7c05523.zip
Notes
Diffstat (limited to 'audio/tomahawk/Makefile')
-rw-r--r--audio/tomahawk/Makefile50
1 files changed, 16 insertions, 34 deletions
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
index 95d81418c107..b1ca709d3a65 100644
--- a/audio/tomahawk/Makefile
+++ b/audio/tomahawk/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= tomahawk
-PORTVERSION= 0.7.0
-PORTREVISION= 4
+PORTVERSION= 0.8.4
CATEGORIES= audio
MAINTAINER= arved@FreeBSD.org
@@ -11,62 +10,45 @@ COMMENT= Multi-source, social, and smart music player
LICENSE= GPLv3
+BUILD_DEPENDS= google-sparsehash>=2.0.2:${PORTSDIR}/devel/google-sparsehash \
+ websocketpp>=0.4.0:${PORTSDIR}/devel/websocketpp
+RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc
LIB_DEPENDS= libattica.so:${PORTSDIR}/x11-toolkits/attica \
- libclucene-core.so:${PORTSDIR}/textproc/clucene \
+ liblucene++.so:${PORTSDIR}/textproc/luceneplusplus \
libboost_thread.so:${PORTSDIR}/devel/boost-libs \
libechonest.so:${PORTSDIR}/audio/libechonest \
+ libgnutls.so:${PORTSDIR}/security/gnutls \
libjreen.so:${PORTSDIR}/net-im/libjreen \
liblastfm.so:${PORTSDIR}/audio/liblastfm \
libqca.so:${PORTSDIR}/devel/qca \
libqjson.so:${PORTSDIR}/devel/qjson \
+ libqtkeychain.so:${PORTSDIR}/security/qtkeychain \
libquazip.so:${PORTSDIR}/archivers/quazip \
libtag.so:${PORTSDIR}/audio/taglib
-CMAKE_ARGS+= -DWITH_BREAKPAD:BOOL="OFF" \
- -DCLUCENE_CONFIG_PATH:PATH="${LOCALBASE}/share/clucene"
-CXXFLAGS+= -Wno-cast-align
+CMAKE_ARGS= -DBUILD_RELEASE="ON"
+CXXFLAGS+= -Wno-cast-align -I${LOCALBASE}/include
GH_ACCOUNT= tomahawk-player
+TELEPATHY_LIB_DEPENDS= libtelepathy-qt4.so:${PORTSDIR}/net-im/telepathy-qt4
+TELEPATHY_DESC= Configure Telepathy Settings
+TELEPATHY_USE_KDE4= kdelibs automoc4
+
INSTALLS_ICONS= yes
-OPTIONS_DEFINE= QTWEETLIB
-OPTIONS_DEFAULT= GSTREAMER QTWEETLIB
-OPTIONS_RADIO= PHONON
-OPTIONS_RADIO_PHONON= GSTREAMER VLC XINE
+OPTIONS_DEFAULT=
+OPTIONS_DEFINE= TELEPATHY
OPTIONS_SUB= yes
-QTWEETLIB_DESC= Enable Twitter SIP plugin
-VLC_DESC= Multimedia support for VLC
PLIST_SUB+= DESKTOPDIR=${DESKTOPDIR:S,^${PREFIX}/,,} \
PORTVERSION=${PORTVERSION}
-USES= cmake pkgconfig desktop-file-utils
+USES= cmake desktop-file-utils pkgconfig
USE_GITHUB= yes
USE_LDCONFIG= yes
-
USE_QT4= dbus designer gui linguist_build moc_build \
network phonon qmake_build qtestlib rcc_build \
sql-sqlite2 svg uic_build xml
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MQTWEETLIB}
-LIB_DEPENDS+= libQTweetLib.so:${PORTSDIR}/net/qtweetlib
-.else
-CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF"
-.endif
-
-.if ${PORT_OPTIONS:MGSTREAMER}
-RUN_DEPENDS+= phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer
-.endif
-
-.if ${PORT_OPTIONS:MVLC}
-RUN_DEPENDS+= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc
-.endif
-
-.if ${PORT_OPTIONS:MXINE}
-RUN_DEPENDS+= phonon-xine>=4.4.4_5:${PORTSDIR}/multimedia/phonon-xine
-.endif
-
.include <bsd.port.mk>