aboutsummaryrefslogtreecommitdiff
path: root/audio/tomahawk/Makefile
diff options
context:
space:
mode:
authorNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:55:59 +0000
committerNicola Vitale <nivit@FreeBSD.org>2013-03-06 22:55:59 +0000
commit504ec80031ee09a340288ae155a00c5941fb4254 (patch)
tree9fd5cfaa1ce40d4abb621f79e72e0f862fbdc953 /audio/tomahawk/Makefile
parent6e24ca6748a783308c4b62613218ac5d911af015 (diff)
downloadports-504ec80031ee09a340288ae155a00c5941fb4254.tar.gz
ports-504ec80031ee09a340288ae155a00c5941fb4254.zip
Notes
Diffstat (limited to 'audio/tomahawk/Makefile')
-rw-r--r--audio/tomahawk/Makefile61
1 files changed, 61 insertions, 0 deletions
diff --git a/audio/tomahawk/Makefile b/audio/tomahawk/Makefile
new file mode 100644
index 000000000000..0c3cc96e96a8
--- /dev/null
+++ b/audio/tomahawk/Makefile
@@ -0,0 +1,61 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= tomahawk
+PORTVERSION= 0.6.0
+#PORTREVISION= 0
+CATEGORIES= audio
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Multi-source, social, and smart music player
+
+LICENSE= GPLv3
+
+BUILD_DEPENDS= clucene>=2.3.3.4:${PORTSDIR}/textproc/clucene
+LIB_DEPENDS= attica:${PORTSDIR}/x11-toolkits/attica \
+ boost_thread:${PORTSDIR}/devel/boost-libs \
+ echonest:${PORTSDIR}/audio/libechonest \
+ jreen:${PORTSDIR}/net-im/jreen \
+ lastfm:${PORTSDIR}/audio/liblastfm \
+ qca:${PORTSDIR}/devel/qca \
+ qjson:${PORTSDIR}/devel/qjson \
+ quazip:${PORTSDIR}/archivers/quazip \
+ tag:${PORTSDIR}/audio/taglib
+RUN_DEPENDS= phonon-vlc>=0.6.1:${PORTSDIR}/multimedia/phonon-vlc \
+ phonon-gstreamer>=4.6.3:${PORTSDIR}/multimedia/phonon-gstreamer \
+ qca-ossl>=2.0.0.b3_4:${PORTSDIR}/security/qca-ossl
+
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE:STRING="Release" \
+ -DCMAKE_COLOR_MAKEFILE:BOOL="OFF" \
+ -DWITH_BREAKPAD:BOOL="OFF" \
+ -DWITH_BUILD:STRING="Release"
+
+GH_ACCOUNT= tomahawk-player
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= ${DISTVERSION}
+GH_COMMIT= 2b8cc4f
+
+INSTALLS_ICONS= yes
+
+OPTIONS_DEFINE= QTWEETLIB
+OPTIONS_DEFAULT= QTWEETLIB
+QTWEETLIB_DESC= Enable Twitter SIP plugin
+
+USE_CMAKE= yes
+USE_GITHUB= yes
+USE_LDCONFIG= yes
+USE_PKGCONFIG= build
+
+USE_QT4= dbus designer gui linguist_build moc_build \
+ network phonon qmake_build qtestlib rcc_build \
+ sql-sqlite2 svg uic_build xml
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MQTWEETLIB}
+LIB_DEPENDS+= QTweetLib:${PORTSDIR}/net/qtweetlib
+.else
+CMAKE_ARGS+= -DWITH_QTweetLib:BOOL="OFF"
+.endif
+
+.include <bsd.port.mk>