aboutsummaryrefslogtreecommitdiff
path: root/audio/tse3
diff options
context:
space:
mode:
authorSergey Matveychuk <sem@FreeBSD.org>2005-08-01 12:01:59 +0000
committerSergey Matveychuk <sem@FreeBSD.org>2005-08-01 12:01:59 +0000
commit8c6b5d324248b5d88db6e9e51c9e7785bf8e1fa7 (patch)
tree21ffb0ae1e9952e96e049c64a7947b60e1215673 /audio/tse3
parent9c8c0e19fe3653bc20823596d87411c869aa45d7 (diff)
downloadports-8c6b5d324248b5d88db6e9e51c9e7785bf8e1fa7.tar.gz
ports-8c6b5d324248b5d88db6e9e51c9e7785bf8e1fa7.zip
Notes
Diffstat (limited to 'audio/tse3')
-rw-r--r--audio/tse3/Makefile39
-rw-r--r--audio/tse3/distinfo4
-rw-r--r--audio/tse3/files/patch-configure10
-rw-r--r--audio/tse3/pkg-plist85
4 files changed, 68 insertions, 70 deletions
diff --git a/audio/tse3/Makefile b/audio/tse3/Makefile
index 19156893ef50..8059459ea319 100644
--- a/audio/tse3/Makefile
+++ b/audio/tse3/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= tse3
-PORTVERSION= 0.2.7
-PORTREVISION= 2
+PORTVERSION= 0.3.0
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,15 +13,16 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A MIDI library
-LIB_DEPENDS= artsc:${PORTSDIR}/audio/arts
-
+USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=15
+USE_LIBTOOL_VER= 15
+CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ARGS= --without-doc-install
+CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" LDFLAGS="${PTHREAD_LIBS}"
INSTALLS_SHLIB= yes
-USE_REINPLACE= yes
-MAN1= tse3play.1
-MAN3= tse3.3
+MAN1= tse3play.1
+MAN3= tse3.3
.include <bsd.port.pre.mk>
@@ -30,6 +30,12 @@ MAN3= tse3.3
BROKEN= "Does not compile on !i386"
.endif
+.if defined(WITH_ARTS)
+LIB_DEPENDS+= artsmidi:${PORTSDIR}/multimedia/kdemultimedia3
+.else
+CONFIGURE_ARGS+= --without-aRts
+.endif
+
pre-everything::
@${ECHO_MSG}
@${ECHO_MSG} -n "checking for SNDCTL_SEQ_GETTIME in sys/soundcard.h... "
@@ -52,11 +58,16 @@ pre-everything::
${ECHO_MSG} "Aborting."; exit 1;\
fi
-post-patch:
- @${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e 's|prefix}/doc/$${PACKAGE}-$${VERSION}|prefix}/share/doc/$${PACKAGE}|'
-
-pre-configure:
- @${FIND} ${WRKSRC} -type f | ${XARGS} -x -n 10 \
- ${REINPLACE_CMD} -e 's|_LDFLAGS =|_LDFLAGS = ${PTHREAD_LIBS}|g'
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.gif ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.jpeg ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.png ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/History ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}/songs
+ ${INSTALL_DATA} ${WRKSRC}/demos/*.tse3 ${DOCSDIR}/songs
+.endif
.include <bsd.port.post.mk>
diff --git a/audio/tse3/distinfo b/audio/tse3/distinfo
index 2cb27e772d57..f77178c986b9 100644
--- a/audio/tse3/distinfo
+++ b/audio/tse3/distinfo
@@ -1,2 +1,2 @@
-MD5 (tse3-0.2.7.tar.gz) = 6ccab942cc51a648af76653771479eed
-SIZE (tse3-0.2.7.tar.gz) = 603222
+MD5 (tse3-0.3.0.tar.gz) = fbf5ebe8b96fdc9886758a42d6b1c13a
+SIZE (tse3-0.3.0.tar.gz) = 716430
diff --git a/audio/tse3/files/patch-configure b/audio/tse3/files/patch-configure
deleted file mode 100644
index 7ac516dccdd4..000000000000
--- a/audio/tse3/files/patch-configure
+++ /dev/null
@@ -1,10 +0,0 @@
---- configure.orig Thu May 27 19:55:30 2004
-+++ configure Thu May 27 19:55:39 2004
-@@ -7820,6 +7820,7 @@
-
- # This can be used to rebuild libtool when needed
- LIBTOOL_DEPS="$ac_aux_dir/ltmain.sh"
-+$ac_aux_dir/ltconfig $LIBTOOL_DEPS
-
- # Always use our own libtool.
- LIBTOOL='$(SHELL) $(top_builddir)/libtool'
diff --git a/audio/tse3/pkg-plist b/audio/tse3/pkg-plist
index 3392e828c778..5a23a29970a0 100644
--- a/audio/tse3/pkg-plist
+++ b/audio/tse3/pkg-plist
@@ -1,4 +1,4 @@
-@comment $FreeBSD: /tmp/pcvs/ports/audio/tse3/pkg-plist,v 1.4 2005-05-31 21:34:44 oliver Exp $
+@comment $FreeBSD: /tmp/pcvs/ports/audio/tse3/pkg-plist,v 1.5 2005-08-01 12:01:59 sem Exp $
bin/tse3play
include/tse3/DisplayParams.h
include/tse3/Error.h
@@ -108,49 +108,46 @@ include/tse3/util/Track.h
lib/libtse3.a
lib/libtse3.so
lib/libtse3.so.0
-share/doc/tse3/AUTHORS
-share/doc/tse3/About.html
-share/doc/tse3/Article.html
-share/doc/tse3/Bugs.html
-share/doc/tse3/Build.html
-share/doc/tse3/COPYING
-share/doc/tse3/Commands.html
-share/doc/tse3/Copyright.html
-share/doc/tse3/Error.html
-share/doc/tse3/Examples.html
-share/doc/tse3/Feedback.html
-share/doc/tse3/HOWTO.html
-share/doc/tse3/History
-share/doc/tse3/History.html
-share/doc/tse3/InsFiles.html
-share/doc/tse3/KDOC.html
-share/doc/tse3/Mutex.html
-share/doc/tse3/Notifier.html
-share/doc/tse3/Playable.html
-share/doc/tse3/Porting.html
-share/doc/tse3/Psalm150.html
-share/doc/tse3/Song.html
-share/doc/tse3/Structure.html
-share/doc/tse3/TSE3MDL.html
-share/doc/tse3/Trax.html
-share/doc/tse3/Trouble.html
-share/doc/tse3/Version.html
-share/doc/tse3/Whitepaper.html
-share/doc/tse3/index.html
-share/doc/tse3/pete.jpeg
-share/doc/tse3/songs/Ambient.tse3
-share/doc/tse3/songs/Bry.tse3
-share/doc/tse3/songs/Demo.tse2
-share/doc/tse3/songs/Demo.tse3
-share/doc/tse3/songs/Enigma.tse3
-share/doc/tse3/songs/FunkyJob.tse3
-share/doc/tse3/songs/Humphry.tse3
-share/doc/tse3/songs/Trip.tse3
-share/doc/tse3/trax.gif
-share/doc/tse3/tse3.gif
-share/doc/tse3/tse3logo.png
-@dirrm share/doc/tse3/songs
-@dirrm share/doc/tse3
+%%PORTDOCS%%%%DOCSDIR%%/About.html
+%%PORTDOCS%%%%DOCSDIR%%/Article.html
+%%PORTDOCS%%%%DOCSDIR%%/Bugs.html
+%%PORTDOCS%%%%DOCSDIR%%/Build.html
+%%PORTDOCS%%%%DOCSDIR%%/Commands.html
+%%PORTDOCS%%%%DOCSDIR%%/Copyright.html
+%%PORTDOCS%%%%DOCSDIR%%/Error.html
+%%PORTDOCS%%%%DOCSDIR%%/Examples.html
+%%PORTDOCS%%%%DOCSDIR%%/Feedback.html
+%%PORTDOCS%%%%DOCSDIR%%/HOWTO.html
+%%PORTDOCS%%%%DOCSDIR%%/History
+%%PORTDOCS%%%%DOCSDIR%%/History.html
+%%PORTDOCS%%%%DOCSDIR%%/InsFiles.html
+%%PORTDOCS%%%%DOCSDIR%%/KDOC.html
+%%PORTDOCS%%%%DOCSDIR%%/Mutex.html
+%%PORTDOCS%%%%DOCSDIR%%/Notifier.html
+%%PORTDOCS%%%%DOCSDIR%%/Playable.html
+%%PORTDOCS%%%%DOCSDIR%%/Porting.html
+%%PORTDOCS%%%%DOCSDIR%%/Psalm150.html
+%%PORTDOCS%%%%DOCSDIR%%/Song.html
+%%PORTDOCS%%%%DOCSDIR%%/Structure.html
+%%PORTDOCS%%%%DOCSDIR%%/TSE3MDL.html
+%%PORTDOCS%%%%DOCSDIR%%/Trax.html
+%%PORTDOCS%%%%DOCSDIR%%/Trouble.html
+%%PORTDOCS%%%%DOCSDIR%%/Version.html
+%%PORTDOCS%%%%DOCSDIR%%/Whitepaper.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pete.jpeg
+%%PORTDOCS%%%%DOCSDIR%%/songs/Ambient.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/Bry.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/Demo.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/Enigma.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/FunkyJob.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/Humphry.tse3
+%%PORTDOCS%%%%DOCSDIR%%/songs/Trip.tse3
+%%PORTDOCS%%%%DOCSDIR%%/trax.gif
+%%PORTDOCS%%%%DOCSDIR%%/tse3.gif
+%%PORTDOCS%%%%DOCSDIR%%/tse3logo.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/songs
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm include/tse3/util
@dirrm include/tse3/plt
@dirrm include/tse3/listen/ins