aboutsummaryrefslogtreecommitdiff
path: root/audio/tse3
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 17:16:05 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-02-26 17:16:05 +0000
commit939e4e8d93f00d5bcf9f9cab74c2316de56c0f38 (patch)
tree335b62b01ba8dd0217653434f7bf32d2ac4e7e0e /audio/tse3
parentdb1b072076399a55f88e66a5b89be5bfcb006bab (diff)
downloadports-939e4e8d93f00d5bcf9f9cab74c2316de56c0f38.tar.gz
ports-939e4e8d93f00d5bcf9f9cab74c2316de56c0f38.zip
Notes
Diffstat (limited to 'audio/tse3')
-rw-r--r--audio/tse3/Makefile26
1 files changed, 14 insertions, 12 deletions
diff --git a/audio/tse3/Makefile b/audio/tse3/Makefile
index 48a30440e4da..749215520c6f 100644
--- a/audio/tse3/Makefile
+++ b/audio/tse3/Makefile
@@ -1,39 +1,41 @@
-# New ports collection makefile for: tse3
-# Date created: Wed Nov 12 14:10:12 PST 2003
-# Whom: Mathew Kanner <mat@hak.cnd.mcgill.ca>
-#
+# Created by: Mathew Kanner <mat@hak.cnd.mcgill.ca>
# $FreeBSD$
PORTNAME= tse3
PORTVERSION= 0.3.1
PORTREVISION= 1
CATEGORIES= audio
-MASTER_SITES= SF/${PORTNAME}/TSE3/${PORTVERSION}
+MASTER_SITES= SF/${PORTNAME}/${PORTNAME:U}/${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A MIDI library
+COMMENT= MIDI library
+
+LICENSE= GPLv2
USE_GMAKE= yes
USE_AUTOTOOLS= libtool
CONFIGURE_ARGS= --without-doc-install
-CPPFLAGS+= ${PTHREAD_CFLAGS}
-LDFLAGS+= ${PTHREAD_LIBS}
USE_LDCONFIG= yes
MAKE_JOBS_UNSAFE= yes
+CPPFLAGS+= ${PTHREAD_CFLAGS}
+LDFLAGS+= ${PTHREAD_LIBS}
+
MAN1= tse3play.1
MAN3= tse3.3
-.include <bsd.port.pre.mk>
+OPTIONS_DEFINE= ARTS DOCS
+
+.include <bsd.port.options.mk>
-.if defined(WITH_ARTS)
+.if ${PORT_OPTIONS:MARTS}
LIB_DEPENDS+= artsmidi:${PORTSDIR}/multimedia/kdemultimedia3
.else
CONFIGURE_ARGS+= --without-aRts
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.gif ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/doc/*.html ${DOCSDIR}
@@ -44,4 +46,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/demos/*.tse3 ${DOCSDIR}/songs
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>