aboutsummaryrefslogtreecommitdiff
path: root/audio/tunesbrowser/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-07-29 23:41:10 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-07-29 23:41:10 +0000
commit817e053e7a0b602117210a043c8e1dafa80ff302 (patch)
tree22ff55ef7926cdcd1cd5d7f7ae5b3ac56b0a2329 /audio/tunesbrowser/Makefile
parent97f84449eccafc4aa85de4f9b28070dfc9d60d6e (diff)
downloadports-817e053e7a0b602117210a043c8e1dafa80ff302.tar.gz
ports-817e053e7a0b602117210a043c8e1dafa80ff302.zip
Notes
Diffstat (limited to 'audio/tunesbrowser/Makefile')
-rw-r--r--audio/tunesbrowser/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/audio/tunesbrowser/Makefile b/audio/tunesbrowser/Makefile
new file mode 100644
index 000000000000..b8482f567d88
--- /dev/null
+++ b/audio/tunesbrowser/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: tunesbrowser
+# Date created: 2004-07-27
+# Whom: Michael Johnson <ahze@ahze.net>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tunesbrowser
+PORTVERSION= 0.1.5
+CATEGORIES= audio
+MASTER_SITES= http://crazney.net/programs/itunes/files/
+
+MAINTAINER= ahze@ahze.net
+COMMENT= Gnome frontend DAAP client
+
+LIB_DEPENDS= opendaap.0:${PORTSDIR}/devel/libopendaap
+
+USE_BZIP2= yes
+USE_LIBTOOL_VER=15
+USE_X_PREFIX= yes
+USE_GNOME= libglade2 gstreamerplugins gnometarget gnomehack
+
+DATADIR= ${PREFIX}/share/gnome/${PORTNAME}
+
+PLIST_FILES= bin/tunesbrowser \
+ %%DATADIR%%/tunesbrowser.glade
+PLIST_DIRS= %%DATADIR%%
+
+pre-everything::
+ @${ECHO_MSG} '===>'
+ @${ECHO_MSG} '===> Warning: ${PORTNAME} is extremelly buggy, especially'
+ @${ECHO_MSG} '===> on the FreeBSD 4.x branch, and may not run at all'
+ @${ECHO_MSG} '===>'
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/tunesbrowser ${PREFIX}/bin
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/tunesbrowser.glade ${DATADIR}
+
+.include <bsd.port.mk>