aboutsummaryrefslogtreecommitdiff
path: root/audio/tunesbrowser
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-03 03:13:17 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-03 03:13:17 +0000
commit014f8392212904e96abe053bc248520e890cef46 (patch)
treed42b0d0f578191c472f5cab4254b13fa7d43dd1e /audio/tunesbrowser
parentbf1e132fa6b77756e4bbf3e096594f8529fa8a68 (diff)
downloadports-014f8392212904e96abe053bc248520e890cef46.tar.gz
ports-014f8392212904e96abe053bc248520e890cef46.zip
Notes
Diffstat (limited to 'audio/tunesbrowser')
-rw-r--r--audio/tunesbrowser/Makefile3
-rw-r--r--audio/tunesbrowser/distinfo4
-rw-r--r--audio/tunesbrowser/files/patch-audioplayer.c43
-rw-r--r--audio/tunesbrowser/files/patch-configure51
-rw-r--r--audio/tunesbrowser/files/patch-daap.c30
-rw-r--r--audio/tunesbrowser/files/patch-main.c31
6 files changed, 45 insertions, 117 deletions
diff --git a/audio/tunesbrowser/Makefile b/audio/tunesbrowser/Makefile
index df7df1855459..951a5de33afb 100644
--- a/audio/tunesbrowser/Makefile
+++ b/audio/tunesbrowser/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= tunesbrowser
-PORTVERSION= 0.1.6
-PORTREVISION= 2
+PORTVERSION= 0.2.0
CATEGORIES= audio
MASTER_SITES= http://craz.net/programs/itunes/files/
diff --git a/audio/tunesbrowser/distinfo b/audio/tunesbrowser/distinfo
index 0254a2a88d2b..fa907bced710 100644
--- a/audio/tunesbrowser/distinfo
+++ b/audio/tunesbrowser/distinfo
@@ -1,2 +1,2 @@
-MD5 (tunesbrowser-0.1.6.tar.bz2) = 5e2f967145b8ce900c81b477e4e16acf
-SIZE (tunesbrowser-0.1.6.tar.bz2) = 191375
+MD5 (tunesbrowser-0.2.0.tar.bz2) = e0fa00ca89ded223033430f4c54a83f9
+SIZE (tunesbrowser-0.2.0.tar.bz2) = 208472
diff --git a/audio/tunesbrowser/files/patch-audioplayer.c b/audio/tunesbrowser/files/patch-audioplayer.c
index f1f0e84efa1f..1d55d6b29d3a 100644
--- a/audio/tunesbrowser/files/patch-audioplayer.c
+++ b/audio/tunesbrowser/files/patch-audioplayer.c
@@ -1,8 +1,18 @@
---- audioplayer.c.orig Thu Apr 29 11:31:57 2004
-+++ audioplayer.c Wed Jul 28 06:38:45 2004
-@@ -62,8 +62,10 @@
+--- audioplayer.c.orig Mon Dec 20 03:03:55 2004
++++ audioplayer.c Wed Feb 2 21:42:19 2005
+@@ -106,7 +106,8 @@
- static void cb_iterate(GstBin *bin, gpointer data)
+ static void async_cmd_cb_gst_setup_clock(__UNUSED__ void *data)
+ {
+- GstClock *clock = gst_bin_get_clock(GST_BIN(pipeline_thread));
++ GstClock *clock;
++ clock = gst_bin_get_clock(GST_BIN(pipeline_thread));
+ songstarted = gst_clock_get_time(clock) / GST_SECOND;
+ }
+
+@@ -157,8 +158,10 @@
+
+ static void cb_iterate(GstBin *bin, __UNUSED__ gpointer data)
{
- GstClock *clock = gst_bin_get_clock(bin);
- int seconds = gst_clock_get_time(clock) / GST_SECOND;
@@ -13,28 +23,3 @@
seconds = seconds - songstarted;
-@@ -80,8 +82,10 @@
- gst_init(0, NULL);
-
- pipeline_thread = gst_thread_new ("pipeline");
-+#if 0
- gst_bin_set_post_iterate_function(GST_BIN(pipeline_thread),
- cb_iterate, NULL);
-+#endif
- pipesrc = gst_element_factory_make ("fdsrc", "pipe_source");
- if (!pipesrc)
- {
-@@ -136,11 +140,12 @@
-
- void audioplayer_playpipe(int fd)
- {
-+ GstClock *clock;
- playing = 1;
- audioplayer_loadpipe(fd);
-
- gst_element_set_state (GST_ELEMENT (pipeline_thread), GST_STATE_PLAYING);
-- GstClock *clock = gst_bin_get_clock(GST_BIN(pipeline_thread));
-+ clock = gst_bin_get_clock(GST_BIN(pipeline_thread));
- songstarted = gst_clock_get_time(clock) / GST_SECOND;
- }
-
diff --git a/audio/tunesbrowser/files/patch-configure b/audio/tunesbrowser/files/patch-configure
deleted file mode 100644
index dbbc4e8a387f..000000000000
--- a/audio/tunesbrowser/files/patch-configure
+++ /dev/null
@@ -1,51 +0,0 @@
---- configure 2004/06/05 22:49:11 1.1
-+++ configure 2004/06/05 22:49:43
-@@ -19625,23 +19625,23 @@
- else
- PKG_CONFIG_MIN_VERSION=0.9.0
- if $PKG_CONFIG --atleast-pkgconfig-version $PKG_CONFIG_MIN_VERSION; then
-- echo "$as_me:$LINENO: checking for opendaap libglade-2.0 gstreamer-0.6" >&5
--echo $ECHO_N "checking for opendaap libglade-2.0 gstreamer-0.6... $ECHO_C" >&6
-+ echo "$as_me:$LINENO: checking for opendaap libglade-2.0 gstreamer-0.8" >&5
-+echo $ECHO_N "checking for opendaap libglade-2.0 gstreamer-0.8... $ECHO_C" >&6
-
-- if $PKG_CONFIG --exists "opendaap libglade-2.0 gstreamer-0.6" ; then
-+ if $PKG_CONFIG --exists "opendaap libglade-2.0 gstreamer-0.8" ; then
- echo "$as_me:$LINENO: result: yes" >&5
- echo "${ECHO_T}yes" >&6
- succeeded=yes
-
- echo "$as_me:$LINENO: checking TB_CFLAGS" >&5
- echo $ECHO_N "checking TB_CFLAGS... $ECHO_C" >&6
-- TB_CFLAGS=`$PKG_CONFIG --cflags "opendaap libglade-2.0 gstreamer-0.6"`
-+ TB_CFLAGS=`$PKG_CONFIG --cflags "opendaap libglade-2.0 gstreamer-0.8"`
- echo "$as_me:$LINENO: result: $TB_CFLAGS" >&5
- echo "${ECHO_T}$TB_CFLAGS" >&6
-
- echo "$as_me:$LINENO: checking TB_LIBS" >&5
- echo $ECHO_N "checking TB_LIBS... $ECHO_C" >&6
-- TB_LIBS=`$PKG_CONFIG --libs "opendaap libglade-2.0 gstreamer-0.6"`
-+ TB_LIBS=`$PKG_CONFIG --libs "opendaap libglade-2.0 gstreamer-0.8"`
- echo "$as_me:$LINENO: result: $TB_LIBS" >&5
- echo "${ECHO_T}$TB_LIBS" >&6
- else
-@@ -19649,7 +19649,7 @@
- TB_LIBS=""
- ## If we have a custom action on failure, don't print errors, but
- ## do set a variable so people can do so.
-- TB_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "opendaap libglade-2.0 gstreamer-0.6"`
-+ TB_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "opendaap libglade-2.0 gstreamer-0.8"`
- echo $TB_PKG_ERRORS
- fi
-
-@@ -19664,8 +19664,8 @@
- if test $succeeded = yes; then
- :
- else
-- { { echo "$as_me:$LINENO: error: Library requirements (opendaap libglade-2.0 gstreamer-0.6) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
--echo "$as_me: error: Library requirements (opendaap libglade-2.0 gstreamer-0.6) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
-+ { { echo "$as_me:$LINENO: error: Library requirements (opendaap libglade-2.0 gstreamer-0.8) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&5
-+echo "$as_me: error: Library requirements (opendaap libglade-2.0 gstreamer-0.8) not met; consider adjusting the PKG_CONFIG_PATH environment variable if your libraries are in a nonstandard prefix so pkg-config can find them." >&2;}
- { (exit 1); exit 1; }; }
- fi
-
diff --git a/audio/tunesbrowser/files/patch-daap.c b/audio/tunesbrowser/files/patch-daap.c
deleted file mode 100644
index 3132a0c36f97..000000000000
--- a/audio/tunesbrowser/files/patch-daap.c
+++ /dev/null
@@ -1,30 +0,0 @@
---- daap.c.orig Wed Jul 28 06:39:51 2004
-+++ daap.c Wed Jul 28 06:41:27 2004
-@@ -456,6 +456,7 @@
- char time[11] = {0};
- char track[11] = {0};
- char year[11] = {0};
-+ int minutes, seconds;
-
- if (selected_artist &&
- strcasecmp(selected_artist, currentSongItems[i].songartist) != 0)
-@@ -464,7 +465,6 @@
- strcasecmp(selected_album, currentSongItems[i].songalbum) != 0)
- continue;
-
-- int minutes, seconds;
-
- seconds = (currentSongItems[i].songtime) / 1000;
- minutes = seconds / 60;
-@@ -563,10 +563,10 @@
- char *get_song_display_str_withalloc(int id)
- {
- int songindex = findSongByID(id);
-+ char *buf;
-
- if (!songindex) return NULL;
-
-- char *buf;
- buf = malloc(strlen(currentSongItems[songindex].songartist) + strlen(" - ")
- + strlen(currentSongItems[songindex].itemname) + 1);
-
diff --git a/audio/tunesbrowser/files/patch-main.c b/audio/tunesbrowser/files/patch-main.c
index ce6cdb663358..4d784a106f84 100644
--- a/audio/tunesbrowser/files/patch-main.c
+++ b/audio/tunesbrowser/files/patch-main.c
@@ -1,6 +1,30 @@
---- main.c.orig Tue Apr 13 03:17:50 2004
-+++ main.c Sat Dec 18 00:55:53 2004
-@@ -46,7 +46,7 @@
+--- main.c.orig Mon Jan 3 21:58:29 2005
++++ main.c Wed Feb 2 21:56:11 2005
+@@ -38,8 +38,8 @@
+ {
+ fprintf(stderr, "Oops! TunesBrowser has crashed. Sorry about that!\n");
+ fprintf(stderr, "This probably won't be of any use unless you feel like debugging,\n");
+- fprintf(stderr, "but the crash occured because of %p being bad.\n", siginfo->si_ptr);
+ #if 0
++ fprintf(stderr, "but the crash occured because of %p being bad.\n", siginfo->si_ptr);
+ fprintf(stderr, "\n\nRaised SIGSTOP. You can now attach a debugger.\n");
+ fprintf(stderr, "Attach to PID %i\n", getpid());
+ raise(SIGSTOP);
+@@ -66,11 +66,11 @@
+ int ret;
+
+ sa.sa_handler = (void*)sighandler_sigsegv;
+- sa.sa_flags = SA_NOMASK | SA_SIGINFO;
++ sa.sa_flags = SA_NODEFER | SA_SIGINFO;
+ ret = sigaction(SIGSEGV, &sa, NULL);
+
+ sa.sa_handler = (void*)sighandler_sigpipe;
+- sa.sa_flags = SA_NOMASK | SA_SIGINFO;
++ sa.sa_flags = SA_NODEFER | SA_SIGINFO;
+ ret = sigaction(SIGPIPE, &sa, NULL);
+ }
+
+@@ -94,7 +94,7 @@
gtk_init(&argc, &argv);
@@ -8,3 +32,4 @@
+ xml = glade_xml_new(XSTR(UIDIR) "/gnome/tunesbrowser/tunesbrowser.glade", NULL, NULL);
glade_xml_signal_autoconnect(xml);
+