aboutsummaryrefslogtreecommitdiff
path: root/audio/uade/files
diff options
context:
space:
mode:
authorMartin Blapp <mbr@FreeBSD.org>2004-01-06 11:16:38 +0000
committerMartin Blapp <mbr@FreeBSD.org>2004-01-06 11:16:38 +0000
commit8654c0d86886033361947a9ba7d6aba9d27e4b5a (patch)
treeca60d01102a9edc8dfdf1e07dd1588c46116c8e9 /audio/uade/files
parent8bc7eb6ce877794d7e71ab36397b8084b0d67cc0 (diff)
downloadports-8654c0d86886033361947a9ba7d6aba9d27e4b5a.tar.gz
ports-8654c0d86886033361947a9ba7d6aba9d27e4b5a.zip
Notes
Diffstat (limited to 'audio/uade/files')
-rw-r--r--audio/uade/files/patch-Makefile.in23
-rw-r--r--audio/uade/files/patch-configure33
-rw-r--r--audio/uade/files/patch-osdep+uade-os-unix.c33
-rw-r--r--audio/uade/files/patch-plugindir+Makefile.in11
-rw-r--r--audio/uade/files/patch-src+Makefile.in11
-rw-r--r--audio/uade/files/patch-src+unix-shell.c29
6 files changed, 17 insertions, 123 deletions
diff --git a/audio/uade/files/patch-Makefile.in b/audio/uade/files/patch-Makefile.in
deleted file mode 100644
index a52da8cba914..000000000000
--- a/audio/uade/files/patch-Makefile.in
+++ /dev/null
@@ -1,23 +0,0 @@
---- Makefile.in.orig Thu Aug 14 20:18:51 2003
-+++ Makefile.in Fri Aug 15 12:19:17 2003
-@@ -1,6 +1,7 @@
- # Top-level Makefile for UADE
-
- MAKE = {MAKE}
-+CFLAGS = {SYSCFLAGS}
-
- FINALBINDIR = {BINDIR}
- FINALDATADIR = {DATADIR}
-@@ -15,10 +16,10 @@
- @chmod u+rx uade
-
- uade-bin:
-- @ cd src && $(MAKE)
-+ @ cd src && CFLAGS='$(CFLAGS)' $(MAKE)
-
- plugin:
-- @ cd plugindir && test "{USEXMMS}" = "no" || $(MAKE)
-+ @ cd plugindir && test "{USEXMMS}" = "no" || CFLAGS='$(CFLAGS)' $(MAKE)
-
- config.h:
- @echo ""
diff --git a/audio/uade/files/patch-configure b/audio/uade/files/patch-configure
index 38fa9970d138..61272e8884b5 100644
--- a/audio/uade/files/patch-configure
+++ b/audio/uade/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Sat Feb 15 18:28:42 2003
-+++ configure Sun Feb 16 01:13:28 2003
-@@ -189,18 +189,34 @@
+--- configure.orig Mon Jan 5 23:10:21 2004
++++ configure Tue Jan 6 11:02:01 2004
+@@ -227,18 +227,34 @@
if test "$prefix" = "$HOME/.xmms"; then
uadedatadir="$prefix/uade"
@@ -39,7 +39,7 @@
fi
if test "$xmmsinputplugindir" != "automatic"; then
-@@ -247,6 +263,7 @@
+@@ -293,6 +309,7 @@
sed -e "s|{DATADIR}|$uadedatadir|" \
-e "s|{MAKE}|$MAKE|" \
@@ -47,26 +47,27 @@
-e "s|{BINDIR}|$bindir|" \
-e "s|{DOCDIR}|$docdir|" \
-e "s|{USEXMMS}|$usexmms|" \
-@@ -261,10 +278,10 @@
- -e "s|{UADEVERSION}|$VERSION|" \
- osdep/uadeconfig-unix.h.in > osdep/uadeconfig.h
+@@ -317,10 +334,11 @@
+ XMMS_CONFIG="xmms-config"
+ fi
--GLIBFLAGS=`glib-config --cflags`
--GLIBLIBS=`glib-config --libs`
--GTKFLAGS=`gtk-config --cflags`
--GTKLIBS=`gtk-config --libs`
+-GLIBFLAGS=`$GLIB_CONFIG --cflags`
+-GLIBLIBS=`$GLIB_CONFIG --libs`
+-GTKFLAGS=`$GTK_CONFIG --cflags`
+-GTKLIBS=`$GTK_CONFIG --libs`
+GLIBFLAGS=`glib12-config --cflags`
+GLIBLIBS=`glib12-config --libs`
+GTKFLAGS=`gtk12-config --cflags`
+GTKLIBS=`gtk12-config --libs`
- XMMSFLAGS=`xmms-config --cflags`
- XMMSLIBS=`xmms-config --libs`
- INCLUDEFLAG="-I$includedir"
-@@ -275,6 +292,7 @@
++
+ XMMSFLAGS=`$XMMS_CONFIG --cflags`
+ XMMSLIBS=`$XMMS_CONFIG --libs`
+
+@@ -332,6 +350,7 @@
-e "s|{GTKFLAGS}|$GTKFLAGS|" -e "s|{GTKLIBS}|$GTKLIBS|" \
-e "s|{XMMSFLAGS}|$XMMSFLAGS|" -e "s|{XMMSLIBS}|$XMMSLIBS|" \
-e "s|{INCLUDEFLAG}|$INCLUDEFLAG|" -e "s|{LIBFLAG}|$LIBFLAG|" \
+ -e "s|{SYSCFLAGS}|$SYSCFLAGS|" \
-e "s|{PLUGINDIR}|$plugin|" \
-e "s|{PACKAGEPREFIX}|$packageprefix|" \
- -e "s|{VERSION}|$VERSION|" \
+ -e "s|{ARCHFLAGS}|$ARCHFLAGS|" \
diff --git a/audio/uade/files/patch-osdep+uade-os-unix.c b/audio/uade/files/patch-osdep+uade-os-unix.c
deleted file mode 100644
index 84f8d1f6eb0a..000000000000
--- a/audio/uade/files/patch-osdep+uade-os-unix.c
+++ /dev/null
@@ -1,33 +0,0 @@
---- osdep/uade-os-unix.c.orig Fri Aug 15 12:46:14 2003
-+++ osdep/uade-os-unix.c Fri Aug 15 12:49:28 2003
-@@ -12,7 +12,7 @@
- #include <errno.h>
- #include <limits.h>
-
--#ifndef HAVE_MACOSX
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- #include <ftw.h>
- #endif
-
-@@ -94,7 +94,7 @@
- static int (*uade_ftw_func) (const char *file, const struct stat *sb, int flag, void *arg);
-
- static int ftw_func(const char *file, const struct stat *sb, int flag) {
--#ifndef HAVE_MACOSX
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- switch (flag) {
- case FTW_F: flag = UADE_FTW_F; break;
- case FTW_D: flag = UADE_FTW_D; break;
-@@ -120,10 +120,10 @@
- {
- uade_ftw_arg = arg;
- uade_ftw_func = fn;
--#ifndef HAVE_MACOSX
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- return ftw(dir, ftw_func, depth);
- #else
-- fprintf(stderr, "uade: error! macosx doesn't have uade_ftw() implemented\n");
-+ fprintf(stderr, "uade: error! macosx & FreeBSD doesn't have uade_ftw() implemented\n");
- return 0;
- #endif
- }
diff --git a/audio/uade/files/patch-plugindir+Makefile.in b/audio/uade/files/patch-plugindir+Makefile.in
deleted file mode 100644
index e13adb4923c0..000000000000
--- a/audio/uade/files/patch-plugindir+Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- plugindir/Makefile.in.orig Thu Aug 14 20:18:51 2003
-+++ plugindir/Makefile.in Fri Aug 15 12:21:02 2003
-@@ -30,7 +30,7 @@
-
- UADEDEPS = uade.h defaults.h gui.h $(DECDIR)/decrunch.h
- INCLUDEFLAGS = -I. -I../osdep -I../effects -I../src/include $(GLIBFLAGS) $(GTKFLAGS) $(XMMSFLAGS) $(INCLUDEFLAG)
--CFLAGS = -O2 -DHAVE_CONFIG_H -D_REENTRANT -DVERSION=\"$(VERSION)\" -W -Wall $(DEBUGFLAGS)
-+CFLAGS += -O2 -DHAVE_CONFIG_H -D_REENTRANT -DVERSION=\"$(VERSION)\" -W -Wall $(DEBUGFLAGS)
- LDFLAGS = $(LIBFLAG) $(GLIBLIBS) $(XMMSLIBS)
- DECFLAGS = -c -O2 -W -Wall -Wno-implicit-int -finline-functions {ARCHFLAGS} $(DEBUGFLAGS)
-
diff --git a/audio/uade/files/patch-src+Makefile.in b/audio/uade/files/patch-src+Makefile.in
deleted file mode 100644
index 84dd3688fdb0..000000000000
--- a/audio/uade/files/patch-src+Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/Makefile.in.orig Thu Aug 14 20:18:51 2003
-+++ src/Makefile.in Fri Aug 15 12:22:07 2003
-@@ -7,7 +7,7 @@
- SDLLIBS= {SDLLIBS}
- SOUNDLIBS= {SOUNDLIBS}
-
--CFLAGS = -fomit-frame-pointer -Wall -Wno-unused -Wno-format -W -Wmissing-prototypes -Wstrict-prototypes -DGCCCONSTFUNC="__attribute__((const))" -D_REENTRANT -fno-exceptions -fno-strength-reduce -DREGPARAM= -D__inline__=inline $(ARCHFLAGS) -O2
-+CFLAGS += -fomit-frame-pointer -Wall -Wno-unused -Wno-format -W -Wmissing-prototypes -Wstrict-prototypes -DGCCCONSTFUNC="__attribute__((const))" -D_REENTRANT -fno-exceptions -fno-strength-reduce -DREGPARAM= -D__inline__=inline $(ARCHFLAGS) -O2
- LIBRARIES = -lm $(ARCHLIBS) $(SDLLIBS) $(SOUNDLIBS)
-
- .SUFFIXES: .a .o .c .h .S
diff --git a/audio/uade/files/patch-src+unix-shell.c b/audio/uade/files/patch-src+unix-shell.c
deleted file mode 100644
index 0bda355d68e4..000000000000
--- a/audio/uade/files/patch-src+unix-shell.c
+++ /dev/null
@@ -1,29 +0,0 @@
---- src/unix-shell.c.orig Fri Aug 15 12:50:41 2003
-+++ src/unix-shell.c Fri Aug 15 12:51:37 2003
-@@ -27,7 +27,7 @@
- #include "../osdep/strl.c"
- #include "unix-shell.h"
-
--#ifndef HAVE_MACOSX /* macosx doesn't have ftw. hell.. */
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- #include <ftw.h>
- #endif
-
-@@ -58,7 +58,7 @@
- }
- }
-
--#ifndef HAVE_MACOSX
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- static int ftw_func(const char *file, const struct stat *sb, int flag, void *arg) {
- if (flag == UADE_FTW_F) {
- char name[PATH_MAX];
-@@ -88,7 +88,7 @@
- return;
- }
-
--#ifndef HAVE_MACOSX
-+#if !defined(HAVE_MACOSX) && !defined(__FreeBSD__)
- do {
- struct stat st;
- if (!stat(file, &st)) {