aboutsummaryrefslogtreecommitdiff
path: root/audio/vagalume
diff options
context:
space:
mode:
authorBernhard Froehlich <decke@FreeBSD.org>2013-10-18 11:40:34 +0000
committerBernhard Froehlich <decke@FreeBSD.org>2013-10-18 11:40:34 +0000
commite8a8a5500c8d3ede89bc77ca30b28afae68fcaf0 (patch)
treeec5d8ac4c0f76c7a692018cf6f53346a73af506a /audio/vagalume
parent6d8dfd2b6545eef54e3d2a48d30ff8a0d361d184 (diff)
downloadports-e8a8a5500c8d3ede89bc77ca30b28afae68fcaf0.tar.gz
ports-e8a8a5500c8d3ede89bc77ca30b28afae68fcaf0.zip
Notes
Diffstat (limited to 'audio/vagalume')
-rw-r--r--audio/vagalume/Makefile43
-rw-r--r--audio/vagalume/pkg-plist54
2 files changed, 31 insertions, 66 deletions
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
index 239689cca891..d70811eb8e03 100644
--- a/audio/vagalume/Makefile
+++ b/audio/vagalume/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vagalume
PORTVERSION= 0.8.5
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= http://vagalume.igalia.com/files/source/ \
${MASTER_SITE_DEBIAN_POOL}
@@ -12,50 +12,36 @@ MASTER_SITE_SUBDIR= pool/main/v/vagalume/
MAINTAINER= decke@FreeBSD.org
COMMENT= A GTK+-based client for the Last.fm online radio
-LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
- curl:${PORTSDIR}/ftp/curl
+LIB_DEPENDS= libxml2.so:${PORTSDIR}/textproc/libxml2 \
+ libcurl.so:${PORTSDIR}/ftp/curl
GNU_CONFIGURE= yes
-NO_STAGE= yes
-USES= gmake pkgconfig
+USES= gmake pkgconfig desktop-file-utils
USE_GNOME= gtk20
USE_GSTREAMER= good mad gconf
INSTALLS_ICONS= yes
-MAN1= vagalume.1
-
OPTIONS_DEFINE= DBUS TRAY NLS GCONF
OPTIONS_DEFAULT= DBUS TRAY
+OPTIONS_SUB= NLS DBUS
TRAY_DESC= Tray icon and libnotify support
.include <bsd.port.options.mk>
+DBUS_LIB_DEPENDS= libdbus-glib-1.so:${PORTSDIR}/devel/dbus-glib
+DBUS_CONFIGURE_ON= --enable-dbus --enable-im-status
+DBUS_CONFIGURE_OFF= --disable-dbus --disable-im-status
+
+TRAY_BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
+TRAY_LIB_DEPENDS= libnotify.so:${PORTSDIR}/devel/libnotify
+TRAY_CONFIGURE_ENABLE= tray-icon
+
.if ${PORT_OPTIONS:MNLS}
USES+= gettext
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB+= NLS=""
.else
CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MDBUS}
-CONFIGURE_ARGS+=--enable-dbus --enable-im-status
-LIB_DEPENDS+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
-PLIST_SUB+= DBUS=""
-MAN1+= vagalumectl.1
-.else
-CONFIGURE_ARGS+=--disable-dbus --disable-im-status
-PLIST_SUB+= DBUS="@comment "
-.endif
-
-.if ${PORT_OPTIONS:MTRAY}
-CONFIGURE_ARGS+=--enable-tray-icon
-BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
-LIB_DEPENDS+= notify.4:${PORTSDIR}/devel/libnotify
-.else
-CONFIGURE_ARGS+=--disable-tray-icon
.endif
.if ${PORT_OPTIONS:MGCONF}
@@ -71,4 +57,7 @@ post-patch:
${WRKSRC}/Makefile.in
.endif
+post-install:
+ ${CP} ${STAGEDIR}${PREFIX}/share/icons/hicolor/48x48/apps/${PORTNAME}.png ${STAGEDIR}${PREFIX}/share/pixmaps
+
.include <bsd.port.mk>
diff --git a/audio/vagalume/pkg-plist b/audio/vagalume/pkg-plist
index 6bd377140422..99c861992e53 100644
--- a/audio/vagalume/pkg-plist
+++ b/audio/vagalume/pkg-plist
@@ -1,21 +1,11 @@
@comment $FreeBSD$
bin/vagalume
%%DBUS%%bin/vagalumectl
+man/man1/vagalume.1.gz
+%%DBUS%%man/man1/vagalumectl.1.gz
share/applications/vagalume.desktop
%%DBUS%%share/dbus-1/services/vagalume.service
share/icons/hicolor/48x48/apps/vagalume.png
-share/pixmaps/vagalume.xpm
-%%DATADIR%%/cover.png
-%%DATADIR%%/servers.xml
-%%DATADIR%%/icons/hicolor/scalable/apps/accessories-text-editor.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/document-save.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/emblem-favorite.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/list-add.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/mail-message-new.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/media-playback-start.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/media-playback-stop.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/media-skip-forward.svg
-%%DATADIR%%/icons/hicolor/scalable/apps/process-stop.svg
%%NLS%%share/locale/ca/LC_MESSAGES/vagalume.mo
%%NLS%%share/locale/de/LC_MESSAGES/vagalume.mo
%%NLS%%share/locale/es/LC_MESSAGES/vagalume.mo
@@ -28,36 +18,22 @@ share/pixmaps/vagalume.xpm
%%NLS%%share/locale/pt/LC_MESSAGES/vagalume.mo
%%NLS%%share/locale/pt_BR/LC_MESSAGES/vagalume.mo
%%NLS%%share/locale/ru/LC_MESSAGES/vagalume.mo
+share/pixmaps/vagalume.xpm
+share/pixmaps/vagalume.png
+%%DATADIR%%/cover.png
+%%DATADIR%%/icons/hicolor/scalable/apps/accessories-text-editor.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/document-save.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/emblem-favorite.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/list-add.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/mail-message-new.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/media-playback-start.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/media-playback-stop.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/media-skip-forward.svg
+%%DATADIR%%/icons/hicolor/scalable/apps/process-stop.svg
+%%DATADIR%%/servers.xml
@dirrm %%DATADIR%%/icons/hicolor/scalable/apps
@dirrm %%DATADIR%%/icons/hicolor/scalable
@dirrm %%DATADIR%%/icons/hicolor
@dirrm %%DATADIR%%/icons
@dirrm %%DATADIR%%
-@dirrmtry share/icons/hicolor/48x48/apps
-@dirrmtry share/icons/hicolor/48x48
-@dirrmtry share/icons/hicolor
-@dirrmtry share/icons
-%%NLS%%@dirrmtry share/locale/de/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/de
-%%NLS%%@dirrmtry share/locale/es/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/es
-%%NLS%%@dirrmtry share/locale/fi/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/fi
-%%NLS%%@dirrmtry share/locale/fr/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/fr
-%%NLS%%@dirrmtry share/locale/gl/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/gl
-%%NLS%%@dirrmtry share/locale/it/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/it
-%%NLS%%@dirrmtry share/locale/lv/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/lv
-%%NLS%%@dirrmtry share/locale/pl/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pl
-%%NLS%%@dirrmtry share/locale/pt/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pt
-%%NLS%%@dirrmtry share/locale/pt_BR/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/pt_BR
-%%NLS%%@dirrmtry share/locale/ru/LC_MESSAGES
-%%NLS%%@dirrmtry share/locale/ru
-%%NLS%%@dirrmtry share/locale
@dirrmtry share/applications