aboutsummaryrefslogtreecommitdiff
path: root/audio/vagalume
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-29 11:10:29 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-29 11:10:29 +0000
commitf3d395779c599a639d4b3a7b07621bf3fb3b1bca (patch)
treefe14eda07602929865f0f39e9dd7bdd9b997439a /audio/vagalume
parent629fa7807d3034797f55c409fe00f9c2186d0725 (diff)
downloadports-f3d395779c599a639d4b3a7b07621bf3fb3b1bca.tar.gz
ports-f3d395779c599a639d4b3a7b07621bf3fb3b1bca.zip
Notes
Diffstat (limited to 'audio/vagalume')
-rw-r--r--audio/vagalume/Makefile59
-rw-r--r--audio/vagalume/distinfo3
-rw-r--r--audio/vagalume/pkg-descr8
-rw-r--r--audio/vagalume/pkg-plist32
4 files changed, 102 insertions, 0 deletions
diff --git a/audio/vagalume/Makefile b/audio/vagalume/Makefile
new file mode 100644
index 000000000000..17bb5a64947d
--- /dev/null
+++ b/audio/vagalume/Makefile
@@ -0,0 +1,59 @@
+# New ports collection makefile for: vagalume
+# Date created: 2008-06-14
+# Whom: Bernhard Fröhlich <decke@bluelife.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= vagalume
+PORTVERSION= 0.6
+CATEGORIES= audio
+MASTER_SITES= ${MASTER_SITE_DEBIAN_POOL}
+MASTER_SITE_SUBDIR= pool/main/v/vagalume/
+DISTNAME= ${PORTNAME}_${PORTVERSION}.orig
+
+MAINTAINER= decke@bluelife.at
+COMMENT= A GTK+-based client for the Last.fm online radio
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
+ curl.4:${PORTSDIR}/ftp/curl
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}.orig
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= libtool:15
+USE_GETTEXT= yes
+USE_GNOME= pkgconfig gtk20
+USE_GSTREAMER= good mad
+INSTALLS_ICONS= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+MAN1= vagalume.1
+
+OPTIONS= IMSTATUS "Build with IM status support" off \
+ TRAY "Build with tray icon and libnotify support" on
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_IMSTATUS)
+CONFIGURE_ARGS+=--enable-im-status
+LIB_DEPEND+= dbus-glib-1.2:${PORTSDIR}/devel/dbus-glib
+.else
+CONFIGURE_ARGS+=--disable-im-status
+.endif
+
+.if !defined(WITHOUT_TRAY)
+CONFIGURE_ARGS+=--enable-tray-icon
+BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/libnotify.pc:${PORTSDIR}/devel/libnotify
+LIB_DEPENDS+= notify.1:${PORTSDIR}/devel/libnotify
+.else
+CONFIGURE_ARGS+=--disable-tray-icon
+.endif
+
+.if defined(WITH_GNOME)
+USE_GNOME+= gconf2
+CONFIGURE_ARGS+=--enable-gconf
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/audio/vagalume/distinfo b/audio/vagalume/distinfo
new file mode 100644
index 000000000000..303e99018643
--- /dev/null
+++ b/audio/vagalume/distinfo
@@ -0,0 +1,3 @@
+MD5 (vagalume_0.6.orig.tar.gz) = c46e2cc182f7f427196a5bb682f10428
+SHA256 (vagalume_0.6.orig.tar.gz) = bd9b6d1689fc01b186f160ed1f2bb813826a20d4118d525122c446fbf0ab3dd8
+SIZE (vagalume_0.6.orig.tar.gz) = 555331
diff --git a/audio/vagalume/pkg-descr b/audio/vagalume/pkg-descr
new file mode 100644
index 000000000000..46bd7cace09b
--- /dev/null
+++ b/audio/vagalume/pkg-descr
@@ -0,0 +1,8 @@
+Vagalume is an GTK+-based client for the Last.fm online radio.
+
+Although it works in standard PCs, it is specially designed
+to work in the Maemo platform. It has access to virtually all
+the same functions as the official client, including scrobbling,
+tagging, loving, banning etc.
+
+WWW: http://vagalume.igalia.com/
diff --git a/audio/vagalume/pkg-plist b/audio/vagalume/pkg-plist
new file mode 100644
index 000000000000..137ba59b0fc9
--- /dev/null
+++ b/audio/vagalume/pkg-plist
@@ -0,0 +1,32 @@
+bin/vagalume
+share/applications/vagalume.desktop
+share/icons/hicolor/48x48/apps/vagalume.png
+share/locale/de/LC_MESSAGES/vagalume.mo
+share/locale/es/LC_MESSAGES/vagalume.mo
+share/locale/es_MX/LC_MESSAGES/vagalume.mo
+share/locale/fi/LC_MESSAGES/vagalume.mo
+share/locale/gl/LC_MESSAGES/vagalume.mo
+share/locale/it/LC_MESSAGES/vagalume.mo
+share/locale/pt/LC_MESSAGES/vagalume.mo
+share/locale/pt_BR/LC_MESSAGES/vagalume.mo
+share/pixmaps/vagalume.xpm
+%%DATADIR%%/cover.png
+%%DATADIR%%/icons/hicolor/scalable/actions/accessories-text-editor.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/document-save.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/emblem-favorite.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/list-add.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/mail-message-new.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/media-playback-start.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/media-playback-stop.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/media-skip-forward.svg
+%%DATADIR%%/icons/hicolor/scalable/actions/process-stop.svg
+@dirrm %%DATADIR%%/icons/hicolor/scalable/actions
+@dirrm %%DATADIR%%/icons/hicolor/scalable
+@dirrm %%DATADIR%%/icons/hicolor
+@dirrm %%DATADIR%%/icons
+@dirrm %%DATADIR%%
+@dirrmtry share/icons/hicolor/48x48/apps
+@dirrmtry share/icons/hicolor/48x48
+@dirrmtry share/icons/hicolor
+@dirrmtry share/icons
+@dirrmtry share/applications