aboutsummaryrefslogtreecommitdiff
path: root/audio/voipong/Makefile
diff options
context:
space:
mode:
authorMarcelo Araujo <araujo@FreeBSD.org>2009-08-22 02:17:22 +0000
committerMarcelo Araujo <araujo@FreeBSD.org>2009-08-22 02:17:22 +0000
commit0a6ab96fe0ff05b1da98d345c0bbaa99d34a974f (patch)
tree0ba04667437dca5edb338362f39a083216b5f356 /audio/voipong/Makefile
parent02d56add8efdaaa55a0edb93a87d1ad652c54ce0 (diff)
Notes
Diffstat (limited to 'audio/voipong/Makefile')
-rw-r--r--audio/voipong/Makefile31
1 files changed, 14 insertions, 17 deletions
diff --git a/audio/voipong/Makefile b/audio/voipong/Makefile
index 18bd43fc9d89..6d648074eef3 100644
--- a/audio/voipong/Makefile
+++ b/audio/voipong/Makefile
@@ -6,31 +6,28 @@
#
PORTNAME= voipong
-PORTVERSION= 1.1
+PORTVERSION= 2.0
CATEGORIES= audio
MASTER_SITES= http://www.enderunix.org/voipong/
MAINTAINER= siseci@EnderUNIX.org
COMMENT= Detect Voice Over IP calls and dump them to separate wave files
-GNU_CONFIGURE= yes
-
-SUB_FILES= pkg-message
-PLIST_FILES= bin/voipong etc/voipong.conf-dist
-PORTDOCS= AUTHORS INSTALL README THANKS
+USE_LDCONFIG= yes
+PORTDOCS= ALGORITHMS AUTHORS ChangeLog COPYING INSTALL KNOWN_BUGS \
+ LICENSE NEWS README THANKS TODO
post-patch:
- @${REINPLACE_CMD} -e 's|^CFLAGS=""||' ${WRKSRC}/configure
- @${REINPLACE_CMD} -e \
- 's|$${prefix}/share/voipong|${DOCSDIR}|; \
- s|COPYING||; s|LICENSE||' \
- ${WRKSRC}/Makefile.in
-.ifdef NOPORTDOCS
- ${REINPLACE_CMD} '/install-data-am:/s/install-${PORTNAME}dataDATA//' \
- ${WRKSRC}/Makefile.in
-.endif
+ ${MV} ${WRKSRC}/Makefile.bsd ${WRKSRC}/Makefile
post-install:
- @${CAT} ${PKGMESSAGE}
-
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}/users-manual
+ ${INSTALL_DATA} ${WRKSRC}/docs/users-manual/*.html ${DOCSDIR}/users-manual/
+ ${INSTALL_DATA} ${WRKSRC}/docs/users-manual/*.css ${DOCSDIR}/users-manual/
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>