aboutsummaryrefslogtreecommitdiff
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2013-09-28 15:30:08 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2013-09-28 15:30:08 +0000
commitcfd400ebbd64ef35718003d8c5236746bb319c23 (patch)
tree551ebf08b7d2d00ba3ede6fc7cc3446bbb908e74 /audio/vorbis-tools
parentad6e1857a0c879bda495fcb227377c2efce41b09 (diff)
downloadports-cfd400ebbd64ef35718003d8c5236746bb319c23.tar.gz
ports-cfd400ebbd64ef35718003d8c5236746bb319c23.zip
Notes
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile36
-rw-r--r--audio/vorbis-tools/pkg-plist6
2 files changed, 20 insertions, 22 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
index ad5caa7903ea..0487d5feef2e 100644
--- a/audio/vorbis-tools/Makefile
+++ b/audio/vorbis-tools/Makefile
@@ -11,37 +11,29 @@ MASTER_SITES= http://downloads.xiph.org/releases/vorbis/
MAINTAINER= naddy@FreeBSD.org
COMMENT= Play, encode, and manage Ogg Vorbis files
-LIB_DEPENDS= ao.4:${PORTSDIR}/audio/libao \
- curl:${PORTSDIR}/ftp/curl \
- FLAC:${PORTSDIR}/audio/flac \
- kate.4:${PORTSDIR}/multimedia/libkate \
- speex.1:${PORTSDIR}/audio/speex \
- vorbis.4:${PORTSDIR}/audio/libvorbis
-
-USES= pkgconfig
-NO_STAGE= yes
+LIB_DEPENDS= libao.so:${PORTSDIR}/audio/libao \
+ libcurl.so:${PORTSDIR}/ftp/curl \
+ libFLAC.so:${PORTSDIR}/audio/flac \
+ libkate.so:${PORTSDIR}/multimedia/libkate \
+ libspeex.so:${PORTSDIR}/audio/speex \
+ libvorbis.so:${PORTSDIR}/audio/libvorbis
+
+USES= iconv pkgconfig
GNU_CONFIGURE= yes
CONFIGURE_ENV= PTHREAD_CFLAGS="${PTHREAD_CFLAGS}" \
PTHREAD_LIBS="${PTHREAD_LIBS}"
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= NLS
+OPTIONS_SUB= yes
-.if ${PORT_OPTIONS:MNLS}
-USES+= gettext
-PLIST_SUB+= NLS=""
-.else
-USES+= iconv
-CONFIGURE_ARGS+=--disable-nls
-PLIST_SUB+= NLS="@comment "
-.endif
-
-MAN1= ogg123.1 oggdec.1 oggenc.1 ogginfo.1 vcut.1 vorbiscomment.1
+NLS_USES= gettext
+NLS_CONFIGURE_ENABLE= nls
post-install:
- ${MKDIR} ${PREFIX}/share/examples/vorbis-tools
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/examples/vorbis-tools
${INSTALL_DATA} ${WRKSRC}/ogg123/ogg123rc-example \
- ${PREFIX}/share/examples/vorbis-tools/ogg123rc
+ ${STAGEDIR}${PREFIX}/share/examples/vorbis-tools/ogg123rc
.include <bsd.port.mk>
diff --git a/audio/vorbis-tools/pkg-plist b/audio/vorbis-tools/pkg-plist
index 6b8cbf12ed4f..c95d17625645 100644
--- a/audio/vorbis-tools/pkg-plist
+++ b/audio/vorbis-tools/pkg-plist
@@ -5,6 +5,12 @@ bin/oggenc
bin/ogginfo
bin/vcut
bin/vorbiscomment
+man/man1/ogg123.1.gz
+man/man1/oggdec.1.gz
+man/man1/oggenc.1.gz
+man/man1/ogginfo.1.gz
+man/man1/vcut.1.gz
+man/man1/vorbiscomment.1.gz
share/examples/vorbis-tools/ogg123rc
%%NLS%%share/locale/be/LC_MESSAGES/vorbis-tools.mo
%%NLS%%share/locale/cs/LC_MESSAGES/vorbis-tools.mo