aboutsummaryrefslogtreecommitdiff
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authorJames E. Housley <jeh@FreeBSD.org>2001-03-28 14:50:09 +0000
committerJames E. Housley <jeh@FreeBSD.org>2001-03-28 14:50:09 +0000
commitf10057af634cac64d99c642319ff5fbac471ef36 (patch)
tree105bf72cb579d3e75ad4b39fb51727d2ef0e69cd /audio/vorbis-tools
parent11126708d2a683aac47165c4f89ddc80a334e532 (diff)
downloadports-f10057af634cac64d99c642319ff5fbac471ef36.tar.gz
ports-f10057af634cac64d99c642319ff5fbac471ef36.zip
Notes
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/files/patch-ae80
-rw-r--r--audio/vorbis-tools/files/patch-af10
2 files changed, 90 insertions, 0 deletions
diff --git a/audio/vorbis-tools/files/patch-ae b/audio/vorbis-tools/files/patch-ae
new file mode 100644
index 000000000000..1b4b681f78f1
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-ae
@@ -0,0 +1,80 @@
+--- aclocal.m4.orig Mon Feb 26 06:51:03 2001
++++ aclocal.m4 Sat Mar 17 17:06:03 2001
+@@ -222,7 +222,7 @@ AC_ARG_ENABLE(aotest, [ --disable-aotes
+ AO_LIBS="-L$ao_prefix/lib"
+ fi
+
+- AO_LIBS="$AO_LIBS -lao -ldl"
++ AO_LIBS="$AO_LIBS -lao"
+
+ AC_MSG_CHECKING(for ao)
+ no_ao=""
+@@ -292,6 +292,68 @@ int main ()
+ AC_SUBST(AO_LIBS)
+ rm -f conf.aotest
+ ])
++
++dnl Shamelessly stolen from Joerg Schilling's star.
++dnl Copyright 1998 J. Schilling
++
++dnl Checks if mmap() works to get shared memory
++dnl Defines HAVE_SMMAP on success.
++AC_DEFUN(AC_FUNC_SMMAP,
++[AC_CACHE_CHECK([if mmap works to get shared memory], ac_cv_func_smmap,
++ [AC_TRY_RUN([
++#include <sys/types.h>
++#include <sys/mman.h>
++
++char *
++mkshare()
++{
++ int size = 8192;
++ int f;
++ char *addr;
++
++ if ((f = open("/dev/zero", 2)) < 0)
++ exit(1);
++ addr = mmap(0, size, PROT_READ|PROT_WRITE, MAP_SHARED, f, 0);
++ if (addr == (char *)-1)
++ exit(1);
++ close(f);
++
++ return (addr);
++}
++
++main()
++{
++ char *addr;
++
++ addr = mkshare(8192);
++ *addr = 'I';
++
++ switch (fork()) {
++
++ case -1:
++ printf("help\n"); exit(1);
++
++ case 0: /* child */
++ *addr = 'N';
++ _exit(0);
++ break;
++ default: /* parent */
++ wait(0);
++ sleep(1);
++ break;
++ }
++
++ if (*addr != 'N')
++ exit(1);
++ exit(0);
++}
++],
++ [ac_cv_func_smmap=yes],
++ [ac_cv_func_smmap=no],
++ [ac_cv_func_smmap=no])])
++if test $ac_cv_func_smmap = yes; then
++ AC_DEFINE(HAVE_SMMAP)
++fi])
+
+ # Do all the work for Automake. This macro actually does too much --
+ # some checks are only needed if your package does certain things.
diff --git a/audio/vorbis-tools/files/patch-af b/audio/vorbis-tools/files/patch-af
new file mode 100644
index 000000000000..1d17313f4d81
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-af
@@ -0,0 +1,10 @@
+--- ogg123/Makefile.am.orig Sat Mar 17 15:55:09 2001
++++ ogg123/Makefile.am Sat Mar 17 15:55:13 2001
+@@ -5,7 +5,6 @@ AUTOMAKE_OPTIONS = foreign
+ bin_PROGRAMS = ogg123
+ docdir = $(datadir)/doc/$(PACKAGE)-$(VERSION)
+ doc_DATA = ogg123rc-example
+-mandir = $(datadir)/man
+ man_MANS = ogg123.1
+
+ INCLUDES = @OGG_CFLAGS@ @VORBIS_CFLAGS@ @AO_CFLAGS@