aboutsummaryrefslogtreecommitdiff
path: root/audio/vorbis-tools
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-11-02 21:17:27 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-11-02 21:17:27 +0000
commitcace07ca95a538063f74e0c22bf548c9ddf7b845 (patch)
treeb7ccfa7122f8145ebe06fa166b74b813cfaf565a /audio/vorbis-tools
parentb2aa1c9be4d8b1779fa5f76b71531e6668e1bd85 (diff)
downloadports-cace07ca95a538063f74e0c22bf548c9ddf7b845.tar.gz
ports-cace07ca95a538063f74e0c22bf548c9ddf7b845.zip
Notes
Diffstat (limited to 'audio/vorbis-tools')
-rw-r--r--audio/vorbis-tools/Makefile48
-rw-r--r--audio/vorbis-tools/distinfo1
-rw-r--r--audio/vorbis-tools/files/patch-aa12
-rw-r--r--audio/vorbis-tools/files/patch-oggenc_audio_c11
-rw-r--r--audio/vorbis-tools/pkg-comment1
-rw-r--r--audio/vorbis-tools/pkg-descr15
-rw-r--r--audio/vorbis-tools/pkg-plist3
7 files changed, 91 insertions, 0 deletions
diff --git a/audio/vorbis-tools/Makefile b/audio/vorbis-tools/Makefile
new file mode 100644
index 000000000000..1ca246d5bf91
--- /dev/null
+++ b/audio/vorbis-tools/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: vorbis-tools
+# Date created: 18 October 2000
+# Whom: t.vanklaveren@student.utwente.nl
+#
+# $FreeBSD$
+#
+
+PORTNAME= vorbis-tools
+PORTVERSION= 20001018
+CATEGORIES= audio
+MASTER_SITES= http://home.student.utwente.nl/t.vanklaveren/distfiles/
+DISTNAME= vorbis-tools-${PORTVERSION}
+
+MAINTAINER= t.vanklaveren@student.utwente.nl
+
+LIB_DEPENDS= ao.0:${PORTSDIR}/audio/libao \
+ ogg.0:${PORTSDIR}/audio/libogg \
+ vorbis.0:${PORTSDIR}/audio/libvorbis
+
+GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_LIBTOOL= yes
+WRKSRC= ${WRKDIR}/vorbis-tools
+ACLOCAL?= ${LOCALBASE}/bin/aclocal
+AUTOHEADER?= ${LOCALBASE}/bin/autoheader
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ARGS+= --with-ogg=${LOCALBASE} \
+ --with-ao=${LOCALBASE}
+
+MAN1= ogg123.1
+
+post-build:
+# This is probably evil, and should be in a Makefile.
+ cd ${WRKSRC}/oggenc && ${CC} ${CFLAGS} -c getopt1.c
+ cd ${WRKSRC}/ogg123 && ${CC} ${CFLAGS} -c ogg123.c -I${LOCALBASE}/include
+ cd ${WRKSRC}/ogg123 && ${CC} ${LDFLAGS} -o ogg123 ogg123.o ../oggenc/getopt.o ../oggenc/getopt1.o -L${LOCALBASE}/lib -logg -lvorbis -lao -lvorbisfile
+
+post-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/ogg123/ogg123 ${PREFIX}/bin/
+ ${INSTALL_MAN} ${WRKSRC}/ogg123/ogg123.1 ${PREFIX}/man/man1/
+
+post-patch:
+ cd ${WRKSRC} && ${ACLOCAL}
+ cd ${WRKSRC} && ${AUTOHEADER}
+ cd ${WRKSRC} && ${AUTOMAKE} --add-missing
+ cd ${WRKSRC} && ${AUTOCONF}
+
+.include <bsd.port.mk>
diff --git a/audio/vorbis-tools/distinfo b/audio/vorbis-tools/distinfo
new file mode 100644
index 000000000000..4a70a9597183
--- /dev/null
+++ b/audio/vorbis-tools/distinfo
@@ -0,0 +1 @@
+MD5 (vorbis-tools-20001018.tar.gz) = 20d4a7aa7c7598538fbf4cb2771bd45f
diff --git a/audio/vorbis-tools/files/patch-aa b/audio/vorbis-tools/files/patch-aa
new file mode 100644
index 000000000000..aef108c712dc
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-aa
@@ -0,0 +1,12 @@
+--- ogg123/ogg123.c.orig Wed Oct 11 06:19:51 2000
++++ ogg123/ogg123.c Wed Oct 18 23:02:20 2000
+@@ -27,8 +27,8 @@
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <string.h>
+-#include <sys/socket.h> /* !!! */
+ #include <sys/types.h>
++#include <sys/socket.h> /* !!! */
+ #include <unistd.h>
+ #include <netdb.h>
+ #include <netinet/in.h>
diff --git a/audio/vorbis-tools/files/patch-oggenc_audio_c b/audio/vorbis-tools/files/patch-oggenc_audio_c
new file mode 100644
index 000000000000..2b82e78c08ea
--- /dev/null
+++ b/audio/vorbis-tools/files/patch-oggenc_audio_c
@@ -0,0 +1,11 @@
+--- oggenc/audio.c.orig Wed Sep 6 17:57:46 2000
++++ oggenc/audio.c Thu Nov 2 12:42:46 2000
+@@ -14,7 +14,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <sys/types.h>
+-#include <malloc.h>
++#include <stdlib.h>
+ #include "audio.h"
+
+ #define WAV_HEADER_SIZE 44
diff --git a/audio/vorbis-tools/pkg-comment b/audio/vorbis-tools/pkg-comment
new file mode 100644
index 000000000000..67aab61bde73
--- /dev/null
+++ b/audio/vorbis-tools/pkg-comment
@@ -0,0 +1 @@
+MP3-comparable audio compression codec library
diff --git a/audio/vorbis-tools/pkg-descr b/audio/vorbis-tools/pkg-descr
new file mode 100644
index 000000000000..b4046279575f
--- /dev/null
+++ b/audio/vorbis-tools/pkg-descr
@@ -0,0 +1,15 @@
+Vorbis is a general-purpose audio and music encoding format contemporary to
+MPEG-4's AAC and TwinVQ, the next generation beyond MPEG audio layer 3. Unlike
+the MPEG sponsored formats (and other proprietary formats such as RealAudio G2
+and Windows' flavor of the month), the Vorbis CODEC specification belongs to
+the public domain. All the technical details are published and documented, and
+any software entity may make full use of the format without royalty or patent
+concerns.
+
+This package contains utilities to encode and decode vorbis streams, and to
+add comments to them.
+
+WWW: http://www.vorbis.com
+
+- Theo van Klaveren
+t.vanklaveren@student.utwente.nl
diff --git a/audio/vorbis-tools/pkg-plist b/audio/vorbis-tools/pkg-plist
new file mode 100644
index 000000000000..6af826e73739
--- /dev/null
+++ b/audio/vorbis-tools/pkg-plist
@@ -0,0 +1,3 @@
+bin/ogg123
+bin/oggenc
+bin/vorbiscomment