aboutsummaryrefslogtreecommitdiff
path: root/audio/wavbreaker/Makefile
diff options
context:
space:
mode:
authorMax Khon <fjoe@FreeBSD.org>2003-06-02 14:42:57 +0000
committerMax Khon <fjoe@FreeBSD.org>2003-06-02 14:42:57 +0000
commit821952899a781af604dae4c4e619869314c46bb7 (patch)
tree8e87602b732cd045ee26f2c391474c024ae0952e /audio/wavbreaker/Makefile
parent253ceff3b3547f3269f308859c6f33b778570084 (diff)
downloadports-821952899a781af604dae4c4e619869314c46bb7.tar.gz
ports-821952899a781af604dae4c4e619869314c46bb7.zip
Notes
Diffstat (limited to 'audio/wavbreaker/Makefile')
-rw-r--r--audio/wavbreaker/Makefile26
1 files changed, 26 insertions, 0 deletions
diff --git a/audio/wavbreaker/Makefile b/audio/wavbreaker/Makefile
new file mode 100644
index 000000000000..33085d333f21
--- /dev/null
+++ b/audio/wavbreaker/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: wavbreaker
+# Date created: 20 May 2003
+# Whom: Kirill Ponomarew <ponomarew@oberon.net>
+#
+# $FreeBSD$
+
+PORTNAME= wavbreaker
+PORTVERSION= 0.2
+CATEGORIES= audio
+MASTER_SITES= http://huli.org/wavbreaker/
+
+MAINTAINER= ponomarew@oberon.net
+COMMENT= Tool to split wav files
+
+USE_GNOME= gtk20 gnomehack
+USE_GMAKE= yes
+USE_REINPLACE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=
+CONFIGURE_ARGS+=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/configure
+
+.include <bsd.port.mk>