aboutsummaryrefslogtreecommitdiff
path: root/audio/wavpack/Makefile
diff options
context:
space:
mode:
authorJeremy Messenger <mezz@FreeBSD.org>2007-01-03 02:19:22 +0000
committerJeremy Messenger <mezz@FreeBSD.org>2007-01-03 02:19:22 +0000
commit004280ba11aff30043710ac112eccd78c5ba5c4f (patch)
treeb42f2c6a9538f027f1afb1c516fd55a839115010 /audio/wavpack/Makefile
parentb8f166a70df5dfbed8bd737f395add6bd31582fb (diff)
downloadports-004280ba11aff30043710ac112eccd78c5ba5c4f.tar.gz
ports-004280ba11aff30043710ac112eccd78c5ba5c4f.zip
Notes
Diffstat (limited to 'audio/wavpack/Makefile')
-rw-r--r--audio/wavpack/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/audio/wavpack/Makefile b/audio/wavpack/Makefile
index 13e261aebf1f..14ec53eb248f 100644
--- a/audio/wavpack/Makefile
+++ b/audio/wavpack/Makefile
@@ -6,21 +6,23 @@
#
PORTNAME= wavpack
-PORTVERSION= 4.32
+PORTVERSION= 4.40.0
CATEGORIES= audio
MASTER_SITES= http://www.wavpack.com/
MAINTAINER= multimedia@FreeBSD.org
COMMENT= Compress (and restore) both 16 and 24-bit audio files in .wav format
-GNU_CONFIGURE= yes
-USE_ICONV= yes
USE_BZIP2= yes
+USE_GNOME= gnomehack gnometarget pkgconfig
+USE_ICONV= yes
+USE_DOS2UNIX= cli/*.[ch] include/*.h src/*.[ch]
+USE_LDCONFIG= yes
+GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-USE_GNOME= gnomehack gnometarget
-INSTALLS_SHLIB= yes
-FILES= wavpack.h unpack3.c words.c md5.c
+
+FILES= include/wavpack.h src/unpack3.c src/words.c cli/md5.c
post-patch:
.for i in ${FILES}