aboutsummaryrefslogtreecommitdiff
path: root/audio/wavpack
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2009-01-12 15:32:41 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2009-01-12 15:32:41 +0000
commitc817bd6c333e8b245cba02ee5f3c8a4b47d9836a (patch)
treeb26bb57e15d61ee280cf6799289d6845e3563216 /audio/wavpack
parentd482a3c700b7c5d618a604fa3877b49b0ff15483 (diff)
downloadports-c817bd6c333e8b245cba02ee5f3c8a4b47d9836a.tar.gz
ports-c817bd6c333e8b245cba02ee5f3c8a4b47d9836a.zip
Notes
Diffstat (limited to 'audio/wavpack')
-rw-r--r--audio/wavpack/Makefile13
-rw-r--r--audio/wavpack/distinfo6
-rw-r--r--audio/wavpack/files/patch-wavpack.c22
-rw-r--r--audio/wavpack/files/patch-wvunpack.c20
4 files changed, 5 insertions, 56 deletions
diff --git a/audio/wavpack/Makefile b/audio/wavpack/Makefile
index a15d4b6ec8de..227a44e9dc35 100644
--- a/audio/wavpack/Makefile
+++ b/audio/wavpack/Makefile
@@ -6,28 +6,19 @@
#
PORTNAME= wavpack
-PORTVERSION= 4.41.0
+PORTVERSION= 4.50.1
CATEGORIES= audio
MASTER_SITES= http://www.wavpack.com/
MAINTAINER= multimedia@FreeBSD.org
-COMMENT= Compress (and restore) both 16 and 24-bit audio files in .wav format
+COMMENT= Audio codec for lossless, lossy and hybrid compression
USE_BZIP2= yes
USE_GNOME= gnomehack gnometarget pkgconfig
USE_ICONV= yes
-USE_DOS2UNIX= cli/*.[ch] include/*.h src/*.[ch]
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
-FILES= include/wavpack.h src/unpack3.c src/words.c cli/md5.c
-
-post-patch:
-.for i in ${FILES}
- @cd ${WRKSRC} && ${CP} ${i} ${i}.orig && \
- col < ${i}.orig > ${i}
-.endfor
-
.include <bsd.port.mk>
diff --git a/audio/wavpack/distinfo b/audio/wavpack/distinfo
index ecc4e60c1919..53f834a2b8b3 100644
--- a/audio/wavpack/distinfo
+++ b/audio/wavpack/distinfo
@@ -1,3 +1,3 @@
-MD5 (wavpack-4.41.0.tar.bz2) = 6a13edeae437498db78fe528d9e95144
-SHA256 (wavpack-4.41.0.tar.bz2) = 7a40748e07a18f86438eb79ebbb0b6e321d0374f683c6cad91f04c5251e7203c
-SIZE (wavpack-4.41.0.tar.bz2) = 329241
+MD5 (wavpack-4.50.1.tar.bz2) = 2c9d7e3672f60070d4fd2c86c924a3b4
+SHA256 (wavpack-4.50.1.tar.bz2) = 29c036d10fb8bcb6daa58718d112394291887fc0e9b108851017218184483954
+SIZE (wavpack-4.50.1.tar.bz2) = 375792
diff --git a/audio/wavpack/files/patch-wavpack.c b/audio/wavpack/files/patch-wavpack.c
deleted file mode 100644
index 5a9a166ea527..000000000000
--- a/audio/wavpack/files/patch-wavpack.c
+++ /dev/null
@@ -1,22 +0,0 @@
-
-$FreeBSD$
-
---- cli/wavpack.c.orig
-+++ cli/wavpack.c
-@@ -1604,6 +1604,7 @@
- MultiByteToWideChar (CP_ACP, 0, string, -1, temp, max_chars + 1);
- WideCharToUTF8 (temp, (uchar *) string, len);
- #else
-+ iconv_t converter;
- char *temp = malloc (len);
- char *outp = temp;
- char *inp = string;
-@@ -1614,7 +1615,7 @@
-
- memset(temp, 0, len);
- old_locale = setlocale (LC_CTYPE, "");
-- iconv_t converter = iconv_open ("UTF-8", "");
-+ converter = iconv_open ("UTF-8", "");
- err = iconv (converter, &inp, &insize, &outp, &outsize);
- iconv_close (converter);
- setlocale (LC_CTYPE, old_locale);
diff --git a/audio/wavpack/files/patch-wvunpack.c b/audio/wavpack/files/patch-wvunpack.c
deleted file mode 100644
index 950e59c5c2e5..000000000000
--- a/audio/wavpack/files/patch-wvunpack.c
+++ /dev/null
@@ -1,20 +0,0 @@
---- cli/wvunpack.c.orig Thu Apr 6 05:48:33 2006
-+++ cli/wvunpack.c Mon May 15 03:42:14 2006
-@@ -1374,6 +1374,8 @@
- static void UTF8ToAnsi (char *string, int len)
- {
- int max_chars = (int) strlen (string);
-+
-+ iconv_t converter;
- #if defined (WIN32)
- unsigned short *temp = malloc ((max_chars + 1) * 2);
- int act_chars = UTF8ToWideChar (string, temp);
-@@ -1400,7 +1402,7 @@
-
- memset(temp, 0, len);
- old_locale = setlocale (LC_CTYPE, "");
-- iconv_t converter = iconv_open ("", "UTF-8");
-+ converter = iconv_open ("", "UTF-8");
- err = iconv (converter, &inp, &insize, &outp, &outsize);
- iconv_close (converter);
- setlocale (LC_CTYPE, old_locale);